Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
anything I try to emerge fails. *** glibc detected ***
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
chrisduck
Apprentice
Apprentice


Joined: 30 Jun 2004
Posts: 283
Location: California

PostPosted: Sun Apr 16, 2006 8:09 pm    Post subject: anything I try to emerge fails. *** glibc detected *** Reply with quote

hi

no matter what I try to emerge, it almost always fails with the same error.

example:
Code:
make[1]: Entering directory `/var/tmp/portage/libcap-1.10-r5/work/libcap-1.10/libcap'
mkdir -p -m 0755 /var/tmp/portage/libcap-1.10-r5/image//usr/include/sys
install -m 0644 include/sys/capability.h /var/tmp/portage/libcap-1.10-r5/image//usr/include/sys
*** glibc detected *** double free or corruption (out): 0x080d8ca8 ***
make[1]: *** [install] Aborted
make[1]: Leaving directory `/var/tmp/portage/libcap-1.10-r5/work/libcap-1.10/libcap'
make: *** [install] Error 2

!!! ERROR: sys-libs/libcap-1.10-r5 failed.
Call stack:
  ebuild.sh, line 1532:   Called dyn_install
  ebuild.sh, line 1005:   Called src_install
  libcap-1.10-r5.ebuild, line 50:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.


just replace the package name with any other package that you can think of. That is the error that I get each time.

What do I need to do so that I may start emerging packages again?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9275

PostPosted: Sun Apr 16, 2006 8:24 pm    Post subject: Reply with quote

Read this, try the suggested fix, post on succes or failure.
Back to top
View user's profile Send private message
chrisduck
Apprentice
Apprentice


Joined: 30 Jun 2004
Posts: 283
Location: California

PostPosted: Mon Apr 17, 2006 3:04 am    Post subject: Reply with quote

desultory,

thanks.

'export MALLOC_CHECK_=0' solved the problem. If I want to set it back to 3, then I guess I'll have to try re-emerging glibc.
Oh well, thanks for your help!
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Mon Apr 17, 2006 10:43 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads in favour of the thread desultory linked to above.
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum