Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Messed up portage?? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
janosh
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jul 2004
Posts: 80
Location: Oslo, Norway

PostPosted: Mon Apr 17, 2006 6:25 pm    Post subject: Messed up portage?? [SOLVED] Reply with quote

I tried to remove a couple of old packages today, but I think I broke something, and now a lot of packages I try to emerge fails to build with this message:
Code:
/usr/include/GL/gl.h:2140:22: GL/glext.h: No such file or directory


I've figured out I'm probably missing a library. But i don't know what to emerge to get this library back.
I tried to use the revdep-rebuild, but it fails with the message I printed above.
My guess is that portage thinks one of my libs is installed when in fact it isn't.

Any help anyone?

--
Jonarne


Last edited by janosh on Mon Apr 17, 2006 8:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
kabage
Guru
Guru


Joined: 31 Jan 2005
Posts: 340

PostPosted: Mon Apr 17, 2006 7:16 pm    Post subject: I believe Reply with quote

Those are mesa libs , but can be related to your drm (if using one)
So try emerging mesa, maybe proprietary (ati, nvidia glx ) if using those.

That should restore files and links to sanity.
_________________
The solutions are easy. Its finding them that is hard.
Back to top
View user's profile Send private message
Ferdinando
Veteran
Veteran


Joined: 25 Nov 2003
Posts: 1027
Location: Gaeta (LT) - Italy

PostPosted: Mon Apr 17, 2006 7:18 pm    Post subject: Reply with quote

It seems the same as in this thread: reemerge eselect-opengl.

Bye
_________________
La risposta, non la devi cercare fuori, la devi cercare dentro di te: e però è SBAGLIATA!
-- Corrado Guzzanti, "Pippo Chennedy Show", 1997
Back to top
View user's profile Send private message
janosh
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jul 2004
Posts: 80
Location: Oslo, Norway

PostPosted: Mon Apr 17, 2006 8:23 pm    Post subject: Reply with quote

That worked. Thanks to both of you...

--
Jonarne
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Tue Apr 18, 2006 3:46 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

Solution in thread Ferdinando posted.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum