Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub question: Linux first, then installed Windows
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
mopmop
n00b
n00b


Joined: 20 May 2004
Posts: 71
Location: Oslo, Norway

PostPosted: Fri Apr 21, 2006 4:12 pm    Post subject: Grub question: Linux first, then installed Windows Reply with quote

I've just installed Windows on my gentoo box.

The linux partitions are on a SATA disk (sda) and the /boot partition is sda1
I installed windows on another hard drive (hda) in hda1. It is toggled bootable

I was quite astonished when grub came up after installing windows, and tried to run:
rootnoverify (hd1,0)
chainloader +1

but then it just hung, nothing happened.

After entering linux and verifying that grub was setup correctly (according to a bunch of sites on the web on dual booting), I tried again. But still no luck, nothing happens.

Windows does start, however, when I insert the install cd and boot from it. It then asks me if I want to boot from it, I say no, and windows starts. I guess its "windows" who asks, as my MB never was this polite.

I've tried to google around for this, but all I get is "dont install linux first". And thats a tad late.

Anyway, I've just installed it to play Warcraft with a friend, so I cant be bothered by moving my partitions around.

I guess there might not be a solution to this, so my question is really: Why is this impossible? (or so darn difficult)
:?
Back to top
View user's profile Send private message
mopmop
n00b
n00b


Joined: 20 May 2004
Posts: 71
Location: Oslo, Norway

PostPosted: Fri Apr 21, 2006 4:19 pm    Post subject: Reply with quote

Whops, I'll try the map (hd ..... thing from the first topic in the forum ... :oops:
Back to top
View user's profile Send private message
mopmop
n00b
n00b


Joined: 20 May 2004
Posts: 71
Location: Oslo, Norway

PostPosted: Fri Apr 21, 2006 4:22 pm    Post subject: Reply with quote

... And that worked. Sorry about this. :D
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Sat Apr 22, 2006 4:34 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Duplicate Threads, please follow up to this topic: Grub Error Collection [Part 5] [POST GRUB QUESTIONS HERE!].
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum