Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Need help with utf-8, deadkeys w/ mac keyboard
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1609
Location: U.S.A.

PostPosted: Mon Apr 24, 2006 4:34 pm    Post subject: Need help with utf-8, deadkeys w/ mac keyboard Reply with quote

I've got gentoo (manual config), xorg-x11, and KDE installed and running nicely (straight stable branch). I set up with utf-8, which seems to be working fine (I can see utf8 web pages and test files, except for what I take to be some things unsupported by my current font choices).

However, after looking through quite a few posts, faqs, howto's, etc., I am at a loss how to correctly set up my machine to make use of deadkeys. I'd appreciate any help anyone can offer.

I have a PowerMac G4 500 AGP with stock keyboard. This physically has 97 keys, is labeled on the back as "Apple USB Keyboard" and "Model M2452", and is soft-identified as an "Alps Electronic Apple USB Keyboard". This is the standard keyboard for PowerMacs (circa 1999-2000 timeframe).

Excerpts from some config files -- I've marked the items I think I could use advice on with (?)
(although I don't know what I don't know):

In /etc/rc.conf:
Code:

...
UNICODE="yes"
...


In /etc/conf.d/consolefont:
Code:

...
CONSOLEFONT="default8x16"            #(?)
CONSOLETRANSLATION="8859-1_to_uni"     #(?)
...


In /etc/conf.d/keymaps:
Code:

...
KEYMAP="us"                                    #(?)
SET_WINDOWKEYS="no"                             #(?)
EXTENDED_KEYMAPS=""                              #(?)
DUMPKEYS_CHARSET="iso-8859-1"              #(?)
...


In /etc/X11/xorg.conf:
Code:

...
Section "Files"                                     #(?)
...
# (Although I emerged additional "unicode-aware" fonts (the corefonts and freefonts packages), I wasn't sure if I
# needed to list them here and did not. I currently have only the fonts as they were set up by Xorgautoconfig.)
...
EndSection
...
Section "InputDevice"
  Identifer     "Alps Electronic Apple USB Keyboard"
  Driver        "kbd"
  Option        "XkbModel"          "pc_105"              #(?)
  Option        "XkbLayout"         "en_us"                #(?)
  Option        "XkbOptions"        "compose:rwin"    #(?)
  #Option      "XkbVariant"        "nodeadkeys"       #(?)
EndSection
...


Of course, I don't know what things I may not have configured at all. Thanks for any advice/assistance.
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Mon Apr 24, 2006 9:34 pm    Post subject: Re: Need help with utf-8, deadkeys w/ mac keyboard Reply with quote

For /etc/X11/xorg.conf I think I would use the following:
Code:

...
Section "Files"                                     
...
# (Although I emerged additional "unicode-aware" fonts (the corefonts and freefonts packages), I wasn't sure if I
# needed to list them here and did not. I currently have only the fonts as they were set up by Xorgautoconfig.)
...
EndSection
...
Section "InputDevice"
  Identifer     "Alps Electronic Apple USB Keyboard"
  Driver        "kbd"
  Option        "XkbModel"          "pc_104"  #that's what I use for my iMac G4             
  Option        "XkbLayout"         "us_intl"                #Should give you dead keys if I am not mistaken.
#  Option        "XkbOptions"        "compose:rwin"    #Don't think this is useful
#Option      "XkbVariant"        "nodeadkeys"       #Don't think this is useful either
EndSection
...

I am not sure what to use for the console.
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1609
Location: U.S.A.

PostPosted: Sat May 13, 2006 1:46 am    Post subject: Reply with quote

Thanks.

When I use us_intl I'm unable to make normal use of the apostrophe. For example, instead of "I'm" (with apostrophe between the I and the m), I get I with an accent over the m.

I've also played around with the KDE package called "kdexkb", which is a gui to define and switch between xkbd configurations. While the configuration and switching seems to work fine, I'm still not able to make use of the keyboard deadkeys.

Since this is not an essential feature for me, I've given up for the time being, but would still be interested in any advice.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat May 13, 2006 3:06 pm    Post subject: Reply with quote

Follow the ' up with a space instead of the m, you'll get the apostrophe instead of the accented m
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Bones McCracker
Veteran
Veteran


Joined: 14 Mar 2006
Posts: 1609
Location: U.S.A.

PostPosted: Sun May 14, 2006 12:24 am    Post subject: Reply with quote

Ah, okay! That's what I needed to know.

Is this stuff written down anywhere, so I can figure out how to use the keymap? How do I go about learning how to make use of it, for example, to apply various accents to characters or type certain characters? As an example of how ignorant I am about this -- I activated the us_intl keyboard but have no idea how to toggle the deadkeys (I assume there's a key I can press (or hold) that toggles certain keys from their "normal" character to an "international" one).

Thanks for the tip!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum