Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PEAR, php, opengroupware, blocked packages
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
GenTimJS
Guru
Guru


Joined: 03 May 2003
Posts: 406
Location: NH, USA

PostPosted: Mon Apr 24, 2006 8:09 pm    Post subject: PEAR, php, opengroupware, blocked packages Reply with quote

What Ive Got:
Gentoo install
manually downloaded and untarred egroupware (latest version, not in portage)
everything fine except when I run egroupware's check tool it complains that it doesnt have something called "PEAR" which it seems to want to sync with ical (the whole point of my wanting to install it, kinda mandatory feature)

Asside from not knowing what PEAR components I need to fill this requirement, when I try to emerge any of them I get this:

Code:
localhost dev-php # emerge -pv PEAR-HTML_Common

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B     ] dev-php/mod_php (is blocking dev-lang/php-5.1.2)
[blocks B     ] dev-php/php (is blocking dev-lang/php-5.1.2)
[blocks B     ] dev-php/mod_php (is blocking dev-php/PEAR-PEAR-1.4.8)
[blocks B     ] dev-php/php (is blocking dev-php/PEAR-PEAR-1.4.8)
[ebuild  N    ] app-admin/php-toolkit-1.0-r2  0 kB
[ebuild  N    ] net-www/gentoo-webroot-default-0.2  -no-htdocs 64 kB
[ebuild  N    ] dev-libs/apr-0.9.7  +ipv6 -urandom 1,020 kB
[ebuild  N    ] dev-libs/apr-util-0.9.7  +berkdb +gdbm +ldap 724 kB
[ebuild     U ] net-www/apache-2.0.55-r1 [2.0.52-r1] +apache2 -debug -doc +ldap -mpm-leader -mpm-peruser -mpm-prefork -mpm-threadpool -mpm-worker -no-suexec (-selinux) +ssl -static-modules +threads 4,684 kB
[ebuild  N    ] dev-lang/php-5.1.2  -adabas -apache +apache2 -bcmath +berkdb -birdstep +bzip2 -calendar -cdb +cgi -cjk -cli +crypt -ctype +curl -curlwrappers -db2 -dba -dbase -dbmaker -debug -discard-path -doc -empress -empress-bcs -esoob -exif -fastbuild -fdftk -filepro -firebird -flatfile -force-cgi-redirect -frontbase -ftp +gd -gd-external +gdbm +gmp -hardenedphp -hash -hyperwave-api -iconv +imap -informix -inifile -interbase -iodbc +ipv6 -java-external +kerberos +ldap -libedit -mcve -memlimit +mhash -ming -msql -mssql +mysql -mysqli +ncurses +nls -oci8 -oci8-instant-client -odbc -pcntl +pcre -pdo -pdo-external -pic +posix -postgres -qdbm +readline -recode -reflection -sapdb -sasl -session -sharedext -sharedmem -simplexml -snmp -soap -sockets -solid +spell -spl -sqlite +ssl -sybase -sybase-ct -sysvipc +threads -tidy -tokenizer -truetype -vm-goto -vm-switch -wddx -xml -xmlreader -xmlrpc -xmlwriter -xpm -xsl -yaz -zip +zlib 6,178 kB
[ebuild  N    ] dev-php/PEAR-PEAR-1.4.8  323 kB
[ebuild  N    ] dev-php/PEAR-HTML_Common-1.2.2  4 kB


This server already has some php stuff going with apache, I'd rather not uninstall mod_php since IIRC last time I tried to do this and use non-mod-php all the php stuff with apache got busted and nolonger worked.

Advice?
Whats the "normal" thing to do about this?
_________________
-Tim Smith
Back to top
View user's profile Send private message
dgaffuri
Advocate
Advocate


Joined: 05 Jun 2005
Posts: 2078
Location: Italy

PostPosted: Mon Apr 24, 2006 8:24 pm    Post subject: Reply with quote

I'm afraid you have to upgrade
Gentoo Weekly Newsletter: 17 April 2006 wrote:
Old-style PHP packages vanishing

The PHP Herd announces that the old-style PHP packages, which were unsupported and deprecated for months, are finally going away. After months of work, the team considers the new dev-lang/php package and the related dev-php[4,5]/ categories fully ready for production use, and encourage all users to upgrade. Helpful informations can be found at the PHP project's pages, along with a HOWTO regarding the migration to dev-lang/php. The old-style PHP packages (dev-php/php, dev-php/php-cgi, dev-php/mod_php, dev-php/PECL-*, and older dev-php/PEAR-* packages) will be package.masked on Wednesday, 19 April 2006, and removed from the Portage tree about a month later.

Code:
# emerge -pv mod_php

These are the packages that would be merged, in order:

Calculating dependencies
!!! All ebuilds that could satisfy "mod_php" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-php/mod_php-4.3.11-r3 (masked by: package.mask)
# Luca Longinotti <chtekk@gentoo.org> (22 Apr 2006)
# Mask the old-style PHP packages as announced in
# http://marc.theaimsgroup.com/?l=gentoo-dev&m=114523997621139&w=2
# Please migrate to dev-lang/php ASAP, since the old-style PHP
# packages contain several security issues, HOWTO available at
# http://www.gentoo.org/proj/en/php/php-upgrading.xml

- dev-php/mod_php-4.3.11-r1 (masked by: package.mask)
- dev-php/mod_php-4.3.11-r4 (masked by: package.mask)
- dev-php/mod_php-4.4.0 (masked by: package.mask)
- dev-php/mod_php-4.3.11 (masked by: package.mask)
- dev-php/mod_php-4.4.0-r8 (masked by: package.mask)
- dev-php/mod_php-4.4.0-r9 (masked by: package.mask)
- dev-php/mod_php-4.4.0-r6 (masked by: package.mask)
- dev-php/mod_php-4.4.0-r7 (masked by: package.mask)
- dev-php/mod_php-4.4.0-r1 (masked by: package.mask, ~x86 keyword)
- dev-php/mod_php-4.4.0-r2 (masked by: package.mask)
- dev-php/mod_php-4.4.0-r3 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.

You may want to look at the upgrade guide for help.
_________________
Adopt an unanswered post
If you feel that your problem has been solved please edit the top post and add [solved] to the subject
Back to top
View user's profile Send private message
tomk
Bodhisattva
Bodhisattva


Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Mon Apr 24, 2006 8:29 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic: Upgrading PHP on Gentoo.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum