Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] MousePad on G4 12" iBook doesn't work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Jointy
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2005
Posts: 142
Location: Saarbrücken

PostPosted: Thu May 04, 2006 6:06 pm    Post subject: [solved] MousePad on G4 12" iBook doesn't work Reply with quote

Hy...

The MousePad et Touchpad in front of the keyboard isn't avalible in Gnome....

^^what entry is exactly needed for the xorg.conf ???


Here I have give you an overview of the system.....
Code:

ibook ~ # cat /proc/bus/input/devices I: Bus=0017 Vendor=0001 Product=0001 Version=0100 N: Name="Macintosh mouse button emulation" P: Phys= S: Sysfs=/class/input/input0 H: Handlers=mouse0 ts0 B: EV=7 B: KEY=70000 0 0 0 0 0 0 0 0 B: REL=3  I: Bus=0017 Vendor=0001 Product=22c4 Version=0200 N: Name="ADB keyboard"
P: Phys=adb2:2.c4/input
S: Sysfs=/class/input/input1
H: Handlers=kbd
B: EV=120003
B: KEY=feb0ffdf 3cfffff ffffffff fffffffe
B: LED=7

I: Bus=0017 Vendor=0001 Product=771f Version=0100
N: Name="ADB Powerbook buttons"
P: Phys=adb7:7.1f/input
S: Sysfs=/class/input/input2
H: Handlers=kbd
B: EV=100003
B: KEY=7b 0 2 0 e0000 0 0 0

I: Bus=0003 Vendor=05ac Product=1000 Version=1965
N: Name="HID 05ac:1000"
P: Phys=usb-0001:10:1a.0-1/input0
S: Sysfs=/class/input/input3
H: Handlers=kbd
B: EV=120003
B: KEY=e080ffdf 1cfffff ffffffff fffffffe
B: LED=1f

I: Bus=0003 Vendor=05ac Product=1000 Version=1965
N: Name="HID 05ac:1000"
P: Phys=usb-0001:10:1a.0-1/input1
S: Sysfs=/class/input/input4
H: Handlers=mouse1 ts1
B: EV=7
B: KEY=1f0000 0 0 0 0 0 0 0 0
B: REL=3

I: Bus=0003 Vendor=046d Product=c016 Version=0340
N: Name="Logitech Optical USB Mouse"
P: Phys=usb-0001:10:1b.0-1/input0
S: Sysfs=/class/input/input5
H: Handlers=mouse2 ts2
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103

I: Bus=0017 Vendor=001f Product=0001 Version=0100
N: Name="PowerMac Beep"
P: Phys=powermac/beep
S: Sysfs=/class/input/input6
H: Handlers=kbd
B: EV=40001
B: SND=6





Code:

Using PowerMac machine description
Total memory = 512MB; using 1024kB for hash table (at cff00000)
Linux version 2.6.17-rc3 (root@ibook) (gcc-Version 3.4.5 (Gentoo 3.4.5-r1, ssp-3.4.5-1.0, pie-8.7.9)) #1 Wed May 3 14:32:48 CEST 2006
Found UniNorth memory controller & host bridge @ 0xf8000000 revision: 0xd2
Mapped at 0xfdfc0000
Found a Intrepid mac-io controller, rev: 0, mapped at 0xfdf40000
Processor NAP mode on idle enabled.
PowerMac motherboard: iBook G4
via-pmu: Server Mode is disabled
PMU driver v2 initialized for Core99, firmware: 0c
Found UniNorth PCI host bridge at 0xf0000000. Firmware bus number: 0->0
Found UniNorth PCI host bridge at 0xf2000000. Firmware bus number: 0->0
Found UniNorth PCI host bridge at 0xf4000000. Firmware bus number: 0->0
nvram: Checking bank 0...
nvram: gen0=130, gen1=131
nvram: Active bank is: 1
nvram: OF partition at 0x410
nvram: XP partition at 0x1020
nvram: NR partition at 0x1120
Top of RAM: 0x20000000, Total RAM: 0x20000000
Memory hole size: 0MB
On node 0 totalpages: 131072
  DMA zone: 131072 pages, LIFO batch:31
Built 1 zonelists
Kernel command line: ro video=radeonfb:1024x768
mpic: Setting up MPIC " MPIC 1   " version 1.2 at 80040000, max 4 CPUs
mpic: ISU size: 64, shift: 6, mask: 3f
mpic: Initializing for 64 sources
PID hash table entries: 4096 (order: 12, 16384 bytes)
GMT Delta read from XPRAM: 0 minutes, DST: off
time_init: decrementer frequency = 18.432000 MHz
time_init: processor frequency   = 1333.333330 MHz
Console: colour dummy device 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 513792k/524288k available (3772k kernel code, 9992k reserved, 344k data, 169k bss, 184k init)
Calibrating delay loop... 36.73 BogoMIPS (lpj=73472)
Mount-cache hash table entries: 512
device-tree: Duplicate name in /cpus/PowerPC,G4@0, renamed to "l2-cache#1"
NET: Registered protocol family 16
KeyWest i2c @0xf8001003 irq 42 /uni-n@f8000000/i2c@f8001000
 channel 1 bus /uni-n@f8000000/i2c@f8001000/i2c-bus@1
KeyWest i2c @0x80018000 irq 26 /pci@f2000000/mac-io@17/i2c@18000
 channel 0 bus /pci@f2000000/mac-io@17/i2c@18000/i2c-bus@0
PMU i2c /pci@f2000000/mac-io@17/via-pmu@16000/pmu-i2c
 channel 1 bus <multibus>
 channel 2 bus <multibus>
PCI: Probing PCI hardware
PCI: Cannot allocate resource region 0 of device 0001:10:18.0
PCI: Cannot allocate resource region 0 of device 0001:10:19.0
Apple USB OHCI 0001:10:18.0 disabled by firmware
Apple USB OHCI 0001:10:19.0 disabled by firmware
SCSI subsystem initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
Bluetooth: Core ver 2.8
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Thermal assist unit not available
initcall at 0xc03879a8: TAU_init+0x0/0x104(): returned with error code 1
Registering PowerMac CPU frequency driver
Low: 666 Mhz, High: 1333 Mhz, Boot: 666 Mhz
audit: initializing netlink socket (disabled)
audit(1146764945.116:1): initialized
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered (default)
io scheduler deadline registered
io scheduler cfq registered
PCI: Enabling device 0000:00:10.0 (0006 -> 0007)
radeonfb (0000:00:10.0): Invalid ROM signature 0 should be 0xaa55
radeonfb: Retrieved PLL infos from Open Firmware
radeonfb: Reference=27.00 MHz (RefDiv=12) Memory=183.00 Mhz, System=210.00 MHz
radeonfb: PLL min 12000 max 35000
radeonfb: Monitor 1 type LCD found
radeonfb: EDID probed
radeonfb: Monitor 2 type no found
radeonfb: Using Firmware dividers 0x00020074 from PPLL 0
radeonfb: Dynamic Clock Power Management enabled
Console: switching to colour frame buffer device 128x48
Registered "mnca" backlight controller,level: 15/15
radeonfb (0000:00:10.0): ATI Radeon NV
Generic RTC Driver v1.07
Macintosh non-volatile memory driver v1.1
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected Apple UniNorth 2 chipset
agpgart: configuring for size idx: 4
agpgart: AGP aperture is 16M @ 0x0
[drm] Initialized drm 1.0.1 20051102
[drm] Initialized radeon 1.24.0 20060225 on minor 0
pmac_zilog: 0.6 (Benjamin Herrenschmidt <benh@kernel.crashing.org>)
ttyS0 at MMIO 0x80013020 (irq = 22) is a Z85c30 ESCC - Serial port
ttyS1 at MMIO 0x80013000 (irq = 23) is a Z85c30 ESCC - Serial port
RAMDISK driver initialized: 8 RAM disks of 8192K size 1024 blocksize
loop: loaded (max 8 devices)
sungem.c:v0.98 8/24/03 David S. Miller (davem@redhat.com)
PHY ID: 4061e4, addr: 0
eth0: Sun GEM (PCI) 10/100/1000BaseT Ethernet 00:11:24:d7:41:42
eth0: Found BCM5221 PHY
MacIO PCI driver attached to Intrepid chipset
input: Macintosh mouse button emulation as /class/input/input0
adb: starting probe task...
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PCI: Enabling device 0002:20:0d.0 (0000 -> 0002)
adb devices: [2]: 2 c4 [7]: 7 1f
ADB keyboard at 2, handler 1
Detected ADB keyboard, type ISO, swapping keys.
input: ADB keyboard as /class/input/input1
input: ADB Powerbook buttons as /class/input/input2
adb: finished probe task...
ide0: Found Apple UniNorth ATA-6 controller, bus ID 3, irq 39
Probing IDE interface ide0...
hda: TOSHIBA MK4025GAS, ATA DISK drive
hda: Enabling Ultra DMA 5
ide0 at 0xe102a000-0xe102a007,0xe102a160 on irq 39
eth0: Link is up at 100 Mbps, full-duplex.
ide1: Found Apple KeyLargo ATA-3 controller, bus ID 0, irq 24
Probing IDE interface ide1...
hdc: MATSHITACD-RW CW-8124, ATAPI CD/DVD-ROM drive
hdc: Enabling MultiWord DMA 2
ide1 at 0xe1024000-0xe1024007,0xe1024160 on irq 24
hda: max request size: 512KiB
hda: 78140160 sectors (40007 MB), CHS=16383/255/63, UDMA(100)
hda: cache flushes supported
 hda: [mac] hda1 hda2 hda3 hda4
hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache, (U)DMA
Uniform CD-ROM driver Revision: 3.20
PCI: Enabling device 0002:20:0e.0 (0000 -> 0002)
ohci1394: fw-host0: OHCI-1394 1.1 (PCI): IRQ=[40]  MMIO=[f5000000-f50007ff]  Max Packet=[2048]  IR/IT contexts=[8/8]
video1394: Installed video1394 module
ieee1394: raw1394: /dev/raw1394 device initialized
ieee1394: sbp2: Driver forced to serialize I/O (serialize_io=1)
ieee1394: sbp2: Try serialize_io=0 for better performance
usbmon: debugfs is not available
PCI: Enabling device 0001:10:1b.2 (0004 -> 0006)
ehci_hcd 0001:10:1b.2: EHCI Host Controller
ehci_hcd 0001:10:1b.2: new USB bus registered, assigned bus number 1
ehci_hcd 0001:10:1b.2: irq 63, io mem 0x80080000
ehci_hcd 0001:10:1b.2: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 5 ports detected
ohci_hcd: 2005 April 22 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
Apple USB OHCI 0001:10:18.0 disabled by firmware
Apple USB OHCI 0001:10:19.0 disabled by firmware
PCI: Enabling device 0001:10:1a.0 (0000 -> 0002)
ohci_hcd 0001:10:1a.0: OHCI Host Controller
ohci_hcd 0001:10:1a.0: new USB bus registered, assigned bus number 2
ohci_hcd 0001:10:1a.0: irq 29, io mem 0x80083000
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
PCI: Enabling device 0001:10:1b.0 (0000 -> 0002)
ohci_hcd 0001:10:1b.0: OHCI Host Controller
ohci_hcd 0001:10:1b.0: new USB bus registered, assigned bus number 3
ohci_hcd 0001:10:1b.0: irq 63, io mem 0x80082000
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 3 ports detected
PCI: Enabling device 0001:10:1b.1 (0000 -> 0002)
ohci_hcd 0001:10:1b.1: OHCI Host Controller
ohci_hcd 0001:10:1b.1: new USB bus registered, assigned bus number 4
ohci_hcd 0001:10:1b.1: irq 63, io mem 0x80081000
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 2 ports detected
usb 2-1: new full speed USB device using ohci_hcd and address 2
usb 2-1: configuration #1 chosen from 1 choice
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[001124fffed74142]
usb 2-2: new full speed USB device using ohci_hcd and address 3
usb 2-2: configuration #1 chosen from 1 choice
usbcore: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
Initializing USB Mass Storage driver...
usb 4-1: new full speed USB device using ohci_hcd and address 2
usb 4-1: configuration #1 chosen from 1 choice
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04A9 pid 0x108D
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usb 3-1: new low speed USB device using ohci_hcd and address 2
usb 3-1: configuration #1 chosen from 1 choice
input: HID 05ac:1000 as /class/input/input3
input: USB HID v1.11 Keyboard [HID 05ac:1000] on usb-0001:10:1a.0-1
input: HID 05ac:1000 as /class/input/input4
input: USB HID v1.11 Mouse [HID 05ac:1000] on usb-0001:10:1a.0-1
HID device not claimed by input or hiddev
input: Logitech Optical USB Mouse as /class/input/input5
input: USB HID v1.10 Mouse [Logitech Optical USB Mouse] on usb-0001:10:1b.0-1
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
mice: PS/2 mouse device common for all mice
device-mapper: 4.6.0-ioctl (2006-02-17) initialised: dm-devel@redhat.com
NET: Registered protocol family 2
IP route cache hash table entries: 16384 (order: 4, 65536 bytes)
TCP established hash table entries: 65536 (order: 6, 262144 bytes)
TCP bind hash table entries: 32768 (order: 5, 131072 bytes)
TCP: Hash tables configured (established 65536 bind 32768)
TCP reno registered
IPv4 over IPv4 tunneling driver
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
ReiserFS: hda4: found reiserfs format "3.6" with standard journal
ReiserFS: hda4: using ordered data mode
ReiserFS: hda4: journal params: device hda4, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: hda4: checking transaction log (hda4)
ReiserFS: hda4: replayed 11 transactions in 1 seconds
ReiserFS: hda4: Using r5 hash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Freeing unused kernel memory: 184k init
ts: Compaq touchscreen protocol output
Adding 1048568k swap on /dev/hda3.  Priority:-1 extents:1 across:1048568k
i2c /dev entries driver
PowerMac i2c bus pmu 2 registered
PowerMac i2c bus pmu 1 registered
PowerMac i2c bus mac-io 0 registered
PowerMac i2c bus uni-n 1 registered
input: PowerMac Beep as /class/input/input6
ieee80211_crypt: registered algorithm 'NULL'
ieee80211: 802.11 data/management/control stack, git-1.1.7
ieee80211: Copyright (C) 2004-2005 Intel Corporation <jketreno@linux.intel.com>
bcm43xx driver
PCI: Enabling device 0001:10:12.0 (0004 -> 0006)
bcm43xx: Chip ID 0x4318, rev 0x2
bcm43xx: Number of cores: 4
bcm43xx: Core 0: ID 0x800, rev 0xd, vendor 0x4243, enabled
bcm43xx: Core 1: ID 0x812, rev 0x9, vendor 0x4243, disabled
bcm43xx: Core 2: ID 0x804, rev 0xc, vendor 0x4243, enabled
bcm43xx: Core 3: ID 0x80d, rev 0x7, vendor 0x4243, enabled
bcm43xx: PHY connected
bcm43xx: Detected PHY: Version: 3, Type 2, Revision 7
bcm43xx: Detected Radio: ID: 8205017f (Manuf: 17f Ver: 2050 Rev: 8)
bcm43xx: Radio turned off
bcm43xx: Radio turned off
eth0: Link is up at 100 Mbps, full-duplex.
eth0: Pause is disabled
bcm43xx: set security called
bcm43xx:    .level = 0
bcm43xx:    .enabled = 0
bcm43xx:    .encrypt = 0
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Associate: failed to initiate scan. Is device up?
bcm43xx: PHY connected
bcm43xx: Radio turned on
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1485:bcm43xx_find_lopair()
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1485:bcm43xx_find_lopair()
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1485:bcm43xx_find_lopair()
bcm43xx: Chip initialized
bcm43xx: DMA initialized
bcm43xx: 80211 cores initialized
bcm43xx: Keys cleared
bcm43xx: ASSERTION FAILED (radio_attenuation < 10) at: drivers/net/wireless/bcm43xx/bcm43xx_phy.c:1485:bcm43xx_find_lopair()
bcm43xx: set security called
bcm43xx:    .level = 0
bcm43xx:    .enabled = 0
bcm43xx:    .encrypt = 0
bcm43xx: set security called
bcm43xx:    .level = 0
bcm43xx:    .enabled = 0
bcm43xx:    .encrypt = 0
bcm43xx: set security called
bcm43xx:    .level = 0
bcm43xx:    .enabled = 0
bcm43xx:    .encrypt = 0
bcm43xx: set security called
bcm43xx:    .level = 0
bcm43xx:    .enabled = 0
bcm43xx:    .encrypt = 0
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Unable to find matching network after scan!
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
SoftMAC: Start scanning with channel: 1
SoftMAC: Scanning 14 channels
SoftMAC: Scanning finished
bcm43xx: Radio turned off
bcm43xx: DMA 0x0200 (RX) max used slots: 1/64
bcm43xx: DMA 0x0260 (TX) max used slots: 0/512
bcm43xx: DMA 0x0240 (TX) max used slots: 0/512
bcm43xx: DMA 0x0220 (TX) max used slots: 1/512
bcm43xx: DMA 0x0200 (TX) max used slots: 0/512
ip_tables: (C) 2000-2006 Netfilter Core Team
ip_conntrack version 2.4 (4096 buckets, 32768 max) - 192 bytes per conntrack
hdc: packet command error: status=0x51 { DriveReady SeekComplete Error }
hdc: packet command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
ide: failed opcode was: unknown
hdc: Enabling MultiWord DMA 2


_________________
[Host: Arko]
ASUS G1S
http://gentoo-wiki.com/HARDWARE_Asus_G1S
[Host: Pandora]
PIII 1Ghz (133) / 512MB
1x40GB & 60GB (mdRAID1)
Hardened Stage 1 Server
[Host: Plato]
verkauft (OpenSuse 11.0)


Last edited by Jointy on Sat May 06, 2006 5:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
Valkura
Apprentice
Apprentice


Joined: 27 Feb 2006
Posts: 242
Location: Ramsey, MN

PostPosted: Fri May 05, 2006 7:25 pm    Post subject: Reply with quote

I believe that the xorg.conf looks the same as with any other mouse (if I remember correctly). Is the module loaded? I think it is appletouch. (If it doesn't modprobe, check the kernel config.) (Unless iBooks use a different driver from Powerbooks...)
_________________
last.fm
SFH, because it's awesome
Back to top
View user's profile Send private message
Jointy
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2005
Posts: 142
Location: Saarbrücken

PostPosted: Sat May 06, 2006 7:24 am    Post subject: Reply with quote

Hy...

the appletouch module is compiled into the kernel....

^^and I have test some different mouse configurations, but no one works :(
_________________
[Host: Arko]
ASUS G1S
http://gentoo-wiki.com/HARDWARE_Asus_G1S
[Host: Pandora]
PIII 1Ghz (133) / 512MB
1x40GB & 60GB (mdRAID1)
Hardened Stage 1 Server
[Host: Plato]
verkauft (OpenSuse 11.0)
Back to top
View user's profile Send private message
Valkura
Apprentice
Apprentice


Joined: 27 Feb 2006
Posts: 242
Location: Ramsey, MN

PostPosted: Sat May 06, 2006 7:54 am    Post subject: Reply with quote

Hmm....

Well, I guess you should check to make sure you edited the right Xorg. Sometimes you have one in /etc AND one in /etc/X11. That gave me problems.

Otherwise, I had problems when I was booting into the wrong kernel. If you have multiple kernels on your machine (like I did - friend gave me his to see if things worked better), that can cause many problems.

Sorry I couldn't be of more help. Good luck!
_________________
last.fm
SFH, because it's awesome
Back to top
View user's profile Send private message
Jointy
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2005
Posts: 142
Location: Saarbrücken

PostPosted: Sat May 06, 2006 5:59 pm    Post subject: Reply with quote

YEAH !!!

It works.....

1. Compile the Apple USB Touch module with [*] into the kernel
Code:

Symbol: USB_APPLETOUCH [=y]                                                     │
  │ Prompt: Apple USB Touchpad support                                              │
  │   Defined at drivers/usb/input/Kconfig:310                                      │
  │   Depends on: USB && INPUT                                                      │
  │   Location:                                                                     │
  │     -> Device Drivers                                                           │
  │       -> USB support         


2. Then edit the /etc/X11/xorg.conf

Code:

Section "ServerLayout"
        Identifier      "X.Org Configured"
        Screen          0  "Screen0" 0 0
        InputDevice     "Mouse0" "CorePointer"
#       InputDevice     "Synaptics Touchpad" "CorePointer"
        InputDevice     "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Protocol"              "ImPS/2"
#       Option          "ZAxisMapping"          "4 5 6 7"
#       Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/input/mouse0"
EndSection


Now it works for me :D
_________________
[Host: Arko]
ASUS G1S
http://gentoo-wiki.com/HARDWARE_Asus_G1S
[Host: Pandora]
PIII 1Ghz (133) / 512MB
1x40GB & 60GB (mdRAID1)
Hardened Stage 1 Server
[Host: Plato]
verkauft (OpenSuse 11.0)
Back to top
View user's profile Send private message
Valkura
Apprentice
Apprentice


Joined: 27 Feb 2006
Posts: 242
Location: Ramsey, MN

PostPosted: Sat May 06, 2006 11:21 pm    Post subject: Reply with quote

Good to see you got it working! I am curious - which setting change made it work? Was it in the kernel as a module before and did that cause you problems, or was it the xorg.conf? (I want to know :D)
_________________
last.fm
SFH, because it's awesome
Back to top
View user's profile Send private message
Jointy
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2005
Posts: 142
Location: Saarbrücken

PostPosted: Sun May 07, 2006 2:57 pm    Post subject: Reply with quote

The problem was that I have added the module to the kernel but didn't make
Code:

cp vmlinuz /boot/linux-2.6.17-vanilla-rc3
ybin -


so i had build the new kernel but don't itegrate them to the system :)

^^shit happens....

After a reboot I used the debian tool "mdetect-0.5.2"
Code:

./mdetect -v -x


After that I restarted my Xorg and it works.
But the absolutly thing that I had added this conf times befor and it didn't worked ;(

^^I think the xorg need this module.....

So that was the story from the mousepad.

regard
Jointy
_________________
[Host: Arko]
ASUS G1S
http://gentoo-wiki.com/HARDWARE_Asus_G1S
[Host: Pandora]
PIII 1Ghz (133) / 512MB
1x40GB & 60GB (mdRAID1)
Hardened Stage 1 Server
[Host: Plato]
verkauft (OpenSuse 11.0)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum