Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Air port extreme dont works(close)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
g0su
Guru
Guru


Joined: 14 May 2003
Posts: 437
Location: Dresden, Deutschland

PostPosted: Sat May 13, 2006 12:30 am    Post subject: Air port extreme dont works(close) Reply with quote

Hello, i have one powerbook 12" 6'8 and i can't work.

Code:

HightTemplar ~ # whoami
root
HightTemplar ~ # lsmod
Module                  Size  Used by
bcm43xx               434900  0
sungem                 34436  0
sungem_phy              9888  1 sungem
HightTemplar ~ # iwconfig
+lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11b/g  ESSID:off/any  Nickname:"Broadcom 4306"
          Mode:Managed  Access Point: Invalid   Bit Rate=1 Mb/s
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

HightTemplar ~ # ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:11:24:90:D2:BC
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:52 Base address:0xc000

HightTemplar ~ #HightTemplar ~ # iwconfig eth1 essid Templario
HightTemplar ~ # iwconfig eth1
eth1      IEEE 802.11b/g  ESSID:"Templario"  Nickname:"Broadcom 4306"
          Mode:Managed  Access Point: Invalid   Bit Rate=1 Mb/s
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

HightTemplar ~ #



But:

Code:
HightTemplar ~ # dmesg | tail -n25
eth0: Link is up at 100 Mbps, full-duplex.
eth0: Pause is disabled
bcm43xx driver
bcm43xx: Chip ID 0x4306, rev 0x3
bcm43xx: Number of cores: 5
bcm43xx: Core 0: ID 0x800, rev 0x4, vendor 0x4243, enabled
bcm43xx: Core 1: ID 0x812, rev 0x5, vendor 0x4243, disabled
bcm43xx: Core 2: ID 0x80d, rev 0x2, vendor 0x4243, enabled
bcm43xx: Core 3: ID 0x807, rev 0x2, vendor 0x4243, disabled
bcm43xx: Core 4: ID 0x804, rev 0x9, vendor 0x4243, enabled
bcm43xx: PHY connected
bcm43xx: Detected PHY: Version: 2, Type 2, Revision 2
bcm43xx: Detected Radio: ID: 2205017f (Manuf: 17f Ver: 2050 Rev: 2)
bcm43xx: Radio turned off
bcm43xx: Radio turned off
bcm43xx: PHY connected
bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Associate: failed to initiate scan. Is device up?
bcm43xx: PHY connected
bcm43xx: Error: Microcode "bcm43xx_microcode5.fw" not available or load failed.
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Associate: failed to initiate scan. Is device up?
SoftMAC: Associate: Scanning for networks first.
SoftMAC: Associate: failed to initiate scan. Is device up?



My kernel config:
Code:
<*>   Generic IEEE 802.11 Networking Stack                           │ │
  │ │[*]     Enable full debugging output                                 │ │
  │ │<*>     IEEE 802.11 WEP encryption (802.1x)                          │ │
  │ │<*>     IEEE 802.11i CCMP support                                    │ │
  │ │<*>     IEEE 802.11i TKIP encryption                                 │ │
  │ │<*>     Software MAC add-on to the IEEE 802.11 networking stack      │ │
  │ │[*]       Enable full debugging output

<M>   Broadcom BCM43xx wireless support                              │ │
  │ │[*]     Broadcom BCM43xx debugging (RECOMMENDED)                     │ │
  │ │        BCM43xx data transfer mode (DMA + PIO)  --->                 │ │
  │ └───────────────────────────────────────────────────


Thx!
_________________
Busco desarrollador con complejo de proxy, interesados MP


Last edited by g0su on Sat May 13, 2006 12:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sat May 13, 2006 1:47 am    Post subject: Reply with quote

Please read the topic:
https://forums.gentoo.org/viewtopic-t-409194.html

You do not have the firmware for the bcm43xx driver.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
g0su
Guru
Guru


Joined: 14 May 2003
Posts: 437
Location: Dresden, Deutschland

PostPosted: Sat May 13, 2006 12:01 pm    Post subject: Reply with quote

Hi! JoseXL sorry, i am stupid, i dont read the option of firmware, i was looking this howto https://forums.gentoo.org/viewtopic-t-460178.html becouse is in spanish and my english is too bad.

I see your post but it dont works(i think becouse i dont understand well the english):

Code:
HightTemplar airport # rc-status | grep hot  hotplug                                                             [ started ]HightTemplar airport # bcm43xx-fwcutter -w /lib/firmware /mnt/macox/System/Library/Extensions/AppleAirPort2.kext/Contents/MacOS/AppleAirPort2
bcm43xx-fwcutter can cut the firmware out of /mnt/macox/System/Library/Extensions/AppleAirPort2.kext/Contents/MacOS/AppleAirPort2

  filename :  AppleAirPort2
  version  :  3.90.34.0.p16 (404.2)
  MD5      :  7200d1aef5f413ebc811046d068b40dc

WARNING! This firmware doesn't include support for 802.11a cards.
WARNING! Use this firmware only for 802.11b/g cards.

extracting bcm43xx_microcode2.fw ...
/lib/firmware/bcm43xx_microcode2.fw: No such file or directory
HightTemplar airport #


I use the wl_apsta.o:

Code:
HightTemplar airport # wget http://openwrt.inf.fh-brs.de/~nbd/wl_apsta.o
--13:37:54--  http://openwrt.inf.fh-brs.de/~nbd/wl_apsta.o
           => `wl_apsta.o'
Resolviendo openwrt.inf.fh-brs.de... 194.95.66.65
Connecting to openwrt.inf.fh-brs.de|194.95.66.65|:80... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 652,866 (638K) [application/x-object]

100%[====================================>] 652,866      104.10K/s    ETA 00:00

13:38:01 (101.51 KB/s) - `wl_apsta.o' saved [652866/652866]

HightTemplar airport # mkdir /lib/firmware
HightTemplar airport # bcm43xx-fwcutter -w /lib/firmware/ wl_apsta.o
bcm43xx-fwcutter can cut the firmware out of wl_apsta.o

  filename :  wl_apsta.o
  version  :  3.130.20.0
  MD5      :  e08665c5c5b66beb9c3b2dd54aa80cb3

extracting bcm43xx_microcode2.fw ...
extracting bcm43xx_microcode4.fw ...
extracting bcm43xx_microcode5.fw ...
extracting bcm43xx_microcode11.fw ...
extracting bcm43xx_pcm4.fw ...
extracting bcm43xx_pcm5.fw ...
extracting bcm43xx_initval01.fw ...
extracting bcm43xx_initval02.fw ...
extracting bcm43xx_initval03.fw ...
extracting bcm43xx_initval04.fw ...
extracting bcm43xx_initval05.fw ...
extracting bcm43xx_initval06.fw ...
extracting bcm43xx_initval07.fw ...
extracting bcm43xx_initval08.fw ...
extracting bcm43xx_initval09.fw ...
extracting bcm43xx_initval10.fw ...
HightTemplar airport #


I think than is bcm43xx-fwcutter and not fwcutter, no?:

Quote:
Following the directions in the README, I select a file. For example, I'll choose this one because it's a recent release and I can download it direct.
Código:
wget http://openwrt.inf.fh-brs.de/~nbd/wl_apsta.o


I then use fwcutter on it as it says in the howto:
Código:
fwcutter wl_apsta.o


I then install the firmware as is says in the howto:
Código:
make installfw


I up the connection:
Code:
HightTemplar firmware # ifconfig eth1 up
HightTemplar firmware # iwconfig eth1 essid Templario
HightTemplar firmware # iwconfig eth1
eth1      IEEE 802.11b/g  ESSID:"Templario"  Nickname:"Broadcom 4306"
          Mode:Managed  Frequency=2.437 GHz  Access Point: 00:13:10:92:AF:71
          Bit Rate=11 Mb/s   Tx-Power=15 dBm
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality=100/100  Signal level=2/3  Noise level=187/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

HightTemplar firmware # dhcpcd eth1
eth1      Link encap:Ethernet  HWaddr 00:11:24:90:D2:BC
          inet addr:192.168.1.104  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:212 errors:0 dropped:9 overruns:0 frame:0
          TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:14225 (13.8 Kb)  TX bytes:8246 (8.0 Kb)
          Interrupt:52

HightTemplar firmware #


And it don't works in start but latter works:

Code:
HightTemplar firmware # ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.104 icmp_seq=1 Destination Host Unreachable
From 192.168.1.104 icmp_seq=2 Destination Host Unreachable
From 192.168.1.104 icmp_seq=3 Destination Host Unreachable
From 192.168.1.104 icmp_seq=5 Destination Host Unreachable
From 192.168.1.104 icmp_seq=6 Destination Host Unreachable
From 192.168.1.104 icmp_seq=7 Destination Host Unreachable
64 bytes from 192.168.1.1: icmp_seq=8 ttl=64 time=13.4 ms
64 bytes from 192.168.1.1: icmp_seq=9 ttl=64 time=4.04 ms
64 bytes from 192.168.1.1: icmp_seq=10 ttl=64 time=4.07 ms
64 bytes from 192.168.1.1: icmp_seq=11 ttl=64 time=4.90 ms
64 bytes from 192.168.1.1: icmp_seq=12 ttl=64 time=4.92 ms
64 bytes from 192.168.1.1: icmp_seq=13 ttl=64 time=3.54 ms
64 bytes from 192.168.1.1: icmp_seq=14 ttl=64 time=3.42 ms

--- 192.168.1.1 ping statistics ---
14 packets transmitted, 7 received, +6 errors, 50% packet loss, time 13026ms
rtt min/avg/max/mdev = 3.424/5.477/13.426/3.291 ms, pipe 3
HightTemplar firmware #


Thx for and sorry for lost your time :( [/bug]
_________________
Busco desarrollador con complejo de proxy, interesados MP
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sat May 13, 2006 2:27 pm    Post subject: Reply with quote

It's okay, I'm glad it's working. The thread is very old, so some of the early directions are not up to date (fwcutter vs. bcm43xx-fwcutter), but it looks like you got it working so everything is okay. :)
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum