Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Spanish keyboard on Powerbook G4 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
luispa
Guru
Guru


Joined: 17 Mar 2006
Posts: 357
Location: España

PostPosted: Sun May 14, 2006 8:50 am    Post subject: Spanish keyboard on Powerbook G4 [SOLVED] Reply with quote

Hi, this is another topic on a recurrent problem, as I've seen in the forums. I've tried to find an answer to my problem without success.

I have a PowerBook G4 17" (PowerBook5,7) with spanish keyboard. I've installed Gentoo and:

Can't get keys that are tipically gotten with ALT in MacOSX: \|@#¢∞¬÷“”≠´‚][{}µ„…–

Taking just one of the most used as an "the pipe (|)", I get it on MacOSX with ALT-1. The problem is that under Gentoo the ALT key is not acting as expected (AltGr in normal PCs), and I've tried the .xmodmap trick without success.

Any spanish coleague out there?

Thanks a lot,

Luis


Last edited by luispa on Fri May 26, 2006 11:05 am; edited 2 times in total
Back to top
View user's profile Send private message
skormel
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2004
Posts: 122
Location: España

PostPosted: Mon May 15, 2006 8:53 am    Post subject: Reply with quote

1º -- Change to the /usr/share/keymaps/i386/qwerty directory
cd /usr/share/keymaps/i386/qwerty

2º -- Convert to root
su

3º -- descompress the es.map.gz keyboard laylout.
gunzip es.map.gz

4º -- use showkeys to get the altgr code, 125 in my case.
showkeys

5º -- edit es.map and add the correct keycode
nano -w es.map
add the string keycode 125 = AltGr

6º -- Compress es.map to es.map.gz
gzip es.map

7º -- reload de es.map keyboard layout
loadkeys es.map

That's All.
_________________
Los moteros duros no mueren, ¡¡van al infierno!!
----------------------
AM2 4.2Ghz, 2Gb DDR2-667,M2N-SLI Deluxe, 250+400Gb SATA2, 6800GT PCI-E , Audigy.
Powerbook 12" G4@1.5Ghz
Macbook pro 17" 2.13Ghz
Via Epia@550Mhz
.... .....
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon May 15, 2006 3:34 pm    Post subject: Reply with quote

Isn't Fn+Alt = AltGr in most layouts? Try that.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
luispa
Guru
Guru


Joined: 17 Mar 2006
Posts: 357
Location: España

PostPosted: Thu May 25, 2006 12:53 pm    Post subject: Reply with quote

skormel wrote:
1º -- ...
[...]

That's All.


Skormel,

Thank you very much (Muchas Gracias!!) for your help. It works very well.

Do you have a similar solution for XWindow?. I guess I have to do something under /etc/X11/xkb/keycodes/xfree86, but maybe you have it done already.

JoseJX wrote:

Isn't Fn+Alt = AltGr in most layouts? Try that.
That's All.


JoseJX, thanks for the tip, however it doesn't work in my PB G4 with Spanish keyboard.

Luis
Back to top
View user's profile Send private message
skormel
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2004
Posts: 122
Location: España

PostPosted: Fri May 26, 2006 9:37 am    Post subject: Reply with quote

I've got a similar problem, on my powerbook 1.5Ghz, the keys @#\ doesn't work on X but withot X it works perfect.
_________________
Los moteros duros no mueren, ¡¡van al infierno!!
----------------------
AM2 4.2Ghz, 2Gb DDR2-667,M2N-SLI Deluxe, 250+400Gb SATA2, 6800GT PCI-E , Audigy.
Powerbook 12" G4@1.5Ghz
Macbook pro 17" 2.13Ghz
Via Epia@550Mhz
.... .....
Back to top
View user's profile Send private message
luispa
Guru
Guru


Joined: 17 Mar 2006
Posts: 357
Location: España

PostPosted: Fri May 26, 2006 11:03 am    Post subject: Reply with quote

At last!. I've got both console and X working in Spanish.
Thanks to all that helped.


Console

Problem:
- 'backslash' and '< >' keys are swapped.
- AltGR key doesn't exists so side-effect: can't get the following keys: \|@#~ {} []

Solution:
Assign an apple key (in my case left apple) as AltGR, which is done by modifying the keymap file.

Code:

   - cd /usr/share/keymaps/i386/qwerty
   - cp es.map.gz es-mac-pbg4.map.gz
   - gunzip es-mac-pbg4.map.gz
   - edit es-mac-pbg4.map and fix to reflect the following:

     keycode  41 = less greater
        alt     keycode  41 = Meta_less
        shift alt keycode 41 = Meta_bar
     keycode  86 = masculine ordfeminine backslash
        control keycode  86 = nul
        alt     keycode  86 = Meta_grave
     keycode 125 = AltGr

   - gzip es-mac-pbg4.map
   - Modify /etc/conf.d/keymaps to start using the new keymap

     # nano -w /etc/conf.d/keymaps
     [..]

     KEYMAP="-u es-mac-pbg4"

     [..]




X-Window

Problem:
- 'backslash' and '< >' keys are swapped.
- AltGR key doesn't exists so side-effect: can't get the following keys: \|@#~ {} []

Solution: Assign an apple key (left) as AltGR and modify some keys, which is done by modifying the xkb xfree86 file

Note: I do NOT modify my xorg.conf. I just leave it as it was created by the Xorgautoconfig program as described in http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml#xorg

Code:

:
Section "InputDevice"
        Identifier      "Keyboard0"
        Driver          "kbd"
# Change "XkbModel" to "macintosh_old" if you are using
# the deprecated adb keycodes.
        Option          "XkbModel"      "pc105"
        Option          "XkbLayout"     "es"
        Option          "XkbOptions"    "compose:rwin"
### Uncomment this if your layout uses nodeadkeys
        #Option         "XkbVariant"    "nodeadkeys"
EndSection
:


I do modify ONLY this file /etc/X11/xkb/keycodes/xfree86 and here you
can find the modifications I've done.

Code:

 # diff -u xfree86 xfree86.mac-ok-spanish
--- xfree86     2006-05-26 12:47:14.000000000 +0200
+++ xfree86.mac-ok-spanish      2006-05-26 12:47:05.000000000 +0200
@@ -12,7 +12,8 @@
 default xkb_keycodes "xfree86" {
     include "xfree86(basic)"
     <BKSL> =  51;
-    <LSGT> =  94;
+    <TLDE> =  94;
+    <LSGT> =  49;
 };

 xkb_keycodes "basic" {
@@ -80,11 +81,11 @@
     <LCTL> =  37;
     <SPCE> =  65;
     <RCTL> = 109;
-    <RALT> = 113;
+    <RALT> = 115;
     // Microsoft keyboard extra keys
-    <LWIN> = 115;
-    <RWIN> = 116;
-    <MENU> = 117;
+    //<LWIN> = 115;
+    //<RWIN> = 116;
+    //<MENU> = 117;

     <ESC>  =   9;
     <FK01> =  67;


Here is how you can ask X to activate your recent modifications to that file, without going out and in of X.

Code:

luis@mybox ~ $ setxkbmap -layout es -rules xorg -model pc105


Thanks again to all that helped.

Luis
Back to top
View user's profile Send private message
skormel
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jun 2004
Posts: 122
Location: España

PostPosted: Fri May 26, 2006 2:12 pm    Post subject: Reply with quote

It works great, thanks Luis!!!!!!!
_________________
Los moteros duros no mueren, ¡¡van al infierno!!
----------------------
AM2 4.2Ghz, 2Gb DDR2-667,M2N-SLI Deluxe, 250+400Gb SATA2, 6800GT PCI-E , Audigy.
Powerbook 12" G4@1.5Ghz
Macbook pro 17" 2.13Ghz
Via Epia@550Mhz
.... .....
Back to top
View user's profile Send private message
HoLzPLatTeN
n00b
n00b


Joined: 11 Feb 2005
Posts: 57
Location: The middle of nowhere

PostPosted: Tue Jul 18, 2006 2:38 pm    Post subject: Reply with quote

I was a lot of time with my spanish keyboard properly configured, but after last update, everything went to the hell. With the same configuration (the one which you have posted), I can't type accented keys or the euro symbol.

After two days trying to solve it... I am thinking of migrating to another distro, less flexible but much more reliable :cry:
_________________
Unanswered posts
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum