Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Initramfs non generation problem!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
cholguin
n00b
n00b


Joined: 17 May 2006
Posts: 5
Location: Dominican Republic

PostPosted: Wed May 17, 2006 2:21 am    Post subject: Initramfs non generation problem!! Reply with quote

I am going through Step 7e of the Gentoo Handbook for the 2006.0, i used Genkernel to compile my kernel on a Powerbook Titanium G4 867mhz 15" Ati Radeon, and when i go to code listing 22 after compliling the kernel:

Code Listing 22: Checking the created kernel image name and initrd

# ls /boot/kernel* /boot/initramfs*


This is what i get:

ls: /boot/initramfs*: No such file or directory
/boot/kernel-genkernel-ppc-2.6.15-gentoo-r5 /boot/kernelz-2.6.15-gentoo-r5


From what i understand the Genkernel is not generating the initramfs that i will later need for the yaboot installation.

Help please i am drowning. :(

God bless.
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Wed May 17, 2006 2:38 am    Post subject: Reply with quote

What was the command you gave for genkernel?
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
cholguin
n00b
n00b


Joined: 17 May 2006
Posts: 5
Location: Dominican Republic

PostPosted: Wed May 17, 2006 8:12 pm    Post subject: Reply with quote

# genkernel --genzimage all
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Thu May 18, 2006 5:00 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Gentoo on PPC.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
cholguin
n00b
n00b


Joined: 17 May 2006
Posts: 5
Location: Dominican Republic

PostPosted: Thu May 18, 2006 6:30 pm    Post subject: Reply with quote

I still have the problem can anyone help me???
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Fri May 19, 2006 11:09 am    Post subject: Reply with quote

Quote:
# genkernel --genzimage all


As far as I know --genzimage isn't one of genkernel's option flags. It isn't on my machine...no wait as second. Huh.
Weird. It's not listed in the manpage or in the output of genkernel --help, but it's definitely a working option.
Anyway, can you post the contents of /var/log/genkernel.log? Before you do, add this option to the command line:
Code:

genkernel --genzimage--debuglevel=5 all

_________________
Thomas S. Howard
Back to top
View user's profile Send private message
cholguin
n00b
n00b


Joined: 17 May 2006
Posts: 5
Location: Dominican Republic

PostPosted: Sat May 20, 2006 4:15 am    Post subject: Reply with quote

thanks i will try that later on, i will try to install another distribution on the mean time and get back to this eventualy.

Thanks anyway God bless.
Back to top
View user's profile Send private message
cholguin
n00b
n00b


Joined: 17 May 2006
Posts: 5
Location: Dominican Republic

PostPosted: Sat May 20, 2006 4:18 am    Post subject: Initfram Problems (Solved, but i will get back to it( Reply with quote

I will definetly try Gentoo again another time.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum