Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
snd-aoa added to portage
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
xyz
n00b
n00b


Joined: 29 Oct 2003
Posts: 67

PostPosted: Fri Sep 22, 2006 2:08 am    Post subject: Reply with quote

According to your suggestion I compiled alsa and aoa in the kernel, now it works!
Thank you very much for your great help!
Back to top
View user's profile Send private message
jaspal kallar
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 194
Location: Sweden

PostPosted: Fri Feb 16, 2007 10:40 pm    Post subject: Reply with quote

JoseJX wrote:
It should work on almost all of the G5's, but you might need to add your bus information to the driver. Give it a shot, ping me on IRC if it doesn't work out of the box and I'll help you get it working. The optical stuff is "supported" in that there's a mostly complete driver for it, but Johannes doesn't have any optical devices to test with it, so you might want to get in touch with him about it if you're interested in testing for him.


I just upgraded to kernel 2.6.19-gentoo-r5 and I'm using the snd-aoa driver. I have a powermac G5 (PowerMac7,2). 1.8 dual. I was wondering if anybody knew if optical out worked as it doesn't seem to om my machine?

Thanks,
- jaspal.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Feb 16, 2007 11:46 pm    Post subject: Reply with quote

It should work (the optical light goes on when I unmute the optical port on my PowerBook). I can't actually test it though.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
jaspal kallar
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 194
Location: Sweden

PostPosted: Mon Feb 19, 2007 10:03 am    Post subject: Reply with quote

JoseJX wrote:
It should work (the optical light goes on when I unmute the optical port on my PowerBook). I can't actually test it though.


I don't see any red light out of my optical port (there's no unmuting as far as I know on a powermac G5). I'm not sure if I've got the correct module loaded. Here's my lsmod
Code:
snd_pcm_oss            65392  0
snd_mixer_oss          28072  2 snd_pcm_oss
snd_aoa_codec_tas      21760  2
snd_aoa_fabric_layout    19296  1
snd_aoa                28624  2 snd_aoa_codec_tas,snd_aoa_fabric_layout
snd_aoa_i2sbus         32724  1
snd_aoa_soundbus       11492  2 snd_aoa_fabric_layout,snd_aoa_i2sbus
snd_pcm               121460  2 snd_pcm_oss,snd_aoa_i2sbus
snd_page_alloc         15656  1 snd_pcm
snd_timer              37568  1 snd_pcm
snd                    94568  8 snd_pcm_oss,snd_mixer_oss,snd_aoa_codec_tas,snd_aoa_fabric_layout,snd_aoa,snd_aoa_i2sbus,snd_pcm,snd_timer
soundcore              12888  2 snd


Perhaps someone can say if I'm missing a module ?

- jaspal

edit:

I loaded the modules snd-aoa-codec-toonie and snd-aoa-codec-onyx and my /var/log/messages output:
Code:
Feb 19 11:04:52 linux snd-aoa: fabric didn't like codec toonie
Feb 19 11:05:04 linux snd-aoa-codec-onyx: found k2-i2c, checking if onyx chip is on it
Feb 19 11:05:04 linux snd-aoa-codec-onyx: failed to read control register
Feb 19 11:05:04 linux snd-aoa-codec-onyx: failed to read control register


No luck in seeing red light out of the optical port so I emailed the author of the tas codec after digging around in the code.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Feb 19, 2007 12:49 pm    Post subject: Reply with quote

The light only turns on if I unmute the IEC958 device in alsamixer.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
jaspal kallar
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 194
Location: Sweden

PostPosted: Wed Feb 21, 2007 5:55 pm    Post subject: Reply with quote

JoseJX wrote:
The light only turns on if I unmute the IEC958 device in alsamixer.


I was wondering what your /proc/cpuinfo looked like and what aoa module was loaded so that you could get the light to turn on?

- jaspal.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Feb 23, 2007 3:13 am    Post subject: Reply with quote

Code:
$ cat /proc/cpuinfo
processor   : 0
cpu      : 7447A, altivec supported
clock      : 1666.666000MHz
revision   : 0.5 (pvr 8003 0105)
bogomips   : 33.15
timebase   : 8320000
platform   : PowerMac
machine      : PowerBook5,9
motherboard   : PowerBook5,9 MacRISC3 Power Macintosh
detected as   : 287 (PowerBook G4 17")
pmac flags   : 00000019
L2 cache   : 512K unified
pmac-generation   : NewWorld


I don't load any snd-aoa modules, they're all compiled in, but my machine seems to be using the onyx device.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum