Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Rosegarden on PPC sequencer problems [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
stmiller
Tux's lil' helper
Tux's lil' helper


Joined: 28 Feb 2006
Posts: 119

PostPosted: Fri May 19, 2006 4:45 pm    Post subject: Rosegarden on PPC sequencer problems [solved] Reply with quote

When starting rosegarden, I get the error: "Rosegarden could not start the sequencer...."

I have snd-seq, snd-seq-oss, snd-seq-device, and snd-pcm-oss loaded. Is Rosegarden working for anyone else? Thanks,

Machine: dual 2Ghz powermac G5


Last edited by stmiller on Sun May 21, 2006 12:17 am; edited 1 time in total
Back to top
View user's profile Send private message
corsair
Retired Dev
Retired Dev


Joined: 06 Oct 2003
Posts: 451
Location: Aachen, Germany

PostPosted: Sat May 20, 2006 7:33 am    Post subject: Reply with quote

Hello,

I just compiled rosegarden on my G5 running Gentoo/PPC64. (note that rosegardes has no keyword for ppc64, i.e. is not tested in any way)

As you can see on this rosegarden screenshot it starts for me. Unfortunaly it crashes when editing a midi device. So the "could not start the sequencer" error should be able to be fixed.

Do you run ppc64 or ppc? do you run arts? does sound work for you in other applications?

Regards,

Markus
Back to top
View user's profile Send private message
stmiller
Tux's lil' helper
Tux's lil' helper


Joined: 28 Feb 2006
Posts: 119

PostPosted: Sat May 20, 2006 2:25 pm    Post subject: Reply with quote

I'm running 32bit userland/ppc64. Yes I have sound working fine in other programs (Audacity, XMMS, VLC, etc.).

Here is the output in the terminal. It seems to hang until I finally ctrl+x from the terminal to kill it.

Code:
stmiller@stmiller ~ $ rosegarden
kbuildsycoca running...
stmiller@stmiller ~ $ Rosegarden ArtsDriver - Arts 1.4.3
RosegardenGUIDoc::xmlParse (reader.parse()): 20ms elapsed
MCOP ObjectManager: can't find implementation for Arts::MidiPort.
KCrash: Application 'rosegardensequencer' crashing...
Unable to start Dr. Konqi
Launched ok, pid = 31771
OggS-SEEK: at 704 want 47096 got 23104 (diff-requested 46392)
OggS-SEEK: at 47040 want 1032 got 0 (diff-requested -46008)
Rosegarden ArtsDriver - Arts 1.4.3
OggS-SEEK: at 704 want 47096 got 23104 (diff-requested 46392)
OggS-SEEK: at 47040 want 1032 got 0 (diff-requested -46008)

stmiller@stmiller ~ $ ICE default IO error handler doing an exit(), pid = 31768, errno = 0



Konqueror errors (and this rosegarden error) makes a crash sound (and uses arts) so I know arts is working. Is there anyway to avoid using arts?

Or could the "MCOP ObjectManager: can't find implementation for Arts::MidiPort." be the problem?
Back to top
View user's profile Send private message
corsair
Retired Dev
Retired Dev


Joined: 06 Oct 2003
Posts: 451
Location: Aachen, Germany

PostPosted: Sat May 20, 2006 2:34 pm    Post subject: Reply with quote

stmiller wrote:
Konqueror errors (and this rosegarden error) makes a crash sound (and uses arts) so I know arts is working. Is there anyway to avoid using arts?


well.. I generaly set USE="-arts" on all production use systems I set up. I don't realy know how to stop using it, when you have it installed, sorry.

stmiller wrote:
Or could the "MCOP ObjectManager: can't find implementation for Arts::MidiPort." be the problem?


Yes, that might be the problem, but I don't have enough knowledge about arts to be sure. Maybe another person knows this.
Back to top
View user's profile Send private message
stmiller
Tux's lil' helper
Tux's lil' helper


Joined: 28 Feb 2006
Posts: 119

PostPosted: Sat May 20, 2006 3:57 pm    Post subject: Reply with quote

Ah great- actually this helps me quite a bit! I set USE="-arts" and re-emerged rosegarden. Now rosegarden starts fine, and connects to my midi device okay (Yamaha UX16 USB midi connector).

Now if only jackd would work.... :)
Back to top
View user's profile Send private message
corsair
Retired Dev
Retired Dev


Joined: 06 Oct 2003
Posts: 451
Location: Aachen, Germany

PostPosted: Sat May 20, 2006 9:34 pm    Post subject: Reply with quote

good to hear that! :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum