Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Any risk using MOL with my real MacOSX partition? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
luispa
Guru
Guru


Joined: 17 Mar 2006
Posts: 357
Location: España

PostPosted: Fri May 26, 2006 2:27 pm    Post subject: Any risk using MOL with my real MacOSX partition? [SOLVED] Reply with quote

Hi,

Sorry if it's a basic/simple question, but I'm really afraid I could break my MacOSX and I've not been able to find a satisfactory answer in the forums, so I'm asking the experts. I have the following:
- PowerBook G4
- Internal Disk: MacOSX.
- External Firewire Disk: Gentoo Linux 2.6.17-rc4.

I'm booting from the firewire disk, then the internal disk appears as follows:
Code:
# mac-fdisk /dev/hda
        #                    type name                  length   base      ( size ) system
/dev/hda1     Apple_partition_map Apple                     63 @ 1         ( 31.5k) Partition map
/dev/hda2              Apple_Free Extra                 262144 @ 64        (128.0M) Free space
/dev/hda3               Apple_HFS Untitled           195109350 @ 262208    ( 93.0G) HFS
/dev/hda4              Apple_Free Extra                     10 @ 195371558 (  5.0k) Free space

Block size=512, Number of Blocks=195371568
DeviceType=0x0, DeviceId=0x0


Questions:
1) Is it possible to setup MOL to boot from the internal disk MacOSX?
2) Are there any chances of corruption/problems?
3) How will MacOSX react when it findsout it's being boot from a 'different' hardware? (video, etc.. will be different).
4) Will it be possible to boot from the internal HD later? Will everything recover to original Hardware setup?

If all the above is good, then:
5) Is it correct to configure my internal disk (/etc/mol/molrc.osx) like this?
Code:
blkdev:                 /dev/hda       -rw


Any other suggestion is highly appreciated.

Thanks a lot

Luis


Last edited by luispa on Fri May 26, 2006 5:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri May 26, 2006 3:18 pm    Post subject: Reply with quote

I haven't ever had any corruption with MOL running from my native OSX install. MOL does require some drivers to be installed for networking and sound, but they are not loaded unless MOL is running. Yopu should have no problem booting OSX in MOL then rebooting back into OSX natively.

When setting up MOL, I would use the specific partition OSX is installed on and add the boot parameter as well.

Good luck!
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
luispa
Guru
Guru


Joined: 17 Mar 2006
Posts: 357
Location: España

PostPosted: Fri May 26, 2006 5:12 pm    Post subject: Reply with quote

Thanks Jose,

I've tried it and I'm definitely impressed. The opportunities it brings are amazing. It works extremely well.

Thanks a lot,

Luis

PD: Still having some issues with the framebuffer full-screen not accepting maximum video resolution/colors, but probably it's due to the ATI driver. Anyway that's another story.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri May 26, 2006 7:08 pm    Post subject: Reply with quote

Do you mean in MOL? What exactly is your resolution/depth? Did you set it in /etc/mol/molrc.video? Did you run movconfig and ensure that the mode was setup that way as well?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
luispa
Guru
Guru


Joined: 17 Mar 2006
Posts: 357
Location: España

PostPosted: Sat May 27, 2006 12:38 pm    Post subject: Reply with quote

JoseJX wrote:
Do you mean in MOL? What exactly is your resolution/depth? Did you set it in /etc/mol/molrc.video? Did you run movconfig and ensure that the mode was setup that way as well?



Hi JoseJX, yes I mean MOL running in Console Video with the maximum resolution supported by my PowerBook G4 17", so 1440x900x24depth.

I've created a new topic for this

Thanks

Luis
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum