Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to mount root fs (solved)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 873
Location: Vancouver, BC

PostPosted: Mon May 29, 2006 7:19 pm    Post subject: Unable to mount root fs (solved) Reply with quote

Well,

I've got the kernel figured out, and have the right drivers installed. However, the livecd detects the cdrom as hda and the drive as hdc, and the system it's the other way around. I can't figure out how to force yaboot to update the boot partition with the correct settings - it complains it can't open /dev/hda2 (which of course is the cdrom.)

Anyone know a way around this?


Last edited by danomac on Mon May 29, 2006 8:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
Dizzutch
Guru
Guru


Joined: 09 Nov 2004
Posts: 463
Location: Worcester, MA

PostPosted: Mon May 29, 2006 7:21 pm    Post subject: Reply with quote

what does your yaboot.conf look like?
_________________
Help the confused! Adopt an unanswered post!
prepend [solved] to your post title when you feel your issue is resolved.
Worcester Judo
Back to top
View user's profile Send private message
danomac
l33t
l33t


Joined: 06 Nov 2004
Posts: 873
Location: Vancouver, BC

PostPosted: Mon May 29, 2006 8:48 pm    Post subject: Reply with quote

Oddly enough, I ran
Code:
ybin -v -b /dev/hdc2 -C /mnt/gentoo/etc/yaboot.conf
the first time and it failed. I ran the command a second time and it worked with no errors? Not really sure what happened there.

This was my yaboot.conf file (I didn't have to change anything):
Code:

boot=/dev/hda2
device=hd:
partition=4
root=/dev/hda4
timeout=30
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot

image=/boot/kernel-2.6.16-gentoo-r7
        label=Gentoo
        read-only
        root=/dev/hda4



It finally booted on its own with no errors, no on to installing some other packages...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum