Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eaclocal: 'm4' does not exist?
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message

Joined: 29 Oct 2004
Posts: 256
Location: Kadena AB, Okinawa Japan

PostPosted: Wed May 31, 2006 9:02 pm    Post subject: eaclocal: 'm4' does not exist? Reply with quote

I've been hitting this error for a few days now. Not always on the same applications, but always mentionof m4.

I've re-emerged m4 a few times with no problems.


Gentoo-MediaBox ~ # emerge -a m4

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] sys-devel/m4-1.4.4


>>> original instance of package unmerged safely.
>>> Regenerating /etc/
>>> sys-devel/m4-1.4.4 merged.

>>> clean: No packages selected for removal.

>>> Auto-cleaning packages ...

>>> No outdated packages were found on your system.

 * Regenerating GNU info directory index...
 * Processed 137 info files.
 * IMPORTANT: 1 config files in /etc need updating.
 * Type emerge --help config to learn how to update config files.


Gentoo-MediaBox ~ # etc-update
Scanning Configuration files...
Automerging trivial changes in: login.defs
Exiting: Nothing left to do; exiting. :)

But when I emerge -e world or system I still get all this:

Here is the error:

Gentoo-MediaBox ~ # emerge --resume
*** Resuming merge...
>>> emerge (1 of 172) media-libs/libdts-0.0.2-r3 to /
>>> md5 files   ;-) libdts-0.0.2-r3.ebuild
>>> md5 files   ;-) files/libdts-0.0.2-freebsd.patch
>>> md5 files   ;-) files/digest-libdts-0.0.2-r3
>>> md5 files   ;-) files/libdts-0.0.2-libtool.patch
>>> md5 files   ;-) files/libdts-0.0.2-visibility.patch
>>> md5 src_uri ;-) libdts-0.0.2.tar.gz
>>> Unpacking source...
>>> Unpacking libdts-0.0.2.tar.gz to /var/tmp/portage/libdts-0.0.2-r3/work
 * Applying libdts-0.0.2-libtool.patch ...                                                                                       [ ok ] * Applying libdts-0.0.2-freebsd.patch ...                                                                                       [ ok ] * Running eautoreconf in '/var/tmp/portage/libdts-0.0.2-r3/work/libdts-0.0.2' ...
 * eaclocal: 'm4' does not exist
 * Running aclocal -I m4 ...                                                                                                     [ !! ]
 * Failed Running aclocal !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/libdts-0.0.2-r3/temp/aclocal-23336.out

!!! ERROR: media-libs/libdts-0.0.2-r3 failed.
!!! Function autotools_run_tool, Line 198, Exitcode 0
!!! Failed Running aclocal !
!!! If you need support, post the topmost build error, NOT this status message.

Doesn't matter if I resume, re-emerge or what ever some point along emerge -e world or emerge -e system I get this error. m4 emerges with out flaw. I changed a bunch of hardware, and did a rebuild of gcc, glibc, binutils and portage. Now I'm re-emerging the system (and world) to make sure all the applications are built correctly for the new cpu and mobo.

Thanks for any and all help,

Here's the other vitals: (haven't tried to compile w/out distcc yet)

Gentoo-MediaBox ~ # emerge --info
Portage 2.0.54-r2 (default-linux/x86/no-nptl, gcc-3.4.6, glibc-2.3.6-r4, 2.6.16-gentoo-r7 i686)
System uname: 2.6.16-gentoo-r7 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.6.14
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
dev-lang/python:     2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=pentium4 -fforce-addr -fomit-frame-pointer -ftracer -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/X11/xkb /usr/lib/mozilla/defaults/pref /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fforce-addr -fomit-frame-pointer -ftracer -pipe -fvisibility-inlines-hidden"
FEATURES="autoconfig ccache distcc distlocks sandbox sfperms strict userpriv usersandbox"
PORTDIR_OVERLAY="/shared/LinuxApps/Portage/xgl-coffee /shared/LinuxApps/Portage/overlays"
USE="X alsa apache2 apm arts audiofile avi bash-completion berkdb bitmap-fonts bzip2 cdparanoia cdr cli crypt cups divx4linux dri dts dvd dvdr dvdread eds emboss encode exif expat fam ffmpeg flac flash fontbase foomaticdb fortran ftp gdbm gif glut glx gmp gnome gpm gstreamer gtk gtk2 imagemagick imlib ipv6 isdnlog java javascript jpeg kde lcms libg++ libwww lirc mad mikmod mime ming mng motif mozilla mp3 mpeg mysql ncurses nls nsplugin nvidia ogg opengl oss pam pcre pdf pdflib perl php png pppd python qt quicktime readline real reflection sdl session spell spl ssl tcpd tiff truetype truetype-fonts type1-fonts udev usb userlocales v4l vcd videos vorbis win32codecs x86 xine xml xml2 xmms xorg xv xvid zlib userland_GNU kernel_linux elibc_glibc"

Be nice or you will be ctrl+alt+deleted .. if you are just being ugly, ctrl+alt+backspaced!
Back to top
View user's profile Send private message

Joined: 18 Jan 2006
Posts: 370
Location: Ontario, Canada

PostPosted: Thu Jun 01, 2006 5:44 am    Post subject: Reply with quote

Problem discussed and fixed:
Back to top
View user's profile Send private message

Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Thu Jun 01, 2006 12:53 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see the topic mentioned above.
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum