Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
single-user mode shutdown now problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
gnomeza
Tux's lil' helper
Tux's lil' helper


Joined: 31 Dec 2003
Posts: 97

PostPosted: Fri Jun 09, 2006 4:49 pm    Post subject: single-user mode shutdown now problem Reply with quote

Came across a strange problem today:

After a clean boot, I logged in to the console as root and ran "shutdown now" to get to single user mode.

The services all seem to shutdown correctly and it gives the expected:
Code:
Give root password for maintenance
(Control-D to continue):
(more or less).

But when I start typing, my root console reappears over the message as if I'd never been logged out of my original console.

If I then type exit I'm left with the "Give root password for maintenance..." message. But every key I press (whether it's Ctrl-D or not) makes the message appear again.

The only way to recover is to use Ctrl-Alt-Delete (which thankfully I have bound to "/sbin/shutdown -r now" in inittab)

Can anyone else reproduce this?

vanilla 2.6.17-rc4, alubook 1.25GHz.
baselayout-1.12.0-r1
Back to top
View user's profile Send private message
chrisstankevitz
Guru
Guru


Joined: 14 Dec 2003
Posts: 472
Location: Santa Barbara, CA, USA

PostPosted: Fri Oct 13, 2006 4:53 pm    Post subject: Reply with quote

Me too.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum