Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Where are my hard drives?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Carnildo
Guru
Guru


Joined: 17 Jun 2004
Posts: 594

PostPosted: Tue Jun 20, 2006 6:20 am    Post subject: Where are my hard drives? Reply with quote

I've got a beige PowerMac G3 that I'm trying to install Gentoo on. It's got three hard drives: an IDE hard drive attached to the mainboard, and two SCSI hard drives attached to an ATTO ExpressPCI PSC SCSI card. When I boot off of the install CD, none of the hard drives appear to exist: /dev/hda is the CD-ROM, and there are no other /dev/hd or /dev/sd devices. Where are my hard drives?
Back to top
View user's profile Send private message
sugar
Guru
Guru


Joined: 07 Aug 2004
Posts: 579
Location: Morrinsville, New Zealand

PostPosted: Tue Jun 20, 2006 10:59 pm    Post subject: Reply with quote

what does
Code:
fdisk -l
show?
Back to top
View user's profile Send private message
Carnildo
Guru
Guru


Joined: 17 Jun 2004
Posts: 594

PostPosted: Wed Jun 21, 2006 1:21 am    Post subject: Reply with quote

Nothing.
Back to top
View user's profile Send private message
Valkura
Apprentice
Apprentice


Joined: 27 Feb 2006
Posts: 242
Location: Ramsey, MN

PostPosted: Wed Jun 21, 2006 1:47 am    Post subject: Reply with quote

What about using mac-fdisk instead of fdisk? Doubt it will make a difference, but might as well check.

Also look at the mac-fdisk help, make sure the command is right to list the HDs
_________________
last.fm
SFH, because it's awesome
Back to top
View user's profile Send private message
Carnildo
Guru
Guru


Joined: 17 Jun 2004
Posts: 594

PostPosted: Wed Jun 21, 2006 2:33 am    Post subject: Reply with quote

Well, I've got a partial answer to where the disks are: I remembered wrong about the boot hard disk: it's on the mainboard's SCSI controller, not the IDE controller.

The output of "lspci":
00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
00:0d.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 04)
00:0f.0 Ethernet controller: Digital Equipment Corporation DECchip 21142/43 (rev 41)
00:10.0 Class ff00: Apple Computer Inc. Heathrow Mac I/O (rev 01)
00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage I/II 215GT [Mach64 GT] (rev 9a)

which indicates to me that it's found the mainboard controller, but not the ATTO ExpressPCI controller. What driver do I need to get the mainboard controller to work, and what do I need to do to get the ATTO controller recognized?
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Jun 21, 2006 12:55 pm    Post subject: Reply with quote

Try modprobe ncr53c8xx and see if that finds your SCSI card. I'm not sure about the built in IDE, but try modprobe cmd64x.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Carnildo
Guru
Guru


Joined: 17 Jun 2004
Posts: 594

PostPosted: Thu Jun 22, 2006 1:52 am    Post subject: Reply with quote

JoseJX wrote:
Try modprobe ncr53c8xx and see if that finds your SCSI card.


There doesn't seem to be a "ncr53c8xx" module. Did you mean "sym53c8xx"?

Quote:
I'm not sure about the built in IDE, but try modprobe cmd64x.


The IDE's fine. It's just that the only thing connected to it is the CD-ROM.
Back to top
View user's profile Send private message
Carnildo
Guru
Guru


Joined: 17 Jun 2004
Posts: 594

PostPosted: Thu Jun 22, 2006 3:54 am    Post subject: Reply with quote

Some improvement: "modprobe sd_mod" gives me a /dev/sda and /dev/sda1-7, which looks like it's the MacOS boot hard drive, but none of the partitions mounts as an HFS+ partition.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum