Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Aluminum powerbook low-level config. tips, tricks, and hacks
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
ramin.honary
n00b
n00b


Joined: 29 Jun 2008
Posts: 24

PostPosted: Sat Nov 01, 2008 1:57 am    Post subject: Reply with quote

randalf wrote:
You've got an ATI Rage 128 graphics card in your Powerbook?
You should probably unset "CONFIG_DRM_R128".
Did you run Xorgautoconfig?


Thanks for responding! And I did remove CONFIG_DRM_R128 from my kernel configuration, re-compiled the kernel and re-installed the kernel. So far, no problems. Then, I uncerimoniously unmerged X.org and my radeon driver and re-emerged them all.

Then I emerged "xorgautoconfig" and ran it, and it generated a configuration file. Now I can start X and I am using a graphical interface right now without any real problems, but it is STILL not using DRM. I checked the configuration and DRM wasn't included into the configuration by "Xorgautoconfig".

Despite all my re-compiling, absolutely nothing has changed, except the configuration file itself which was generated by "Xorgautoconfig". So, running GLXGears still gives me only 30-40 FPS.
Back to top
View user's profile Send private message
randalf
n00b
n00b


Joined: 02 Jan 2006
Posts: 61
Location: Dresden

PostPosted: Sat Nov 01, 2008 10:40 am    Post subject: Reply with quote

What are your USE-Flags for xorg-server and what have you set in your /etc/make.conf VIDEO_CARDS -Section?
Back to top
View user's profile Send private message
ramin.honary
n00b
n00b


Joined: 29 Jun 2008
Posts: 24

PostPosted: Tue Nov 18, 2008 7:46 pm    Post subject: Reply with quote

randalf wrote:
What are your USE-Flags for xorg-server and what have you set in your /etc/make.conf VIDEO_CARDS -Section?
Sorry for taking so long to reply.
In "/etc/make.conf" I set
Code:
VIDEO="fglrx"
But in "/etc/portage/package.use" I did not set any use flags for "x11-base/xorg-server". Should I have set it to "xorg"?

Should I try recompiling with that use flag set?
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Wed Nov 19, 2008 8:43 am    Post subject: Reply with quote

Quote:
VIDEO="fglrx"


that makes no sense actually :

a) the variable is called VIDEO_CARDS
b) fglrx ( ati´s binary driver) isn´t available for ppc arch

in case your powerbook has a Rage 128, VIDEO_CARDS="r128" should do it, if it is a radeon card VIDEO_CARDS="radeon" and so on.
Re-read the documentation and triplecheck your make.conf for other things, add that to your make.conf and rebuild stuff ( emerge -avN should tell you which ones). Maybe it would be a good idea to show us your make.conf before you start compiling in order to check if everything is in place.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
ramin.honary
n00b
n00b


Joined: 29 Jun 2008
Posts: 24

PostPosted: Wed Nov 19, 2008 4:33 pm    Post subject: Reply with quote

It worked!
gringo wrote:
that makes no sense actually :
a) the variable is called VIDEO_CARDS
b) fglrx ( ati´s binary driver) isn´t available for ppc arch
Sorry, I mistook the name of that variable, ineed it was "VIDEO_CARDS", but it was set to "fglrx".
gringo wrote:
in case your powerbook has a Rage 128, VIDEO_CARDS="r128" should do it, if it is a radeon card VIDEO_CARDS="radeon" and so on.
Re-read the documentation and triplecheck your make.conf for other things, add that to your make.conf and rebuild stuff ( emerge -avN should tell you which ones). Maybe it would be a good idea to show us your make.conf before you start compiling in order to check if everything is in place.
Running "lspci" tells me I have a radeon card. So I set the variable VIDEO_CARDS="radeon", re-emerged "x11-base/xorg-server" and then rebooted my machine and now it works! "Glxgears" is going at full speed (considering the radeon driver can't make use of the radeon OpenGL extensions.)

I checked the Genoo Linux PPC handbook and there is no mention of setting the "VIDEO_CARDS" variable anywhere. I can only imaging that while I was trying to solve my problem, Google pointed me to gentoo's X11 handbook for i386 architectures, and I used the information from that incorrectly to set my "VIDEO_CARDS" variable to "fglrx". Someone who can make changes to the manual might want to make a note of that.

Well, my most sincerest thanks to everyone who helped me solve this problem! My system is nearly complete.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Wed Nov 19, 2008 8:00 pm    Post subject: Reply with quote

Quote:
I checked the Genoo Linux PPC handbook and there is no mention of setting the "VIDEO_CARDS" variable anywhere. I can only imaging that while I was trying to solve my problem, Google pointed me to gentoo's X11 handbook for i386 architectures, and I used the information from that incorrectly to set my "VIDEO_CARDS" variable to "fglrx". Someone who can make changes to the manual might want to make a note of that.


But there is also the ppc faq which you should have read too -> http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml .
but yes, if thats true someone should make a note or sth.

Quote:
Running "lspci" tells me I have a radeon card. So I set the variable VIDEO_CARDS="radeon", re-emerged "x11-base/xorg-server" and then rebooted my machine and now it works! "Glxgears" is going at full speed (considering the radeon driver can't make use of the radeon OpenGL extensions.)


check above linked faq, you will find a few more things you need to check ;)
Mesa also needs to be rebuilt btw, it has the VIDEO_CARDS USE too. Use emerge -avN to see which packages have modified USEs.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
ramin.honary
n00b
n00b


Joined: 29 Jun 2008
Posts: 24

PostPosted: Thu Nov 20, 2008 5:00 pm    Post subject: [solved] Reply with quote

gringo wrote:
Quote:
I checked the Genoo Linux PPC handbook and there is no mention of setting the "VIDEO_CARDS" variable anywhere.
But there is also the ppc faq which you should have read too -> http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml .

but yes, if thats true someone should make a note or sth.

check above linked faq, you will find a few more things you need to check ;)
Mesa also needs to be rebuilt btw, it has the VIDEO_CARDS USE too. Use emerge -avN to see which packages have modified USEs.
You're right, I looked at the FAQ and towards the bottom in the section called "What is required for DRM?", it says you need to set VIDEO_CARDS="radeon".

I should also say, should anyone else ever benefit from this thread, I did do an "emerge --newuse world" after I re-emerged "x11-base/xorg-server", so that's why it worked so nicely after I rebooted my machine.

OK, I didn't start this thread but I marked this post as [SOLVED]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum