Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo on a Mac G5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
arantius
n00b
n00b


Joined: 03 Jan 2004
Posts: 66

PostPosted: Wed Jun 28, 2006 5:30 pm    Post subject: Gentoo on a Mac G5 Reply with quote

I want to test some new software/network set ups. I've claimed a spare Mac G5 sitting around to install these things on. I haven't managed to get Gentoo installed on it.

If I put in the ppc64 install cd, I get to the boot prompt, hit enter and see:

Code:
CF000100

MM Init
CF000100

MM Init Done
CF000012

Setup Arch


And the machine appears to be locked. If I just use the ppc install cd, I get the boot prompt and see:

Code:
... ok
opening display /pci@0,0000000/NVDA,Parent@0/NVDA,Display-B@1... ok
copying OF device tree...done
starting cpu /cpus/PowerPC,G5@1...failed: 00000000
Initializing fake screen: NVDA,Display-A
Calling quiesce ...
returning 0x01400000 from prom_init

Invalid memory access at   %SRR0: 00000000.01403778   %SRR1: 10000000.00083030

Apple PowerMac11,2 5.2.7f1 BootROM built on 09.03/05 at 15:31:03

To continue booting, type "mac-boot" and press return.
To shut down, type "shut-down" and press return.

Release keys to continue!


And again, the machine appears to be locked.
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Thu Jun 29, 2006 2:51 am    Post subject: Reply with quote

Moved from Installing Gentoo to Gentoo on PPC.
Back to top
View user's profile Send private message
veonline
n00b
n00b


Joined: 21 Mar 2005
Posts: 58

PostPosted: Thu Jun 29, 2006 4:21 pm    Post subject: Re: Gentoo on a Mac G5 Reply with quote

arantius wrote:

Code:
... ok
opening display /pci@0,0000000/NVDA,Parent@0/NVDA,Display-B@1... ok
copying OF device tree...done
starting cpu /cpus/PowerPC,G5@1...failed: 00000000
Initializing fake screen: NVDA,Display-A
Calling quiesce ...
returning 0x01400000 from prom_init

Invalid memory access at   %SRR0: 00000000.01403778   %SRR1: 10000000.00083030

Apple PowerMac11,2 5.2.7f1 BootROM built on 09.03/05 at 15:31:03

To continue booting, type "mac-boot" and press return.
To shut down, type "shut-down" and press return.

Release keys to continue!




have you tryed to type "mac-boot" as stated in the error??
try also to duobletab at the boot promp of the install cd to se what kernel images are available and try some of those... try also the kernel boot option video=ofonly
Back to top
View user's profile Send private message
arantius
n00b
n00b


Joined: 03 Jan 2004
Posts: 66

PostPosted: Thu Jun 29, 2006 4:23 pm    Post subject: Reply with quote

Yes, typing has no effect at that prompt.

I've tried video=ofonly.

The only alternative kernel appears to be something built to use the serial console instead of the monitor/keyboard.
Back to top
View user's profile Send private message
veonline
n00b
n00b


Joined: 21 Mar 2005
Posts: 58

PostPosted: Thu Jun 29, 2006 4:38 pm    Post subject: Reply with quote

i've succeded in installing the system some month ago using this
http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/experimental/ppc64/livecd/install-ppc64-minimal-dual-core-2006.0-32ul.iso
iso (from an italian mirror)

maybe you don't have the right one with the support for dual core...
Back to top
View user's profile Send private message
protege07
n00b
n00b


Joined: 11 Jan 2007
Posts: 2

PostPosted: Thu Jan 11, 2007 6:44 pm    Post subject: Reply with quote

I'm very interested in the solution to this thread.
I am also trying to install Gentoo (2006.1) on an older G5
No matter what I try it hangs at the "Release keys" Open Firmware prompt
Trouble is that I didn't get to the Open Firmware by pressing command+option+O+F
There are no keys to release
My proc is definitely not dual-core
Back to top
View user's profile Send private message
protege07
n00b
n00b


Joined: 11 Jan 2007
Posts: 2

PostPosted: Wed Feb 07, 2007 3:08 pm    Post subject: 64bit worked!! Reply with quote

The PPC64 LiveCD booted the machine fine....DUH!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum