Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem on merging nant
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
stellit
n00b
n00b


Joined: 18 Jun 2005
Posts: 44

PostPosted: Tue Apr 11, 2006 12:49 am    Post subject: Problem on merging nant Reply with quote

This is the error message I have, when I emerge nant, the ebuild also have the same.
Code:
debug:


set-framework-configuration:


set-mono-2.0-framework-configuration:


create-common-assemblyinfo:

   [attrib] Setting file attributes for 1 files to Normal.

BUILD FAILED

/var/tmp/portage/nant-0.85_rc3-r1/work/nant-0.85-nightly-2005-12-13/NAnt.build(93,10):
AssemblyInfo file '/var/tmp/portage/nant-0.85_rc3-r1/work/nant-0.85-nightly-2005-12-13/src/CommonAssemblyInfo.cs' could not be generated.
    An exception was thrown by the type initializer for System.Runtime.Remoting.Lifetime.LifetimeServices
        SIGILL

Total time: 1.4 seconds.

make: *** [build-nant] Error 1

!!! ERROR: dev-dotnet/nant-0.85_rc3-r1 failed.
Call stack:
  ebuild.sh, line 1526:   Called dyn_compile
  ebuild.sh, line 923:   Called src_compile
  nant-0.85_rc3-r1.ebuild, line 40:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.

mono version :
Code:
Mono JIT compiler version 1.1.13.4, (C) 2002-2005 Novell, Inc and Contributors. www.mono-project.com
        TLS:           __thread
        GC:            Included Boehm (with typed GC)
        SIGSEGV      : normal

My mono is 1.1.13, I dunno why it happens.
this is my emerge info:
Code:
Portage 2.1_pre7-r4 (default-linux/ppc/ppc32/2006.0/G4, gcc-3.4.5, glibc-2.3.6-r3, 2.6.16-gentoo-r1 ppc)
=================================================================
System uname: 2.6.16-gentoo-r1 ppc 7447A, altivec supported
Gentoo Base System version 1.12.0_pre16
dev-lang/python:     2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r4
ACCEPT_KEYWORDS="ppc ~ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -pipe -mcpu=7400 -maltivec -mabi=altivec"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -pipe -mcpu=7400 -maltivec -mabi=altivec"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="ppc X aim alsa altivec apache2 apm arts berkdb bitmap-fonts bluetooth bonobo calendar cdr cjk cli crypt ctype cups dba dri dvd eds emacs emboss encode esd expat fastbuild fbcon foomaticdb force-cgi-redirect fortran ftp gd gdbm gif gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml ieee1394 imlib immqt-bc ipv6 isdnlog jabber java javascript jpeg kde ldap libg++ libwww mad memlimit mikmod motif mozilla mp3 mpeg ncurses nls nptl ogg opengl pam pcmcia pcre pdflib perl png posix pppd python qt quicktime readline ruby sdl session simplexml soap sockets spell spl ssl tcpd tetex tokenizer truetype truetype-fonts type1-fonts udev unicode usb vorbis xml xmms xsl xv zlib elibc_glibc kernel_linux userland_GNU"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Apr 11, 2006 3:42 pm    Post subject: Reply with quote

SIGILL usually means that a cpu instruction was used that wasn't supported, on ppc, this is usually altivec. Make sure that you have altivec support enabled in your kernel. Is there anything in dmesg when you get this error?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
stellit
n00b
n00b


Joined: 18 Jun 2005
Posts: 44

PostPosted: Tue Apr 11, 2006 5:00 pm    Post subject: Reply with quote

This is my kernel menuconfig, I thought I have alread compile kernel with "AltiVec Support" .
Code:
x x     Processor Type (6xx/7xx/74xx)  --->                             x x 
  x x [*] AltiVec Support                                                 x x 
  x x [ ] Symmetric multi-processing support

Error message with dmesg:
Code:
Gentoo linux # dmesg | grep error
usb 1-1: device descriptor read/64, error -71
usb 1-1: device descriptor read/64, error -71
usb 1-1: device descriptor read/64, error -71
usb 1-1: device descriptor read/64, error -71
usb 1-1: device descriptor read/8, error -71
usb 1-1: device descriptor read/8, error -71


Thanks,
regard,

stellit
Back to top
View user's profile Send private message
sno35
Guru
Guru


Joined: 15 May 2004
Posts: 334
Location: Paris, France

PostPosted: Tue Apr 11, 2006 7:44 pm    Post subject: Reply with quote

Same problem encountered.
As I stated in https://bugs.gentoo.org/show_bug.cgi?id=120550
there is something that smells bad in the tgz I guess.
(Ans altivec is set on my kernels)
Hth.
Back to top
View user's profile Send private message
stellit
n00b
n00b


Joined: 18 Jun 2005
Posts: 44

PostPosted: Wed Apr 12, 2006 1:11 am    Post subject: Reply with quote

Now I use "dev-dotnet/nant-0.85_rc3" instead of "dev-dotnet/nant-0.85_rc3-r1".
nant-0.85_rc3 complied fine, but , I cannot contiue compile ikvm, it alsa has the similar error like nant-0.85_rc3-r1, mean while, I alsa cannot emerge monodevelop.
Is there any other way to avoid this problem ?

Regards,
stellit
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Apr 12, 2006 2:38 pm    Post subject: Reply with quote

On a stable ppc system, I marked the 2.4.2 versions of *-sharp ppc stable, monodevelop worked fine? Can you be a little more specific as to the versions that you're working with?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
stellit
n00b
n00b


Joined: 18 Jun 2005
Posts: 44

PostPosted: Wed Apr 12, 2006 7:42 pm    Post subject: Reply with quote

From the beginning, I emerge monodevelop, version 0.9-r1, but I got a error when emerge dev-dotnet/nant-0.85_rc3-r1, (The one i post above).
than I saw the post from sno35 ,
Quote:
Same problem encountered.
As I stated in https://bugs.gentoo.org/show_bug.cgi?id=120550
there is something that smells bad in the tgz I guess.
(Ans altivec is set on my kernels)
Hth.

So I read https://bugs.gentoo.org/show_bug.cgi?id=120550
Quote:
i can post my output later, it won't compile here either, but strangely
nant-0.85_rc3 merges just fine, so a temporary workaround is to just emerge
=nant-0.85_rc3 instead...monodev and boo build against it just fine.

After I saw this, I try mask nant-0.85_rc3-r1, inoder to merge a old version : nant-0.85_rc3
nant-0.85_rc3 Works fine, than I try emerge the rest package, which monodevelop needs, but it doesn't make sense, I got a other error on ikvm:
Code:

** (/usr/share/NAnt/bin/NAnt.exe:8746): WARNING **: Missing method .ctor in assembly /usr/share/NAnt/bin/NAnt.exe, type System.Runtime.CompilerServices.RuntimeCompatibilityAttribute

** ERROR **: Can't find custom attr constructor image: /usr/share/NAnt/bin/NAnt.exe mtoken: 0x0a000056
aborting...
/usr/portage/dev-dotnet/ikvm/ikvm-0.20.0.0.ebuild: line 27:  8746 Aborted                 nant -D:jikes.compiler=true -D:ecj.compiler=false

!!! ERROR: dev-dotnet/ikvm-0.20.0.0 failed.
Call stack:
  ebuild.sh, line 1532:   Called dyn_compile
  ebuild.sh, line 929:   Called src_compile
  ikvm-0.20.0.0.ebuild, line 28:   Called die

!!! ikvm build failed
!!! If you need support, post the topmost build error, and the call stack if relevant.

I also try to emerge boo-0.7.5.2013, but also got error:
Code:
** (/usr/share/NAnt/bin/NAnt.exe:10314): WARNING **: Missing method .ctor in assembly /usr/share/NAnt/bin/NAnt.exe, type System.Runtime.CompilerServices.RuntimeCompatibilityAttribute

** ERROR **: Can't find custom attr constructor image: /usr/share/NAnt/bin/NAnt.exe mtoken: 0x0a000056
aborting...
/usr/portage/dev-lang/boo/boo-0.7.5.2013.ebuild: line 39: 10314 Aborted                 LC_ALL="C" LANG="C" nant -t:mono-1.0 -D:install.prefix=/usr

!!! ERROR: dev-lang/boo-0.7.5.2013 failed.
Call stack:
  ebuild.sh, line 1532:   Called dyn_compile
  ebuild.sh, line 929:   Called src_compile
  boo-0.7.5.2013.ebuild, line 40:   Called die

!!! (no error message)
!!! If you need support, post the topmost build error, and the call stack if relevant.

There are the errors I got, so I cannot emerge monodevelop.


Im sorry, Im not a english native speaker, I hope I have explain the problem clearly.
Thank you,

Regards,
Stellit
Back to top
View user's profile Send private message
stellit
n00b
n00b


Joined: 18 Jun 2005
Posts: 44

PostPosted: Thu Apr 13, 2006 10:49 pm    Post subject: Reply with quote

any solution ?
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1062
Location: Burgas, Bulgaria

PostPosted: Mon May 22, 2006 7:11 am    Post subject: Reply with quote

stellit wrote:
any solution ?


Yes.

After merging mono and before merging nant need to do etc-update...
It's crazy but it's working for me...
_________________
Lefsha
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1062
Location: Burgas, Bulgaria

PostPosted: Mon Jun 05, 2006 1:25 am    Post subject: Reply with quote

boo-0.7.5.2013 has problem with archive file.

to build it you need rearchive it and remove digest file from
./files directory.

At least it helps me to build this boo version against nant-0.85-rc4
_________________
Lefsha
Back to top
View user's profile Send private message
davidgurvich
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1063

PostPosted: Fri Jul 28, 2006 4:55 am    Post subject: Reply with quote

Copy the ebuild for nant-0.85_rc3 to nant-0.85_rc4 and remove the 3 epatch files as they patch items that are, largely, fixed. Then ebuild nant...ebuild digest and emerge nant.

Only other problem I've run into is needing to edit gecko-sharp to use seamonkey instead of mozilla and monodevelop requiring that MOZILLA_FIVE_HOME be set before using it. So far seems ok. If I actually knew C# would be all set.
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1062
Location: Burgas, Bulgaria

PostPosted: Fri Jul 28, 2006 11:28 am    Post subject: Reply with quote

But all that could not give me working monodevelop.
It crashes every time I start it.
_________________
Lefsha
Back to top
View user's profile Send private message
davidgurvich
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1063

PostPosted: Fri Jul 28, 2006 4:13 pm    Post subject: Reply with quote

What error messages do you get when monodevelop crashes?
Monodevelop does not work completely smoothly here but does not crash. I need a wrapper script to start monodevelop and need to click in the screen area with the mouse to see anything.
Back to top
View user's profile Send private message
lefsha
Veteran
Veteran


Joined: 30 Aug 2004
Posts: 1062
Location: Burgas, Bulgaria

PostPosted: Fri Jul 28, 2006 4:51 pm    Post subject: Reply with quote

Some kind of internal error.
I get a main window and then it crashes.

But I see absolutely no reason to use such a program which bring only troubles in it.

I wanted to try Boo. Very interesting language.
But now I stick with Python and forget about it.

The second trouble in it. I need a lot of gnome libs to work with.
Even metacity, what I can't understand and can't accept.

I've made a conclusion that it is oriented for using in Gnome, not KDE.
OK. It's clear, cause Miguel came from Gnome Project.

But I don't share his opinion about Gnome. Every time Gnome getting less and less usable.
I just hate its File Open Dialog.
_________________
Lefsha
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum