Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
STLport-5.0.2 for ppc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
davidgurvich
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1063

PostPosted: Tue Jul 18, 2006 3:21 am    Post subject: STLport-5.0.2 for ppc Reply with quote

The package builds using the patches from bgo https://bugs.gentoo.org/show_bug.cgi?id=132054. I don't know if there are any problems with the patches, but so far openoffice-2.0.3 hasn't stopped compiling.
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Tue Jul 18, 2006 3:40 am    Post subject: Reply with quote

Isn't openoffice using its own version, shipped with its own sources?

Or do you use a patch or branch where you can build with an external STLport?
Which would be great!
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Jul 18, 2006 4:04 am    Post subject: Reply with quote

OO.o uses its own STLport snapshot.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
davidgurvich
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1063

PostPosted: Tue Jul 18, 2006 12:36 pm    Post subject: Reply with quote

There is an option to use system STLport.
Code:
--with-stlport=BASEDIR
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Tue Jul 18, 2006 10:47 pm    Post subject: Reply with quote

davidgurvich wrote:
There is an option to use system STLport.
Code:
--with-stlport=BASEDIR

OK but I am sure it is not an option of the ebuild. You are therefore building manually, correct?
The version of STLport shipped with OOo is 4.5 if I remember correctly, you are using 5.x,
There is the potential to run into problem if the interface has changed.
Has your OOo build succeded or failed yet?
Back to top
View user's profile Send private message
davidgurvich
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1063

PostPosted: Tue Jul 18, 2006 10:59 pm    Post subject: Reply with quote

It has failed but not from STLport, somewhere in xmlhelp it can't find a java package.
Back to top
View user's profile Send private message
davidgurvich
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1063

PostPosted: Mon Oct 02, 2006 6:01 pm    Post subject: Reply with quote

A patch for STLport-5, largefile-support.diff, required to build OO-2.0.4_pre4 from geki's overlay. This and other patches for PPC system.
Code:
@@ -8,7 +8,7 @@
 include ${SRCROOT}/Makefiles/top.mak

 ifeq ($(OSNAME),linux)
-DEFS += -D_STLP_REAL_LOCALE_IMPLEMENTED -D_GNU_SOURCE
+DEFS += -D_STLP_REAL_LOCALE_IMPLEMENTED -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
 endif

 # options for build with boost support
--- build/test/unit/gcc.mak.orig        2006-09-04 12:44:04.000000000 +0200
+++ build/test/unit/gcc.mak     2006-09-04 12:46:12.000000000 +0200
@@ -10,6 +10,10 @@

 DEFS += -D_STLP_NO_CUSTOM_IO

+ifeq ($(OSNAME), linux)
+DEFS += -D_FILE_OFFSET_BITS=64
+endif
+
 dbg-shared:    DEFS += -D_STLP_DEBUG_UNINITIALIZED
 stldbg-shared: DEFS += -D_STLP_DEBUG_UNINITIALIZED
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Tue Oct 03, 2006 8:08 am    Post subject: Reply with quote

Since we are on the subject of OOo-2.0.4, I emerged successfully the rc2 version
currently in portage (rc1 worked as well).
I didn't try java as it require the new java subsystem and I am not ready to make
that jump on my ppc machine yet. Have you already done that?
Back to top
View user's profile Send private message
davidgurvich
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1063

PostPosted: Fri Oct 06, 2006 6:30 pm    Post subject: Reply with quote

I emerged that version without java and modified the ebuild to use system libraries. That took about 5 hours on a dual G4 combined with an x86 node. There does seem to be a problem with the resulting binaries. I'll try again with different CFLAGS and see if that is stable.

The ebuild is based on geki's ebuild, as that tries to use as many system libraries as possible.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum