Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] problem updating portage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Tue Jul 18, 2006 3:45 pm    Post subject: [SOLVED] problem updating portage Reply with quote

Hi.

I'm trying to updating portage (emerge -uD portage).
After some problem I was able to solve (thanks to a friend), I had to install a masked package.
This was the message:
Code:

These are the packages that I would merge, in order:

Calculating dependencies   
!!! All ebuilds that could satisfy "dev-java/blackdown-jdk" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-java/blackdown-jdk-1.3.1-r23 (masked by: ~ppc keyword)
- dev-java/blackdown-jdk-1.3.1-r8 (masked by: ~ppc keyword)
- dev-java/blackdown-jdk-1.4.1-r1 (masked by: -* keyword)
- dev-java/blackdown-jdk-1.3.1-r10 (masked by: package.mask)
# Joseph Jezak <josejx@gentoo.org> (05 Mar 2006)
# Please use IBM's Java instead on PPC
# Masked because there are better options and security issues with this version

- dev-java/blackdown-jdk-1.4.1-r12 (masked by: -* keyword)
- dev-java/blackdown-jdk-1.4.2.03-r2 (masked by: -* keyword)
- dev-java/blackdown-jdk-1.4.2.03-r12 (masked by: -* keyword)
- dev-java/blackdown-jdk-1.4.2.03 (masked by: -* keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
section 2.2 "Software Availability" in the Gentoo Handbook.
!!!    (dependency required by "sys-libs/db-4.2.52_p2-r1" [ebuild])


I decided to unmask one (I'm a newbie...) randomly... I decided to unmask dev-java/blackdown-jdk-1.4.2.03.

Now.. it's time to emerge that package.. and I got this message after portage checked the md5 (so at the beginning of the emerging...):

Code:

!!!ERROR:dev-java/blackdown-jdk-1.4.2.03 failed.
!!!Function src_unpack, Line 61, Exitcode 0.
!!!Failed to get offset of tarball!



What am I supposed to do???
_________________
GoogleTalk: romanovic@gmail.com


Last edited by makaveli87 on Thu Jul 20, 2006 7:20 am; edited 1 time in total
Back to top
View user's profile Send private message
oKtosiTe
Tux's lil' helper
Tux's lil' helper


Joined: 15 Aug 2005
Posts: 122
Location: Halmstad, Sweden

PostPosted: Tue Jul 18, 2006 5:19 pm    Post subject: Reply with quote

The -r[number] a lot of package names end with are their revision number. This usually means the higher numbered one is the one you want...
_________________
Ask Ubuntu | Super User
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Tue Jul 18, 2006 8:21 pm    Post subject: Reply with quote

ehm... I don't understand what I have to do then....
If emerge want to emerge that package... ca I change it and choose the r12 ???
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Jul 18, 2006 8:22 pm    Post subject: Reply with quote

There is no blackdown port for PPC of any recent (>= java-1.4) release. Since they're binaries, no amount of keywording is going to help you out. On PPC, we suggest IBM's JDK instead.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Tue Jul 18, 2006 8:24 pm    Post subject: Reply with quote

Code:
# Please use IBM's Java instead on PPC
# Masked because there are better options and security issues with this version

Usually gentoo developers don't put such messages in ebuilds without good reason.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Tue Jul 18, 2006 8:31 pm    Post subject: Reply with quote

Ok... I thought it too.... but I'm a newbie.. I asked to a person (but it ha gentoo on x86.. maybe he didn't know that..) and he told me to unmask the package...


Now, what can I do to solve this problem??



(I already have ibm-jdk-bin 1.4.2.03
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Wed Jul 19, 2006 9:39 am    Post subject: Reply with quote

So....
I masked again the blackdown so now I have again the message:
Code:

These are the packages that I would merge, in order:

Calculating dependencies   
!!! All ebuilds that could satisfy "dev-java/blackdown-jdk" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-java/blackdown-jdk-1.3.1-r23 (masked by: ~ppc keyword)
- dev-java/blackdown-jdk-1.3.1-r8 (masked by: ~ppc keyword)
- dev-java/blackdown-jdk-1.4.1-r1 (masked by: -* keyword)
- dev-java/blackdown-jdk-1.3.1-r10 (masked by: package.mask)
# Joseph Jezak <josejx@gentoo.org> (05 Mar 2006)
# Please use IBM's Java instead on PPC
# Masked because there are better options and security issues with this version

- dev-java/blackdown-jdk-1.4.1-r12 (masked by: -* keyword)
- dev-java/blackdown-jdk-1.4.2.03-r2 (masked by: -* keyword)
- dev-java/blackdown-jdk-1.4.2.03-r12 (masked by: -* keyword)
- dev-java/blackdown-jdk-1.4.2.03 (masked by: -* keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
section 2.2 "Software Availability" in the Gentoo Handbook.
!!!    (dependency required by "sys-libs/db-4.2.52_p2-r1" [ebuild])


And.... what can I do now.?????
How can I use IBM jdk if it is my default Java vm???

EDIT: Maybe I find something...


EDIT2: Can I have only the IBM-jdk-bin SR5 ??
Can I unmerge blackdown 1.3 ???
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Jul 19, 2006 1:36 pm    Post subject: Reply with quote

Why are you still trying to emerge blackdown? Are you sure you don't have any x86 keywords in /etc/make.conf or /etc/portage? What does emerge virtual/jdk -pv show?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Wed Jul 19, 2006 1:50 pm    Post subject: Reply with quote

I asked if I can do:
# emerge -C blackdown-jdk

because now I don't use it anymore, but I think it's installed ...

btw:
Code:

# emerge virtual/jdk -pv

These are the packages that would be merged, in order:

Calculating dependencies   ... done!
[ebuild  NSF  ] dev-java/ibm-jdk-bin-1.5.0-r11  USE="X -javacomm -nsplugin" 64,193 kB
[ebuild  N    ] virtual/jdk-1.5.0  0 kB

Total size of downloads: 64,193 kB


_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Thu Jul 20, 2006 7:20 am    Post subject: Reply with quote

I put the tag SOLVED.
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Jul 20, 2006 2:47 pm    Post subject: Reply with quote

Did you get it working then? What was the problem?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Thu Jul 20, 2006 3:05 pm    Post subject: Reply with quote

I didn't know anything about the new Java system...After some search in this forum I found the guide, followed it and after some little problems I solved deleting the old blackdown jdk and installing the ibm-jdk.

Now I have some problems.. but I open a new thread.
Thanks to all!
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum