Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem building graphviz-2.6-r1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Wed Jul 19, 2006 4:28 am    Post subject: problem building graphviz-2.6-r1 Reply with quote

Hi guys,

I hit a spot of trouble this morning I edited my use flags in /etc/make.conf
to reflect the fact that tcltk is now separated in tcl and tk.
I then did an emerge -Dv --newuse world. One of the package where the
flags have changed is graphviz-2.6-r1.

I started emerging the various packages concerned and then suddenly
my computer became very slow. I found out that portage was configuring
graphviz and was stop checking for ruby. top revealed that the memory
usage of configure was going through the roof (88% and both ram and swap
were in short supply I have 512MB of both) and then it froze hard.
I tried to ssh from another computer but ssh never got to the password stage
in 10mn (strangely enough it didn't close the connection either so there may
have been some very slow communication).

After rebooting I tried a second time-same place the config script started to eat
memory but it didn't freeze. My konsole just diseapered, logged remotely and
killed the config script. Somehow kwin must have broken down in the process
as new windows didn't have decorations or borders, logging out an in again
took care of that.

I decided to leave it alone for now and poll the forum before filling a bug for this.
For info I am on a G4 iMac:
Code:
emerge --info
Portage 2.1-r1 (default-linux/ppc/ppc32/2006.1/G4, gcc-4.1.1, glibc-2.4-r3, 2.6.16-gentoo-r5 ppc)
=================================================================
System uname: 2.6.16-gentoo-r5 ppc 7450, altivec supported
Gentoo Base System version 1.6.15
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r4
ACCEPT_KEYWORDS="ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mtune=G4 -mcpu=G4 -maltivec -mabi=altivec -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS=""
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.vic.keypoint.com.au http://mirrors.tds.net/gentoo ftp://mirrors.tds.net/gentoo http://mirror.tucdemonic.org/gentoo/"
LC_ALL="en_GB.UTF-8"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/science"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="ppc X a52 aac aalib alsa altivec arts audiofile berkdb bitmap-fonts bonobo bzip2 cairo cddb cdf cdparanoia cdr cli crypt cups curl dlloader dri dts dv dvd dvdr dvdread emboss encode esd expat f77 ffmpeg firefox flac foomaticdb fortran gdbm gif gmp gpm graphviz gstreamer gtk gtk2 gtkhtml hal idn ieee1394 imagemagick imlib2 ipv6 isdnlog java jbig jpeg jpeg2k kde kdexdeltas lcms libg++ libwww live lzo mad mikmod mjpeg mng mp3 mpeg ncurses netcdf network nls nptl nptlonly ogg openexr opengl oss pam pcre pdf pdflib perl png ppds pppd python qt qt3 qt4 quicktime rdesktop readline reflection ruby samba sdl session slang slp spell spl ssl svg szip tcl tcltk tcpd tetex theora tiff tk truetype truetype-fonts type1-fonts udev unicode usb vorbis wmf xine xml xml2 xmms xorg xv xvid zeroconf zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev kernel_linux userland_GNU video_cards_fbdev video_cards_nv video_cards_vga"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum