Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Powerpc blender / xorg issue?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Forty-Two
n00b
n00b


Joined: 14 Jul 2003
Posts: 54

PostPosted: Thu Jul 20, 2006 1:16 am    Post subject: Powerpc blender / xorg issue? Reply with quote

I had posted this issue elsewhere, but I haven't seen other people with this problem, so I thought (hoped) that maybe it was a ppc specific issue.

Anyways, I've been having problems with getting kicked out of my X session, and back into KDM. It only happens when I am in blender, and then it happens randomly (but always following a keystroke). I've reinstalled the system in hopes that the problem would magicaly go away, but had no such luck. To be honest, I'm not sure if the problem lies with Blender, or xorg.

My system:
Quote:
Portage 2.1-r1 (default-linux/ppc/ppc32/2006.0/G4, gcc-4.1.1, glibc-2.4-r3, 2.6.16-gentoo-r9 ppc)
=================================================================
System uname: 2.6.16-gentoo-r9 ppc 7450, altivec supported
Gentoo Base System version 1.6.15
app-admin/eselect-compiler: [Not Present]
dev-lang/python: 2.3.5, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache: [Not Present]
dev-util/confcache: [Not Present]
sys-apps/sandbox: 1.2.17
sys-devel/autoconf: 2.13, 2.59-r7
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils: 2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.11-r4
ACCEPT_KEYWORDS="ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mtune=powerpc -pipe"
CHOST="powerpc-unknown-linux-gnu"
...


Blender is version 2.42 (also happens in 2.41), and xorg-x11 is 7.1.0. Any help would be wonderful, as I rather need a working blender. :)

xorg.conf
Xorg.0.log (has a backtrace)
_________________
"We appologize for the inconvenince"
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Jul 20, 2006 2:53 pm    Post subject: Reply with quote

Blender works fine on my Radeon with 7.1, I suspect it might be a software rendering problem. I would report the issue upstream (MESA) and see what they have to say about it. That said, I'm not sure how well it's going to run even if it stops crashing, nvidia is an awful choice for anything 3D related on PPC.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum