Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Help configuring Xorg
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
veonline
n00b
n00b


Joined: 21 Mar 2005
Posts: 58

PostPosted: Wed Jul 26, 2006 2:09 pm    Post subject: Reply with quote

JoseJX wrote:

veonline:
Do you need help with getting X working too?


you are really kind, but no thanks, i've got X working on the g5, i was referring about the ubuntu livecd :P
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Wed Jul 26, 2006 5:02 pm    Post subject: Reply with quote

With Kubuntu after some problems I started kde!

This is the Xorg.conf
Code:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "i2c"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "type1"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ExplorerPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "ATI Technologies, Inc. Rage 128 PF/PRO AGP 4x TMDS"
   Driver      "ati"
   BusID      "PCI:0:16:0"
   Option      "UseFBDev"      "true"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   28-51
   VertRefresh   43-60
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI Technologies, Inc. Rage 128 PF/PRO AGP 4x TMDS"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus" "SendCoreEvents"
   InputDevice     "cursor" "SendCoreEvents"
   InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection



JoseJX.. i'll try! (but I don't understand what I have to do...
# nano ~/.xinitrc
___ nano___
xterm
The I save and exit and then launch startx???)
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Jul 26, 2006 5:07 pm    Post subject: Reply with quote

Yes. I'm fairly sure you don't have a problem with your xorg.conf, but I don't know what isn't "working" when you type startx. There's no error that would cause it to stop in the text you posted previously.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Wed Jul 26, 2006 6:48 pm    Post subject: Reply with quote

I changed HorizSync and VertRefresh according to the xorg.conf copied from kubuntu.
It works but I have some little problems with configuration....
Before putting the tag SOLVED I want to solve those...

Thanks to all!!

EDIT: solved....
only some little questions not worthing the opening of a discussion...
1) can I use the special keys of an Apple Keyboard (volume, eject...)
2).. i don't remember :D
_________________
GoogleTalk: romanovic@gmail.com
Back to top
View user's profile Send private message
Grexe
n00b
n00b


Joined: 26 Oct 2005
Posts: 29
Location: Vienna

PostPosted: Mon Aug 14, 2006 6:35 pm    Post subject: Works with latest xautoconfig Reply with quote

I learnt it the hard way (did not know about Xautoconfig), and solved the issue with fixing the sync-settings.
However, out of curiosity, I tried the latest Xautoconfig 0.2.2, and it detected everything correctly in a second..!
Maybe worth adding to the wiki/modular X-docs:)
Using a Powerbook Titanium G4, XOrg 7.1, gcc 4.1.1 - even the widescreen-resolution of 1152x768 was detected properly!
Many thanks.
_________________
There are two states of gentoo boxes: compiling and turned off...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum