Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Yaboot problems: dual-boot [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
theholymac
n00b
n00b


Joined: 28 Jun 2006
Posts: 56
Location: Probably at the solar car shop in St. Paul

PostPosted: Sat Jul 22, 2006 6:36 am    Post subject: Yaboot problems: dual-boot [SOLVED] Reply with quote

I've been getting used to Gentoo of the past week, and tonight I finally got around to re-installing 10.4 on the partition I'd set away for it. I had to go into open firmware to manually make it look to the bootstrap partition to boot instead of going straight to OSX, but now I'm stuck in linux. I can't for the life of me figure out how to get my OSX partition to show up as a boot option in yaboot.

Partitions:
1. Apple partition map
2. Bootstrap
3. Swap
4. Linux
5. Mac OSX

yaboot.conf:

Code:
boot=/dev/hda2
device=/pci@f2000000/mac-io@17/ata-4@1f000/disk@0:

delay=10
defaultos=Linux
timeout=30
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot

image=/boot/2.6.16-gentoo-r9
     label=Linux
     root=/dev/hda4
     partition=4
     read-only

macosx=/dev/hda5
enablecdboot
enableofboot


Any ideas?

Thanks!


Last edited by theholymac on Sat Jul 22, 2006 2:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sat Jul 22, 2006 12:00 pm    Post subject: Reply with quote

Don't forget to run ybin -v after updating yaboot.conf
You could try changing macosx=/dev/hda5 into macosx=hd:5
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
theholymac
n00b
n00b


Joined: 28 Jun 2006
Posts: 56
Location: Probably at the solar car shop in St. Paul

PostPosted: Sat Jul 22, 2006 2:42 pm    Post subject: Reply with quote

nixnut wrote:
Don't forget to run ybin -v after updating yaboot.conf


*headdesk*

It's always the obvious stuff that you forget, that'll probably do it.

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum