Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
ueulo
n00b
n00b


Joined: 13 Jul 2006
Posts: 15

PostPosted: Fri Jul 28, 2006 7:38 am    Post subject: Emerge problem Reply with quote

For example when i try emerge konsole,eterm,mplayer...I get this error

Code:
!!! ERROR: x11-libs/gtk+-2.8.19 failed.
Call stack:
  ebuild.sh, line 1555:   Called dyn_compile
  ebuild.sh, line 668:   Called src_compile
  gtk+-2.8.19.ebuild, line 57:   Called die

!!! cairo needs the X flag set
!!! If you need support, post the topmost build error, and the call stack if relevant.


Please ,help
Back to top
View user's profile Send private message
acturneruk
Apprentice
Apprentice


Joined: 06 Feb 2005
Posts: 162
Location: UK

PostPosted: Fri Jul 28, 2006 7:40 am    Post subject: Reply with quote

Er, do you have the X flag set for cairo?
Back to top
View user's profile Send private message
zurd
Apprentice
Apprentice


Joined: 17 Dec 2003
Posts: 228
Location: Canada, Montreal

PostPosted: Fri Jul 28, 2006 7:42 am    Post subject: Reply with quote

Yeah maybe just a
USE="X" emerge cairo
then emerge something will be just fine
Back to top
View user's profile Send private message
Sedrik
l33t
l33t


Joined: 08 Apr 2005
Posts: 655
Location: Uppsala, Sweden

PostPosted: Fri Jul 28, 2006 7:43 am    Post subject: Reply with quote

either do
Code:
USE="X" emerge <program you where emergin with emerge flags>


or edit your make.conf to include X in the global use settings (This is what I would recommend)
_________________
From Gentoo with love
Back to top
View user's profile Send private message
ueulo
n00b
n00b


Joined: 13 Jul 2006
Posts: 15

PostPosted: Fri Jul 28, 2006 7:43 am    Post subject: Reply with quote

acturneruk wrote:
Er, do you have the X flag set for cairo?


No
Back to top
View user's profile Send private message
acturneruk
Apprentice
Apprentice


Joined: 06 Feb 2005
Posts: 162
Location: UK

PostPosted: Fri Jul 28, 2006 7:45 am    Post subject: Reply with quote

ueulo wrote:
acturneruk wrote:
Er, do you have the X flag set for cairo?


No


Then this may well be the problem :wink:
Back to top
View user's profile Send private message
ueulo
n00b
n00b


Joined: 13 Jul 2006
Posts: 15

PostPosted: Fri Jul 28, 2006 7:53 am    Post subject: Reply with quote

zurd wrote:
Yeah maybe just a
USE="X" emerge cairo
then emerge something will be just fine


Its working,thx
Back to top
View user's profile Send private message
acturneruk
Apprentice
Apprentice


Joined: 06 Feb 2005
Posts: 162
Location: UK

PostPosted: Fri Jul 28, 2006 7:58 am    Post subject: Reply with quote

You will need to add the flag to either make.conf or package.use, otherwise the next time you do an emerge -uDN world, cairo will be re-emerged without the flag again.

See the Gentoo Handbook for more details.

Andrew
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum