Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Installing Xorg 7 - Compile errors? [Thanks!]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Tue Aug 01, 2006 6:39 pm    Post subject: [Solved] Installing Xorg 7 - Compile errors? [Thanks!] Reply with quote

I've been thinking of installing the new Xorg-x11 but I keep getting digest errors. I know how to re-digest them, i'm just not sure if I should... It seems that when I do they don't compile correctly. I was wondering if anyone else has had the same troubles on PPC? 8O

thanks!
:roll:
_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.


Last edited by FadeRanger on Tue Aug 08, 2006 5:34 pm; edited 5 times in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Aug 01, 2006 7:01 pm    Post subject: Reply with quote

Re-sync, and if that doesn't fix it, remove the files that don't match from /usr/portage/distfiles and let portage re-download them. That should fix it. :)
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Tue Aug 01, 2006 7:25 pm    Post subject: Reply with quote

Thanks, I've been trying that for severl days.... Since some of the new Xorg compiled correctly, i've gotten the list of packages and have unistalled them and will try again.... Thank you! :D

Oh yes.... I was using gcc 4.x to compile, is this not recommended? It seems like most things work fine with the new GCC so I use it for everything. Thanks! :D


I do have to say that of the Linux Distributions I have used, Gentoo has by far has the most helpful documentation and community based help. I've been using it since May and any probelm which I've encountered could either be fixed with a little tinkering or by searching the forums and Wiki. Everyday I learn something new! Thank you! :)
_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Aug 01, 2006 8:08 pm    Post subject: Reply with quote

Yes, we recommend using GCC-4.1 since that's now our stable compiler.

Glad you like the distro, feel free to post again if you need more help with this.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Tue Aug 01, 2006 10:40 pm    Post subject: Reply with quote

Hmmmm...... I tried the re-sync and download again..... i'm doing a fetch only first because I dont' have an internet connection at home yet and I can only get the dist files at work and take them home to compile. When I unmerged the packages from Xorg 7.0 which HAD compiled, it broke a bunch of stuff that uses X11. I'm revdep-rebuilding now and hoping that fixes it before I try to install again. I'm hoping it fixes firefox so I can post the build and/or digest errors and my USE flags. :roll:


Well.... okay, it works but it seems like revdep is finding a bunch of stuff to build anyways so I'll probably be busy for a day or so... I'll try again when it's done building. thanks!!! :)
_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.
Back to top
View user's profile Send private message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Fri Aug 04, 2006 5:24 pm    Post subject: Reply with quote

Here's some of the fetch errors which I encounter when I try to merge Xorg 7. I've cleaned the distfiles and re-synced and re-downloaded to no avial... 8O

>>> Emerging (3 of 88) x11-libs/libXScrnSaver-1.1.0 to /
>>> Downloading http://distfiles.gentoo.org/distfiles/libXScrnSaver-1.1.0.tar.bz2
--10:07:43-- http://distfiles.gentoo.org/distfiles/libXScrnSaver-1.1.0.tar.bz2
=> `/usr/portage/distfiles/libXScrnSaver-1.1.0.tar.bz2'
Resolving distfiles.gentoo.org... 216.165.129.135, 156.56.247.195, 64.50.236.52, ...
Connecting to distfiles.gentoo.org|216.165.129.135|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 226,956 (222K) [application/x-tar]

100%[================================================================================>] 226,956 131.55K/s

10:07:46 (131.25 KB/s) - `/usr/portage/distfiles/libXScrnSaver-1.1.0.tar.bz2' saved [226956/226956]

>>> libXScrnSaver-1.1.0.tar.bz2 MD5 ;-)
>>> libXScrnSaver-1.1.0.tar.bz2 RMD160 ;-)
>>> libXScrnSaver-1.1.0.tar.bz2 SHA1 ;-)
>>> libXScrnSaver-1.1.0.tar.bz2 SHA256 ;-)
>>> libXScrnSaver-1.1.0.tar.bz2 size ;-)
>>> checking ebuild checksums
!!! Digest verification failed:
!!! /usr/portage/x11-libs/libXScrnSaver/libXScrnSaver-1.1.0.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 552
!!! Expected: 557

!!! Fetch for /usr/portage/x11-libs/libXScrnSaver/libXScrnSaver-1.1.0.ebuild failed, continuing...




>>> libXdamage-1.0.3.tar.bz2 MD5 ;-)
>>> libXdamage-1.0.3.tar.bz2 RMD160 ;-)
>>> libXdamage-1.0.3.tar.bz2 SHA1 ;-)
>>> libXdamage-1.0.3.tar.bz2 SHA256 ;-)
>>> libXdamage-1.0.3.tar.bz2 size ;-)
>>> checking ebuild checksums
!!! Digest verification failed:
!!! /usr/portage/x11-libs/libXdamage/libXdamage-1.0.3.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 664
!!! Expected: 669

!!! Fetch for /usr/portage/x11-libs/libXdamage/libXdamage-1.0.3.ebuild failed, continuing...


>>> Downloading http://distfiles.gentoo.org/distfiles/x11-driver-patches-1.tar.bz2
--10:13:34-- http://distfiles.gentoo.org/distfiles/x11-driver-patches-1.tar.bz2
=> `/usr/portage/distfiles/x11-driver-patches-1.tar.bz2'
Resolving distfiles.gentoo.org... 216.165.129.135, 156.56.247.195, 64.50.236.52, ...
Connecting to distfiles.gentoo.org|216.165.129.135|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 389 [application/x-tar]

100%[================================================================================>] 389 --.--K/s

10:13:35 (48.95 KB/s) - `/usr/portage/distfiles/x11-driver-patches-1.tar.bz2' saved [389/389]

>>> x11-driver-patches-1.tar.bz2 MD5 ;-)
>>> x11-driver-patches-1.tar.bz2 RMD160 ;-)
>>> x11-driver-patches-1.tar.bz2 SHA1 ;-)
>>> x11-driver-patches-1.tar.bz2 SHA256 ;-)
>>> x11-driver-patches-1.tar.bz2 size ;-)
>>> checking ebuild checksums
!!! Digest verification failed:
!!! /usr/portage/x11-drivers/xf86-video-vesa/xf86-video-vesa-1.2.1.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 590
!!! Expected: 592

!!! Fetch for /usr/portage/x11-drivers/xf86-video-vesa/xf86-video-vesa-1.2.1.ebuild failed, continuing...


>>> Emerging (78 of 88) x11-drivers/xf86-video-fbdev-0.3.0 to /
>>> Downloading http://distfiles.gentoo.org/distfiles/xf86-video-fbdev-0.3.0.tar.bz2
--10:13:35-- http://distfiles.gentoo.org/distfiles/xf86-video-fbdev-0.3.0.tar.bz2
=> `/usr/portage/distfiles/xf86-video-fbdev-0.3.0.tar.bz2'
Resolving distfiles.gentoo.org... 216.165.129.135, 156.56.247.195, 64.50.236.52, ...
Connecting to distfiles.gentoo.org|216.165.129.135|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 231,592 (226K) [application/x-tar]

100%[================================================================================>] 231,592 157.97K/s

10:13:37 (157.49 KB/s) - `/usr/portage/distfiles/xf86-video-fbdev-0.3.0.tar.bz2' saved [231592/231592]

>>> xf86-video-fbdev-0.3.0.tar.bz2 MD5 ;-)
>>> xf86-video-fbdev-0.3.0.tar.bz2 RMD160 ;-)
>>> xf86-video-fbdev-0.3.0.tar.bz2 SHA1 ;-)
>>> xf86-video-fbdev-0.3.0.tar.bz2 SHA256 ;-)
>>> xf86-video-fbdev-0.3.0.tar.bz2 size ;-)
>>> Previously fetched file: x11-driver-patches-1.tar.bz2 MD5 ;-)
>>> Previously fetched file: x11-driver-patches-1.tar.bz2 RMD160 ;-)
>>> Previously fetched file: x11-driver-patches-1.tar.bz2 SHA1 ;-)
>>> Previously fetched file: x11-driver-patches-1.tar.bz2 SHA256 ;-)
>>> Previously fetched file: x11-driver-patches-1.tar.bz2 size ;-)
>>> checking ebuild checksums
!!! Digest verification failed:
!!! /usr/portage/x11-drivers/xf86-video-fbdev/xf86-video-fbdev-0.1.0.5.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 610
!!! Expected: 613

!!! Fetch for /usr/portage/x11-drivers/xf86-video-fbdev/xf86-video-fbdev-0.3.0.ebuild failed, continuing...


>>> xf86-input-keyboard-1.1.0.tar.bz2 MD5 ;-)
>>> xf86-input-keyboard-1.1.0.tar.bz2 RMD160 ;-)
>>> xf86-input-keyboard-1.1.0.tar.bz2 SHA1 ;-)
>>> xf86-input-keyboard-1.1.0.tar.bz2 SHA256 ;-)
>>> xf86-input-keyboard-1.1.0.tar.bz2 size ;-)
>>> Previously fetched file: x11-driver-patches-1.tar.bz2 MD5 ;-)
>>> Previously fetched file: x11-driver-patches-1.tar.bz2 RMD160 ;-)
>>> Previously fetched file: x11-driver-patches-1.tar.bz2 SHA1 ;-)
>>> Previously fetched file: x11-driver-patches-1.tar.bz2 SHA256 ;-)
>>> Previously fetched file: x11-driver-patches-1.tar.bz2 size ;-)
>>> checking ebuild checksums
!!! Digest verification failed:
!!! /usr/portage/x11-drivers/xf86-input-keyboard/xf86-input-keyboard-1.0.1.3.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 601
!!! Expected: 604

!!! Fetch for /usr/portage/x11-drivers/xf86-input-keyboard/xf86-input-keyboard-1.1.0.ebuild failed, continuing...

_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Fri Aug 04, 2006 5:49 pm    Post subject: Reply with quote

Are you sure that the sync went correctly? It's failing on the digest for the ebuild, not on the files. In CVS, the correct size is 552, just as you've got there and the Manifest reflects that, but it seems yours doesn't. Are you excluding manifests from your sync or anything weird like that? Can you try deleting the manifest files that aren't working and then re-sync and see if that fixes it?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Sat Aug 05, 2006 6:47 pm    Post subject: Reply with quote

JoseJX wrote:
Are you excluding manifests from your sync or anything weird like that? Can you try deleting the manifest files that aren't working and then re-sync and see if that fixes it?


I'm not excluding any manifests from my sync as far as I know, or at least I've never intentionally done it. Are the manifests located in /usr/portage/<package group>/<package name>/ ??
_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.
Back to top
View user's profile Send private message
corsair
Retired Dev
Retired Dev


Joined: 06 Oct 2003
Posts: 451
Location: Aachen, Germany

PostPosted: Sat Aug 05, 2006 7:03 pm    Post subject: Reply with quote

FadeRanger wrote:
Are the manifests located in /usr/portage/<package group>/<package name>/ ??


yes, they are. and they should be updated with a normal "emerge --sync"
Back to top
View user's profile Send private message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Sat Aug 05, 2006 7:45 pm    Post subject: Reply with quote

corsair wrote:
yes, they are. and they should be updated with a normal "emerge --sync"


Hmmm.... I removed all the manifest files and re-synced and the digest errors are gone. I will try the compile tonight and cross my fingers. :) :D Thanks!!!!
_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.
Back to top
View user's profile Send private message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Mon Aug 07, 2006 7:09 pm    Post subject: Reply with quote

Now the first package of xorg-x11 fails to build.....

xhost.c:204: error: 'local_xerror' undeclared (first use in this function)
xhost.c:212: error: 'enabled' undeclared (first use in this function)

and a list of similar errors about undeclared functions. Any ideas? :?
_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Mon Aug 07, 2006 8:04 pm    Post subject: Reply with quote

Post your emerge --info please.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Mon Aug 07, 2006 8:13 pm    Post subject: Reply with quote

emerge --info
\Portage 2.1-r2 (default-linux/ppc/ppc32/2006.0/G4, gcc-4.1.1, glibc-2.4-r3, 2.6.16-gentoo-r13 ppc)
=================================================================
System uname: 2.6.16-gentoo-r13 ppc 7447/7457, altivec supported
Gentoo Base System version 1.6.15
ccache version 2.3 [disabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python: 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache: 2.3
dev-util/confcache: [Not Present]
sys-apps/sandbox: 1.2.17
sys-devel/autoconf: 2.13, 2.59-r7
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils: 2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.11-r4
ACCEPT_KEYWORDS="ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=G4 -mtune=G4 -maltivec -mabi=altivec -fno-strict-aliasing -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -mcpu=G4 -mtune=G4 -maltivec -mabi=altivec -fno-strict-aliasing -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="ppc X aac alsa altivec apache2 apm arts bcmath berkdb bitmap-fonts bonobo cdr clamav cli crypt cups curl dri dvd eds emboss encode esd ethereal firefox foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtkhtml hal ieee1394 imagemagick imlib ipod ipv6 isdnlog jack javascript jpeg ldap libg++ libwww mad mikmod motif mozilla mp3 mpeg ncurses nls npltonly nptl nptlonly nv objc objc++ ogg opengl pam pbbuttonsd pcre pdflib perl pmu png pppd python qt qt3 qt4 quicktime readline reflection ruby sdl session spell spl ssl svg tcpd tiff truetype truetype-fonts type1-fonts udev unicode usb verbose vnc vorbis wifi wmf xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_nv video_cards_fbdev video_cards_vesa"
Unset: CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.
Back to top
View user's profile Send private message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Mon Aug 07, 2006 9:21 pm    Post subject: Reply with quote

BTW, do I need all of the old verisons of automake and autoconf?

sys-devel/autoconf: 2.13, 2.59-r7
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.
Back to top
View user's profile Send private message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Mon Aug 07, 2006 10:43 pm    Post subject: Reply with quote

I just tried re-compiling xorg 6.8.2-r8 again just to see and it failed as well.... I wonder if I unmerged something which is causing the build to break. :?
_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.
Back to top
View user's profile Send private message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Tue Aug 08, 2006 12:06 am    Post subject: Reply with quote

Hmmm.... Now it's telling me that there are several packages which were installed that are blocking the Xorg 6.8, these must have been from the failed build of 7.0. I'm unmerging and building again. Then I'll package up the 6.8 and unmerge to install the 7.1. Maybe that'll work! :)
_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Tue Aug 08, 2006 1:41 am    Post subject: Reply with quote

FadeRanger wrote:
I just tried re-compiling xorg 6.8.2-r8 again just to see and it failed as well.... I wonder if I unmerged something which is causing the build to break. :?

I would be surprised if you build xorg.x11-6.8 with gcc4.1.1 and glibc2.4.
If I remember it fails on opengl components (the version of mesa included
in 6.8 doesn't like the version of gcc or glibc) if you really want to build it
you need to do it with
Code:
USE="-opengl -xv"
if I remember well.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Aug 08, 2006 2:07 am    Post subject: Reply with quote

Yes, you need those versions of automake, etc.

I think you should focus on getting xorg 7 installed. Can you give the whole log for the package that failed?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
FadeRanger
n00b
n00b


Joined: 25 Jul 2006
Posts: 16
Location: Glen Ellen, CA

PostPosted: Tue Aug 08, 2006 5:06 pm    Post subject: Reply with quote

Yippie!!! It installed seamlessly. I think I had some old packages from a previously failed 7 installation which I hadn't realized needed to be unmerged. Everything works great. The only discrepency is when I start Gnome I get an error message about
<---------------------------------------------->
Error activating XKB configuration.
It can happen under various circumstances:
- a bug in libxklavier library
- a bug in X server (xkbcomp, xmodmap utilities)
- X server with incompatible libxkbfile implementation
<---------------------------------------------->

but everything seems to work despite the error. Woohoo!! :lol: :) :D :wink:
_________________
"One has a moral responsibility to disobey unjust laws."
-Martin Luther King, Jr.

Apple Aluminum PowerBook G4 1ghz, 768 RAM, nVidia GPU and
a Pentium II 233, 128RAM conglomeration of funkiness.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum