Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] java upgrade on ppc: 1.4 and 1.5 jdk?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
iMike
Apprentice
Apprentice


Joined: 01 Apr 2005
Posts: 217
Location: Stockholm, Sweden

PostPosted: Fri Aug 04, 2006 11:58 am    Post subject: [SOLVED] java upgrade on ppc: 1.4 and 1.5 jdk? Reply with quote

I was trying to follow the Gentoo Java Upgrade Guide on a PPC but am not clear how to get both a 1.5 and 1.4 JDK. After adding the suggested items to package.keywords, it's easy to get a 1.5 JDK, namely, dev-java/ibm-jdk-bin-1.5.0.2. It's also easy to get a 1.3 JDK, like dev-java/blackdown-jdk-1.3.1-r23. However, if I try to get blackdown-jdk 1.4.x, it suggests using IBM's JDK instead. It appears the only choice left is to have both IBM's 1.4 and 1.5 JDK. Is that correct? If so, is one supposed to SLOT them differently? How? I searched around for more on SLOTing on Gentoo but didn't find anything too helpful, except that the MYSQL project had to back away from it and some other flame stuff saying SLOTs don't work well under Gentoo. Anyone got any tips on trying the java upgrade and/or slotting?

Best regards,
/iMike


Last edited by iMike on Mon Aug 07, 2006 12:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
nelchael
Retired Dev
Retired Dev


Joined: 20 Mar 2004
Posts: 1948
Location: /dev/drzewo

PostPosted: Fri Aug 04, 2006 1:21 pm    Post subject: Re: java upgrade on ppc: 1.4 and 1.5 jdk? Reply with quote

iMike wrote:
It appears the only choice left is to have both IBM's 1.4 and 1.5 JDK. Is that correct?

Yes
iMike wrote:
If so, is one supposed to SLOT them differently? How?


Code:
nelchael@nelchael ~$ cd gentoo-x86/dev-java/ibm-jdk-bin/
nelchael@nelchael ibm-jdk-bin$ grep ^SLOT *
ibm-jdk-bin-1.4.2.03.ebuild:SLOT="1.4"
ibm-jdk-bin-1.4.2.04-r10.ebuild:SLOT="1.4"
ibm-jdk-bin-1.4.2.04.ebuild:SLOT="1.4"
ibm-jdk-bin-1.4.2.5.ebuild:SLOT="1.4"
ibm-jdk-bin-1.5.0-r11.ebuild:SLOT="1.5"
ibm-jdk-bin-1.5.0.2.ebuild:SLOT="1.5"
ibm-jdk-bin-1.5.0.ebuild:SLOT="1.5"
nelchael@nelchael ibm-jdk-bin$


Just do:

Code:
emerge -av1 '=ibm-jdk-bin-1.4*' '=ibm-jdk-1.5*'

_________________
[color=gray:17697d0166]http://dev.gentoo.org/~nelchael/[/color:17697d0166]

[size=14:17697d0166]>> [b:17697d0166]Zasady na f.g.o->Polish[/b:17697d0166] <<[/size:17697d0166]
Back to top
View user's profile Send private message
iMike
Apprentice
Apprentice


Joined: 01 Apr 2005
Posts: 217
Location: Stockholm, Sweden

PostPosted: Mon Aug 07, 2006 12:25 pm    Post subject: [SOLVED] java upgrade on ppc: 1.4 and 1.5 jdk? Reply with quote

Thanks you! Your suggestion, with slight mod to include "-bin" in the 1.5 version,

Code:
emerge -av1 '=ibm-jdk-bin-1.4*' '=ibm-jdk-bin-1.5*'


worked perfect!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum