Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Mac Mini and linux-2.6.17 troubles: RTC and reboot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2584
Location: userland

PostPosted: Tue Aug 08, 2006 6:35 pm    Post subject: [SOLVED] Mac Mini and linux-2.6.17 troubles: RTC and reboot Reply with quote

Hi! After an upgrade to gentoo-sources-2.6.17 on my Mac Mini, two things stopped working:
1) Upon
Code:
shutdown -r now

i get a message that it's OK to turn off the power, but no reboot happens.
2) I can't find a valid configuration to get a working real time clock, so that updating system time on boot fails and my box thinks it's the year 1970. With the arrival of the new RTC kernel subsystem, the SENSORS_RTC8564 driver was replaced by RTC_DRV_PCF8563. For about two weeks now I've been trying various combinations of kernel settings with no avail. Either no /dev/misc/rtc isn't created or it is not functional.

You wouldn't happen to have a working .config-2.6.17 for Mac Mini (or G4 PowerBook) lying around? Anyone?


Last edited by Voltago on Sun Aug 13, 2006 2:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Aug 13, 2006 9:39 am    Post subject: Reply with quote

Here's mine. I didn't change anything with regards to rtc compared to earlier kernels. Works for me.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Voltago
Advocate
Advocate


Joined: 02 Sep 2003
Posts: 2584
Location: userland

PostPosted: Sun Aug 13, 2006 2:13 pm    Post subject: Reply with quote

Rebooting and RTC work fine again, thanks nixnut!

I'll include the important kernel config options for RTC (I2C subsystem and RTC settings)
Code:
root@laplace 2.6.17-gentoo-r4 # cat config | grep -E '(RTC|I2C)'
CONFIG_GEN_RTC=y
# CONFIG_GEN_RTC_X is not set
# I2C support
CONFIG_I2C=y
CONFIG_I2C_CHARDEV=m
# I2C Algorithms
CONFIG_I2C_ALGOBIT=y
# CONFIG_I2C_ALGOPCF is not set
# CONFIG_I2C_ALGOPCA is not set
# I2C Hardware Bus support
# CONFIG_I2C_ALI1535 is not set
# CONFIG_I2C_ALI1563 is not set
# CONFIG_I2C_ALI15X3 is not set
# CONFIG_I2C_AMD756 is not set
# CONFIG_I2C_AMD8111 is not set
# CONFIG_I2C_I801 is not set
# CONFIG_I2C_I810 is not set
# CONFIG_I2C_PIIX4 is not set
CONFIG_I2C_POWERMAC=y
# CONFIG_I2C_MPC is not set
# CONFIG_I2C_NFORCE2 is not set
# CONFIG_I2C_PARPORT_LIGHT is not set
# CONFIG_I2C_PROSAVAGE is not set
# CONFIG_I2C_SAVAGE4 is not set
# CONFIG_I2C_SIS5595 is not set
# CONFIG_I2C_SIS630 is not set
# CONFIG_I2C_SIS96X is not set
# CONFIG_I2C_STUB is not set
# CONFIG_I2C_VIA is not set
# CONFIG_I2C_VIAPRO is not set
# CONFIG_I2C_VOODOO3 is not set
# CONFIG_I2C_PCA_ISA is not set
# Miscellaneous I2C Chip support
# CONFIG_I2C_DEBUG_CORE is not set
# CONFIG_I2C_DEBUG_ALGO is not set
# CONFIG_I2C_DEBUG_BUS is not set
# CONFIG_I2C_DEBUG_CHIP is not set
CONFIG_FB_RADEON_I2C=y
# CONFIG_RTC_CLASS is not set
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum