Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ruby fails to emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Thu Aug 17, 2006 2:54 pm    Post subject: ruby fails to emerge Reply with quote

I'm trying to emerge gvim. /dev-lang/ruby-1.8.4-r3 is brought in as dependency and fails during the emerge.
Code:
checking for compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.
make: *** [config.status] Error 77

!!! ERROR: dev-lang/ruby-1.8.4-r3 failed.
Call stack:
   ebuild.sh, line 1539:    Called dyn_compile
   ebuild.sh, line 939:    Called src_compile
   ruby-1.8.4-r3.ebuild, line 94:    Called die

!!! emake failed

I'm on ppc.
_________________
gentoo good to be true
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9265

PostPosted: Thu Aug 17, 2006 5:25 pm    Post subject: Reply with quote

Three options:
  1. Set USE -ruby while emerging gvim.
  2. Post the config.log, at least the section relating the failure.
  3. If available, try using a different compiler.

You might want to ask the moderators to move this topic from Portage & Programming to Gentoo on PPC as that might garner more useful traffic.
Back to top
View user's profile Send private message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Thu Aug 17, 2006 6:09 pm    Post subject: Reply with quote

The problem seems to be bigger than ruby so I'm going to post my lastest error and then request this post be moved to ppc. Thanks for the tip. Trying to install xfe file manager now and x11-libs/fox is pulled in. Emerge fails.
Code:
make: *** [all-recursive] Error 1

!!! ERROR: x11-libs/fox-1.2.6-r3 failed.
Call stack:
   ebuild.sh, line 1539:    Called dyn_compile
   ebuild.sh, line 939:    Called src_compile
   fox-1.2.6-r3.ebuild, line 39:    Called die

!!! Parallel Make Failed

_________________
gentoo good to be true
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9265

PostPosted: Thu Aug 17, 2006 6:35 pm    Post subject: Reply with quote

If you can, option 3 is likely your best option.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4923
Location: Gothenburg, Sweden

PostPosted: Thu Aug 17, 2006 6:48 pm    Post subject: Reply with quote

Moved from Portage & Programming to Gentoo on PPC as requested.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Thu Aug 17, 2006 6:59 pm    Post subject: Reply with quote

I don't know how to use a different compiler. I recently upgraded to gcc-4.1.1. Why are many programs failing to compile with this new version?
_________________
gentoo good to be true
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9265

PostPosted: Thu Aug 17, 2006 7:44 pm    Post subject: Reply with quote

You can switch compilers using sys-devel/gcc-config, if you did not unmerge the compiler you upgraded from.
Back to top
View user's profile Send private message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Thu Aug 17, 2006 8:12 pm    Post subject: Reply with quote

If I'm having to switch back to an older compiler to emerge what is starting to look like many more than one program, should gcc-4.1.1 be marked stable on ppc?
_________________
gentoo good to be true
Back to top
View user's profile Send private message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Thu Aug 17, 2006 8:25 pm    Post subject: Reply with quote

Would recompiling my kernel (or even my entire system), now that I have gcc-4.1.1, help to resolve these problems?

Note to self: I have a lot to learn.
_________________
gentoo good to be true
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Thu Aug 17, 2006 11:43 pm    Post subject: Reply with quote

Hello again Bobotoes,

So it seems that gcc-4.1.1 is not working for you. I just checked I have
ruby installed here, no problems. I want you to post the results of a few comands:
Code:
gcc-config -l
and
Code:
emerge --info

I suspect there is something wrong some options of your compiler, more specifically
in your CFLAGS. It can be a cause for config to think that your compiler cannot create
executables - depending on the ebuild.

For info we are several around here to have purely gcc-4.1.1/glibc-2.4-r3 systems
rebuild from scratch, and there is no ebuild at the moment for which I would
need a gcc-3.x compiler, which is not on my system anymore.
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Thu Aug 17, 2006 11:48 pm    Post subject: Reply with quote

Another thing Bobotoes, just posting this isn't helping very much:
bobotoes wrote:

Code:
make: *** [all-recursive] Error 1

!!! ERROR: x11-libs/fox-1.2.6-r3 failed.
Call stack:
   ebuild.sh, line 1539:    Called dyn_compile
   ebuild.sh, line 939:    Called src_compile
   fox-1.2.6-r3.ebuild, line 39:    Called die

!!! Parallel Make Failed

Try to include at least the last call from gcc (or whatever comands cause
the make to fail) please. 8)
Back to top
View user's profile Send private message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Fri Aug 18, 2006 8:14 pm    Post subject: Reply with quote

Code:
# gcc-config -l
 [1] powerpc-unknown-linux-gnu-3.4.4
 [2] powerpc-unknown-linux-gnu-3.4.4-hardened
 [3] powerpc-unknown-linux-gnu-3.4.4-hardenednopie
 [4] powerpc-unknown-linux-gnu-3.4.4-hardenednopiessp
 [5] powerpc-unknown-linux-gnu-3.4.4-hardenednossp
 [6] powerpc-unknown-linux-gnu-4.1.1 *

Code:
# emerge --info
Gentoo Base System version 1.12.4
Portage 2.1-r2 (default-linux/ppc/ppc32/2006.0/G4, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r4 ppc)
=================================================================
System uname: 2.6.17-gentoo-r4 ppc 7455, altivec supported
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r4
ACCEPT_KEYWORDS="ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=7450 -maltivec -mabi=altivec -fno-strict-aliasing -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -mcpu=7450 -maltivec -mabi=altivec -fno-strict-aliasing -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="ppc X alsa altivec apache2 apm berkdb bitmap-fonts bonobo bzip2 cdr cli crypt cups dlloader dri dts dvd dvdr eds emacs emboss encode esd fftw firefox foomaticdb fortran gdbm gif gpm gstreamer gtk gtk2 gtkhtml guile imagemagick imlib ipv6 isdnlog jpeg ldap libg++ libwww mad mikmod motif mozilla mp3 mpeg ncurses nls nptl nptlonly ogg opengl pam pcre pdf pdflib perl plotutils png pppd python quicktime readline reflection ruby sdl session spell spl ssl tcpd tetex tiff truetype truetype-fonts type1-fonts udev unicode usb vorbis wifi xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_radeon"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

After some updating, adding new programs, retrying and messing around... ruby has compiled. x11-libs/fox (the second of the two main errors I posted) continues to fail.
_________________
gentoo good to be true
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Sat Aug 19, 2006 3:48 am    Post subject: Reply with quote

OK.

First can you change your profile from 2006.0 to 2006.1. That may help with a
few things. Now for x11-libs/fox we really need more info from the error message.
For example:
Code:
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../include -I../../include/quicktime -I/usr/include/ffmpeg -O3 -funroll-all-loops -fomit-frame-pointer -finline-functions -Wall -Winline -MT video.lo -MD -MP -MF .deps/video.Tpo -c video.c -o video.o >/dev/null 2>&1
params.c: In function 'lqt_ffmpeg_set_parameter':
params.c:206: error: 'AVCodecContext' has no member named 'bidir_refine'
params.c:207: error: 'AVCodecContext' has no member named 'brd_scale'
params.c:208: error: 'AVCodecContext' has no member named 'scenechange_factor'
make[3]: *** [params.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/libquicktime-0.9.9/work/libquicktime-0.9.9/plugins/ffmpeg'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/libquicktime-0.9.9/work/libquicktime-0.9.9/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libquicktime-0.9.9/work/libquicktime-0.9.9'
make: *** [all] Error 2

!!! ERROR: media-libs/libquicktime-0.9.9 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  libquicktime-0.9.9.ebuild, line 47:   Called die

!!! emake failed
and not just
Code:
make: *** [all] Error 2

!!! ERROR: media-libs/libquicktime-0.9.9 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  libquicktime-0.9.9.ebuild, line 47:   Called die

!!! emake failed
In fact this last part is usually irrelevant in most (but not all) problems.

For a quick shot in the dark some ebuild don't really like parrallel make so you
can try to change MAKEOPTS from -j2 to -j1. I don't say it will work.
Back to top
View user's profile Send private message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Sun Aug 20, 2006 3:27 am    Post subject: Reply with quote

I changed my profile and tried again. Here's the (hopefully more complete, thanks) error:

Code:
cc1plus: warning: command line option "-Wmissing-prototypes" is valid for C/ObjC but not for C++
FXColorNames.cpp: In function 'FX::FXColor FX::fxcolorfromname(const FX::FXchar*)':
FXColorNames.cpp:769: error: 'comparecase' was not declared in this scope
make[1]: *** [FXColorNames.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
rm -f .libs/FXColorSelector.lo
c++ -DPACKAGE=\"fox\" -DVERSION=\"1.2.6\" -DHAVE_DLFCN_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_SYS_WAIT_H=1 -DHAVE_DIRENT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_SYS_SELECT_H=1 -DWORDS_BIGENDIAN=1 -DHAVE_PNG_H=1 -DHAVE_TIFF_H=1 -DHAVE_ZLIB_H=1 -DHAVE_BZLIB_H=1 -DHAVE_VSSCANF=1 -DHAVE_LIBDL=1 -I. -I. -I../include -I../include -I/usr/include/freetype2 -I/usr/include -I/usr/include/freetype2 -I/usr/include/freetype2 -DHAVE_XFT_H=1 -DHAVE_XSHM_H=1 -D_GNU_SOURCE -DHAVE_JPEG_H=1 -DHAVE_PNG_H=1 -DHAVE_TIFF_H=1 -DHAVE_ZLIB_H=1 -DHAVE_BZ2LIB_H=1 -DHAVE_XCURSOR_H=1 -DHAVE_CUPS_H=1 -Wall -W -Wmissing-prototypes -Woverloaded-virtual -Wformat -DHAVE_GL_H=1 -DSUN_OGL_NO_VERTEX_MACROS -DHPOGL_SUPPRESS_FAST_API -DHAVE_GLU_H=1 -c FXColorSelector.cpp  -fPIC -DPIC -o .libs/FXColorSelector.lo
cc1plus: warning: command line option "-Wmissing-prototypes" is valid for C/ObjC but not for C++
FXColorSelector.cpp: In member function 'long int FX::FXColorSelector::onUpdAlphaText(FX::FXObject*, FX::FXSelector, void*)':
FXColorSelector.cpp:446: error: 'FXStringVal' was not declared in this scope
FXColorSelector.cpp: In member function 'long int FX::FXColorSelector::onUpdRGBText(FX::FXObject*, FX::FXSelector, void*)':
FXColorSelector.cpp:551: error: 'FXStringVal' was not declared in this scope
FXColorSelector.cpp: In member function 'long int FX::FXColorSelector::onUpdHSVText(FX::FXObject*, FX::FXSelector, void*)':
FXColorSelector.cpp:597: error: 'FXStringVal' was not declared in this scope
FXColorSelector.cpp: In member function 'long int FX::FXColorSelector::onUpdCMYText(FX::FXObject*, FX::FXSelector, void*)':
FXColorSelector.cpp:642: error: 'FXStringVal' was not declared in this scope
make[1]: *** [FXColorSelector.lo] Error 1
make[1]: Leaving directory `/var/tmp/portage/fox-1.2.6-r3/work/fox-1.2.6/src'
make: *** [all-recursive] Error 1

!!! ERROR: x11-libs/fox-1.2.6-r3 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  fox-1.2.6-r3.ebuild, line 39:   Called die

!!! Parallel Make Failed
!!! If you need support, post the topmost build error, and the call stack if relevant.

_________________
gentoo good to be true
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Sun Aug 20, 2006 5:58 am    Post subject: Reply with quote

That's better, but I would have liked the whole of the following:
Code:
powerpc-unknown-linux-gnu-g++ -DPACKAGE=\"fox\" -DVERSION=\"1.2.6\"
-DHAVE_DLFCN_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_SYS_WAIT_H=1 -DHAVE_DIRENT_H=1
-DHAVE_UNISTD_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_SYS_SELECT_H=1
-DWORDS_BIGENDIAN=1 -DHAVE_PNG_H=1 -DHAVE_TIFF_H=1 -DHAVE_ZLIB_H=1
-DHAVE_BZLIB_H=1 -DHAVE_VSSCANF=1 -DHAVE_LIBDL=1 -I. -I. -I../include
-I../include -I/usr/include/freetype2 -I/usr/include -I/usr/include/freetype2
-DHAVE_XFT_H=1 -DHAVE_XSHM_H=1 -D_GNU_SOURCE -DHAVE_JPEG_H=1 -DHAVE_PNG_H=1
-DHAVE_TIFF_H=1 -DHAVE_ZLIB_H=1 -DHAVE_BZ2LIB_H=1 -DHAVE_XCURSOR_H=1
-DHAVE_CUPS_H=1 -Wall -W -Wmissing-prototypes -Woverloaded-virtual -Wformat
-DHAVE_GL_H=1 -DSUN_OGL_NO_VERTEX_MACROS -DHPOGL_SUPPRESS_FAST_API
-DHAVE_GLU_H=1 -c FXColorNames.cpp  -fPIC -DPIC -o .libs/FXColorNames.lo
cc1plus: warning: command line option "-Wmissing-prototypes" is valid for
C/ObjC but not for C++
cc1plus: warning: command line option "-Wmissing-prototypes" is valid for
C/ObjC but not for C++
FXColorNames.cpp: In function 'FX::FXColor FX::fxcolorfromname(const
FX::FXchar*)':
FXColorNames.cpp:769: error: 'comparecase' was not declared in this scope
make[1]: *** [FXColorNames.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
rm -f .libs/FXColorSelector.lo
powerpc-unknown-linux-gnu-g++ -DPACKAGE=\"fox\" -DVERSION=\"1.2.6\"
-DHAVE_DLFCN_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_SYS_WAIT_H=1 -DHAVE_DIRENT_H=1
-DHAVE_UNISTD_H=1 -DHAVE_SYS_PARAM_H=1 -DHAVE_SYS_SELECT_H=1
-DWORDS_BIGENDIAN=1 -DHAVE_PNG_H=1 -DHAVE_TIFF_H=1 -DHAVE_ZLIB_H=1
-DHAVE_BZLIB_H=1 -DHAVE_VSSCANF=1 -DHAVE_LIBDL=1 -I. -I. -I../include
-I../include -I/usr/include/freetype2 -I/usr/include -I/usr/include/freetype2
-DHAVE_XFT_H=1 -DHAVE_XSHM_H=1 -D_GNU_SOURCE -DHAVE_JPEG_H=1 -DHAVE_PNG_H=1
-DHAVE_TIFF_H=1 -DHAVE_ZLIB_H=1 -DHAVE_BZ2LIB_H=1 -DHAVE_XCURSOR_H=1
-DHAVE_CUPS_H=1 -Wall -W -Wmissing-prototypes -Woverloaded-virtual -Wformat
-DHAVE_GL_H=1 -DSUN_OGL_NO_VERTEX_MACROS -DHPOGL_SUPPRESS_FAST_API
-DHAVE_GLU_H=1 -c FXColorSelector.cpp  -fPIC -DPIC -o .libs/FXColorSelector.lo
cc1plus: warning: command line option "-Wmissing-prototypes" is valid for
C/ObjC but not for C++
cc1plus: warning: command line option "-Wmissing-prototypes" is valid for
C/ObjC but not for C++
FXColorSelector.cpp: In member function 'long int
FX::FXColorSelector::onUpdAlphaText(FX::FXObject*, FX::FXSelector, void*)':
FXColorSelector.cpp:446: error: 'FXStringVal' was not declared in this scope
FXColorSelector.cpp: In member function 'long int
FX::FXColorSelector::onUpdRGBText(FX::FXObject*, FX::FXSelector, void*)':
FXColorSelector.cpp:551: error: 'FXStringVal' was not declared in this scope
FXColorSelector.cpp: In member function 'long int
FX::FXColorSelector::onUpdHSVText(FX::FXObject*, FX::FXSelector, void*)':
FXColorSelector.cpp:597: error: 'FXStringVal' was not declared in this scope
FXColorSelector.cpp: In member function 'long int
FX::FXColorSelector::onUpdCMYText(FX::FXObject*, FX::FXSelector, void*)':
FXColorSelector.cpp:642: error: 'FXStringVal' was not declared in this scope
make[1]: *** [FXColorSelector.lo] Error 1
make[1]: Leaving directory `/var/tmp/portage/fox-1.2.6-r3/work/fox-1.2.6/src'
make: *** [all-recursive] Error 1


I didn't try it myself. You are suffering from this bug.
It is related to gcc-4.x. The latest version of fox (1.4.x) is patched correctly
but not earlier versions. This package need a maintainer which is why it is
not patched yet. Sorry about that.
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Wed Aug 23, 2006 8:11 am    Post subject: Reply with quote

Things are moving on the fox front.
Code:
more /usr/portage/x11-libs/fox/ChangeLog
# ChangeLog for x11-libs/fox
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.54 2006/08/23 00:46:43 dberkholz Exp $

  23 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>; fox-1.0.53.ebuild:
  Same gcc-4 fix as for 1.2

*fox-1.6.14 (23 Aug 2006)
*fox-1.4.34 (23 Aug 2006)
*fox-1.2.18 (23 Aug 2006)

  23 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>; +fox-1.2.18.ebuild,
  +fox-1.4.34.ebuild, +fox-1.6.14.ebuild:
  (#128917) Bump to latest versions, so everything works with gcc-4. For 1.2
  series, the ebuild also needs -ffriend-injection (Martin von Gagern).

  19 Aug 2006; Thomas Cort <tcort@gentoo.org> fox-1.2.6-r3.ebuild:
  Stable on amd64 wrt Bug #138871.

You may have to put it in /etc/portage/package.keywords and may be add
the flag mentionned, in your CFLAGS if it is not done by the ebuild.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum