Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge of xorg-server failing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
echo6
Guru
Guru


Joined: 04 Jan 2003
Posts: 587

PostPosted: Sun Aug 20, 2006 5:50 pm    Post subject: emerge of xorg-server failing Reply with quote

https://forums.gentoo.org/viewtopic-t-490568.html

I'm on my third attempt trying to get this to emerge, just wondered if this problem is related to ppc.

Lots of errors similar to
Code:
/usr/include/linux/byteorder/big_endian.h:44: error: parse error before "__cpu_t
o_le64p"


Any ideas how I can get this to emerge ?
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sun Aug 20, 2006 7:46 pm    Post subject: Reply with quote

Are you sure you've done emerge --sync? The stable xorg-server on ppc is 1.1.0-r1, not 1.0.2-r7 as in your other post.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
echo6
Guru
Guru


Joined: 04 Jan 2003
Posts: 587

PostPosted: Sun Aug 20, 2006 9:34 pm    Post subject: Reply with quote

I've tried all the ones available in my current portage tree,
1.1.1
1.1.0-r1
1.0.2-r7
They all fail :-(
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sun Aug 20, 2006 10:03 pm    Post subject: Reply with quote

Which version of linux-headers do you have installed?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
echo6
Guru
Guru


Joined: 04 Jan 2003
Posts: 587

PostPosted: Mon Aug 21, 2006 6:15 am    Post subject: Reply with quote

Code:
*  sys-kernel/linux-headers
      Latest version available: 2.6.11-r4
      Latest version installed: 2.6.11-r4
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Mon Aug 21, 2006 6:41 am    Post subject: Reply with quote

I have looked at your other post where you posted your emerge --info.
Is there any reason why you still use an old toolchain? Especially glibc?
Upgrading to the 2006.1 profile may present some challenges, but
something inside me look at this error and says "toolchain!", try to update
glibc to at least 2.3.6-r3 and possibly gcc to 3.4.5.
Back to top
View user's profile Send private message
echo6
Guru
Guru


Joined: 04 Jan 2003
Posts: 587

PostPosted: Mon Aug 21, 2006 7:52 am    Post subject: Reply with quote

I've considered updating the toolchain. but as a last resort.

If I have to update the toolchain I would probably consider a fresh install.
Back to top
View user's profile Send private message
echo6
Guru
Guru


Joined: 04 Jan 2003
Posts: 587

PostPosted: Mon Aug 21, 2006 3:13 pm    Post subject: Reply with quote

Hmm, ok I've now managed to succesfully emerge Xorg modular.

From memory I did the following
Code:
ACCEPT_KEYWORDS="~x86 ~ppc" emerge =linux-headers-2.6.17
emerge -Ca xorg-x11
rm -rf /usr/lib/libGL*
rm -rf /usr/lib/X11/xkb/
emerge gcc glibc
emerge -DuNv xorg-x11


gcc-4.1.1
glibc-2.3.4.20041102-r11

It now wants to update glibc to glibc-2.4-r3, I'm not sure what's best to do now. I have kde-3.4.1-r1 installed but that's broken now since the update, but fluxbox works :-)

Should I go ahead and update glibc and then update kde?
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Mon Aug 21, 2006 9:37 pm    Post subject: Reply with quote

I am quite surprised you managed to compile gcc-4.1.1 with this glibc 8O .
The requirement is to have at least glibc-2.3.6 - other than that apart
from the linux-headers I can follow most of it. From my experience they
were also problems emerging xorg-x11 with -D as portage would not put
all the packages in the right order, that may have been solved.

I am not sure about kde-3.4.1 it may be a problem with modular X but it could
also be a problem with gcc. You can check that by switching compiler with
gcc-config to your old gcc and try starting kde again, I remember when I
switched to gcc-4.1.x I had problems with a few kde applications, I switched
compiler and then they started. They were probably linked to libstdc++ (?)
which changed sligthly compared to the previous version. I ended up recompiling
the whole system anyway.
Back to top
View user's profile Send private message
echo6
Guru
Guru


Joined: 04 Jan 2003
Posts: 587

PostPosted: Mon Aug 21, 2006 9:54 pm    Post subject: Reply with quote

fb wrote:
I am quite surprised you managed to compile gcc-4.1.1 with this glibc 8O .


I'm surprised it compiled xorg Modular!!

I've started emerging kdebase-3.5.2-r2, about 3 hours ago, it's still doing it......

I wonder what the outcome will be? I'll let you know when I get up tomorrow....oh!...shortly after I posted it completed successfully and I'm now running kde-3.5 :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum