Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ibm-jdk-bin-1.4.2.03
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Wed Aug 23, 2006 11:19 pm    Post subject: ibm-jdk-bin-1.4.2.03 Reply with quote

I'm trying to install a first generation java VM.
Code:
# emerge =ibm-jdk-bin-1.4.2.03
Calculating dependencies... done!
>>> Emerging (1 of 1) dev-java/ibm-jdk-bin-1.4.2.03 to /
!!! IBMJava2-SDK-142.ppc-SR3.tgz not found in /usr/portage/distfiles

!!! dev-java/ibm-jdk-bin-1.4.2.03 has fetch restriction turned on.
!!! This probably means that this ebuild's files must be downloaded
!!! manually.  See the comments in the ebuild for more information.

 * Due to license restrictions, we cannot redistribute or fetch the distfiles
 * Please visit: http://www-128.ibm.com/developerworks/java/jdk/linux/older_download.html
 * Under Java 1.4.2, download SR3: IBMJava2-SDK-142.ppc.tgz
 * Rename IBMJava2-SDK-142.ppc.tgz to IBMJava2-SDK-142.ppc-SR3.tgz
 * Place the file(s) in: /usr/portage/distfiles
 * Then run emerge ibm-jdk-bin

I'm following the instructions but things are still unclear. After it says "* Under Java 1.4.2, download SR3: IBMJava2-SDK-142.ppc.tgz," I try to follow on the ibm page but there is still one more big choice that the instructions do not make clear. Do I choose version 142 SR5 or 142 SR4-1 or 142 SR4?
_________________
gentoo good to be true
Back to top
View user's profile Send private message
trupoet
Apprentice
Apprentice


Joined: 08 Aug 2002
Posts: 160

PostPosted: Wed Aug 23, 2006 11:22 pm    Post subject: Reply with quote

Hmm sounds like portage wants SR3 but IBM is now only providing SR4 and 5.

Have you emerge --sync'd lately?
Back to top
View user's profile Send private message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Wed Aug 23, 2006 11:26 pm    Post subject: Reply with quote

Yes, I've emerge sync'ed today. On the ibm page I'm able to choose SR3 under 1.4.2 but then I'm given the choices just mentioned. ?
_________________
gentoo good to be true
Back to top
View user's profile Send private message
trupoet
Apprentice
Apprentice


Joined: 08 Aug 2002
Posts: 160

PostPosted: Wed Aug 23, 2006 11:31 pm    Post subject: Reply with quote

Well download them both, and try each one of them as it says.

If the checksums don't match, it will tell you
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Aug 23, 2006 11:49 pm    Post subject: Reply with quote

You want the IBM iSeries/pSeries 32 Bit Linux, SR3 (second from the top in the 1.4.2 column).
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Thu Aug 24, 2006 12:02 am    Post subject: Reply with quote

I chose that and then on the next page there are more choices, the ones I just mentioned.
_________________
gentoo good to be true
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Thu Aug 24, 2006 2:45 am    Post subject: Reply with quote

bobotoes wrote:
I chose that and then on the next page there are more choices, the ones I just mentioned.
You should say "they had different choices" and SR3 is indeed not one of them
anymore. It is still on the page that portage points to but once you are logged it's gone.

That's not the first time it has been reported, I am a bit surprised
no one did bump the version for 2006.1, one would think that could be a problem.
Anyway I guess you could download SR5, rename it to the name expected by portage
and then regenerating the digest so emerge doesn't complain as explained in the linked
thread.
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Aug 24, 2006 2:52 am    Post subject: Reply with quote

The Java team has a "freeze" on ebuild keywording. :p Sorry I forgot about that post, but there's not much we can do until they're ready to move forward. I bugged nicoj about it again today and he said they should be "un-freezing" things soon.

Sorry about the inconvenience.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
nss
Guru
Guru


Joined: 04 Oct 2004
Posts: 389

PostPosted: Thu Aug 24, 2006 3:28 am    Post subject: Reply with quote

Here I am complaining of things being unclear and I may not be describing what's going on clearly. I'm tired, for whatever that's worth. Thanks for the help.
_________________
gentoo good to be true
Back to top
View user's profile Send private message
fb
l33t
l33t


Joined: 08 Dec 2003
Posts: 636
Location: New Zealand

PostPosted: Thu Aug 24, 2006 8:00 am    Post subject: Reply with quote

bobotoes wrote:
Here I am complaining of things being unclear and I may not be describing what's going on clearly. I'm tired, for whatever that's worth. Thanks for the help.


Sorry, if I came a little bit blunt, I didn't mean to be :oops: .
I hope you have a good rest and can successfully continue on
with your install :) .

Sorry also to JoseJX if I was a little bit impertinent, I didn't
know about the java freeze, or in this case a really deep freeze.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum