Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
tilde weg (keyboard problemen)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
stevena
n00b
n00b


Joined: 17 Apr 2003
Posts: 50

PostPosted: Wed Apr 23, 2003 2:06 pm    Post subject: tilde weg (keyboard problemen) Reply with quote

Ik kan de tilde (dat golfje op het woord senor) niet meer tikken als ik grafisch zit.
Ik vermoed dat met het emergen van de nieuwe XFree er iets veranderd is aan mijn toetsenbordinstellingen. Heb al wat geprutst aan mijn keyboardlayout maar krijg hem niet in orde.
Hij staat nu zo in mijn XFree86Config:
Code:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbLayout" "be"
        Option "XkbModel" "pc104"
EndSection

Kent er iemand een oplossing?


Last edited by stevena on Thu Apr 24, 2003 5:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
foser
Retired Dev
Retired Dev


Joined: 28 Oct 2002
Posts: 154

PostPosted: Wed Apr 23, 2003 4:26 pm    Post subject: Reply with quote

ik las ergens anders op 't forum dat je dan "pc105" moet gebruiken
_________________
Gentoo Gnome Desktop team
Back to top
View user's profile Send private message
stevena
n00b
n00b


Joined: 17 Apr 2003
Posts: 50

PostPosted: Thu Apr 24, 2003 6:21 am    Post subject: Reply with quote

foser wrote:
ik las ergens anders op 't forum dat je dan "pc105" moet gebruiken

Heb dat ook gelezen/geprobeerd maar hij doet het niet.

Steven
Back to top
View user's profile Send private message
SeJo
Retired Dev
Retired Dev


Joined: 08 Oct 2002
Posts: 298
Location: Belgium

PostPosted: Thu Apr 24, 2003 6:47 am    Post subject: Reply with quote

Steven heb je een gewoon azerty of een qwerty bord?
azerty werkt met pc105 en layout be...

check eens of je in je config geen dubbele declaratie hebt ergens...
Back to top
View user's profile Send private message
JefP@@
Apprentice
Apprentice


Joined: 09 May 2002
Posts: 179
Location: Belgium

PostPosted: Thu Apr 24, 2003 7:39 am    Post subject: Reply with quote

gebruik je kde ? en zo ja.. check eens hoe je keyboard instellingen staan in je kde. Als deze nog op pc104 staan, heb je hetzelfde probleem ...

Alles op pc105 zetten is de boodschap ;)

Grtz
Back to top
View user's profile Send private message
zwik
Apprentice
Apprentice


Joined: 08 Sep 2002
Posts: 167
Location: NL, NB, Liempde

PostPosted: Thu Apr 24, 2003 1:06 pm    Post subject: Reply with quote

Ik heb hier ook last van. Wanneer ik bijvoorbeeld een Eterm open gebeurd er niks wanneer ik op de tilde druk.

Ik zal hier op de forums ook zoeken ;) .
_________________
Daily life and stuff.
Back to top
View user's profile Send private message
Raskas
n00b
n00b


Joined: 09 Apr 2003
Posts: 28

PostPosted: Thu Apr 24, 2003 5:40 pm    Post subject: Reply with quote

zelfde probleem in kde3

als er iemand ook dat probleem had, en een oplossing heeft gevonden: posten a.u.b

Greetzzz Raskas
Back to top
View user's profile Send private message
wdconinc
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2003
Posts: 80
Location: Ann Arbor, Michigan

PostPosted: Thu Apr 24, 2003 6:45 pm    Post subject: Reply with quote

Hallo,

Het probleem komt bij mij ook voor. Tot verleden week had ik het probleem met de verdwenen backslash. Dat is nu opgelost, maar mijn verbazing was groot toen mijn tilde verdwenen was. De verandering is gebeurd bij de overgang naar de nieuwe xfree (ik gebruik wel "<tilde>x86", grrr :-) ).

Bestaat er misschien maar een beperkte plaats voor toetsen in het geheugen en moeten er bepaalde toetsen verdwijnen als er andere bijkomen? :-)

Iig, vrij vervelend om iedere keer een destructor in c++ te maken door te copy&pasten...

Greetz
wouter
Back to top
View user's profile Send private message
wdconinc
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2003
Posts: 80
Location: Ann Arbor, Michigan

PostPosted: Thu Apr 24, 2003 6:53 pm    Post subject: Reply with quote

Hoi,

Trouwens, geen enkele dead-key doet het. Het is niet enkel de tilde. Ook de accenten (dead_acute, dead_grave, en alle andere dead_* in /etc/X11/xkb/symbols/pc/be)

greetz,
wouter
Back to top
View user's profile Send private message
kamikaz3
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 187

PostPosted: Fri Apr 25, 2003 11:44 am    Post subject: Reply with quote

ik heb juist hetzelfde sinds gisteren, na m'n upgrade van xfree
Back to top
View user's profile Send private message
Raskas
n00b
n00b


Joined: 09 Apr 2003
Posts: 28

PostPosted: Fri Apr 25, 2003 2:13 pm    Post subject: Reply with quote

het probleem is bij mij ook ontstaan na de update van xfree...

mogelijk iets met xfree? een bug?
Back to top
View user's profile Send private message
schutten
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2002
Posts: 120
Location: Veldhoven, the Netherlands

PostPosted: Fri Apr 25, 2003 5:21 pm    Post subject: Reply with quote

Kijk eens in deze thread:
https://forums.gentoo.org/viewtopic.php?p=294397

Ik had hetzelfde probleem, maar nu werkt het weer.
Back to top
View user's profile Send private message
stevena
n00b
n00b


Joined: 17 Apr 2003
Posts: 50

PostPosted: Sat Apr 26, 2003 4:59 pm    Post subject: Reply with quote

Bedankt.
Werkt schitterend! (zelfs zonder dat KDE het keyboard moet mappen)

Dus kort samengevat:
    in "/etc/env.d/02locale" LC_CTYPE="nl_BE@euro" zetten
    #env-update
    #source /etc/profile
    x herstarten


MODERATOR GARO:
Quote:
in "/etc/env.d/02locale" LC_CTYPE="nl_BE@euro" zetten

als dit bestand niet bestaat maak het dan aan:
Code:
su -
touch /etc/env.d/02locale
Back to top
View user's profile Send private message
Da_dille
n00b
n00b


Joined: 23 May 2003
Posts: 13
Location: Belgium

PostPosted: Wed Jun 04, 2003 8:13 am    Post subject: Reply with quote

bij mij werkt dat niet

kan ik nog iets anders proberen???

ok het werkt

prachtig

bedankt
Back to top
View user's profile Send private message
tHeoo
n00b
n00b


Joined: 20 Mar 2003
Posts: 50
Location: Bammental, Deutschland

PostPosted: Wed Jun 04, 2003 9:00 am    Post subject: Dead keys in KDE Reply with quote

Ik heb nog steeds problemen sinds ik overgestapt ben naar X 4.3.0-r2. Ik had 4.2.1. Daar als instellingen in XF86Config:

Code:

   Option    "XkbLayout"     "us"
   Option    "XkbModel"     "pc105"
   Option    "XkbRules"     "xfree86"


Dit heb ik nu weer in 4.3.0. Ik heb al geremerged via:

rm /usr/portage/distfiles/XFree-compose-*
emerge sync
emerge xfree
etc-update

maar nog steeds problemen in KDE. MIjn taalsettings zijn nl_NL@euro via LANG="nl_NL@euro" in .bashrc Dat geeft deze output :
Code:

#locale
LANG=nl_NL@euro
LC_CTYPE="nl_NL@euro"
LC_NUMERIC="nl_NL@euro"
LC_TIME="nl_NL@euro"
LC_COLLATE="nl_NL@euro"
LC_MONETARY="nl_NL@euro"
LC_MESSAGES="nl_NL@euro"
LC_PAPER="nl_NL@euro"
LC_NAME="nl_NL@euro"
LC_ADDRESS="nl_NL@euro"
LC_TELEPHONE="nl_NL@euro"
LC_MEASUREMENT="nl_NL@euro"
LC_IDENTIFICATION="nl_NL@euro"
LC_ALL=


Dus die 02locale file lijk ik niet nodig te hebben. Als ik in KDE alle toetsenbordindelingen uitschakel kan ik geen dode toetsen gebruiken, maar alle tekens werken behalve Euro. Als ik us_intl als extra indeling toevoeg heb ik ineens geen aanhalingsteken (') meer en ("), of ik nu de additionele indeling gebruik of niet.
Iemand enig idee hoe dit zit?
Hart.gr.,

Maarten Wisse
Back to top
View user's profile Send private message
Braempje
l33t
l33t


Joined: 31 Jan 2003
Posts: 748

PostPosted: Wed Jun 04, 2003 12:48 pm    Post subject: Reply with quote

Waarom staat je XkbLayout op us? Is dat niet het probleem?
_________________
Dictionary of the Flemish Sign Language - Woordenboek Vlaamse Gebarentaal
Back to top
View user's profile Send private message
tHeoo
n00b
n00b


Joined: 20 Mar 2003
Posts: 50
Location: Bammental, Deutschland

PostPosted: Wed Jun 04, 2003 12:51 pm    Post subject: Reply with quote

Omdat ik een us keyboard heb, zoals de meeste Nederlanders. Het heeft altijd gewerkt zo.
Back to top
View user's profile Send private message
Braempje
l33t
l33t


Joined: 31 Jan 2003
Posts: 748

PostPosted: Wed Jun 04, 2003 1:04 pm    Post subject: Reply with quote

tHeoo wrote:
Omdat ik een us keyboard heb, zoals de meeste Nederlanders. Het heeft altijd gewerkt zo.

Mijn excuses, dat zal een patriotistisch trekje zijn van mij :oops:
_________________
Dictionary of the Flemish Sign Language - Woordenboek Vlaamse Gebarentaal
Back to top
View user's profile Send private message
schutten
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2002
Posts: 120
Location: Veldhoven, the Netherlands

PostPosted: Wed Jun 04, 2003 3:15 pm    Post subject: Reply with quote

tHeoo,

De .bashrc wordt pas gelezen als je een terminal opstart, en heeft (dacht ik) nog geen effect gehad als KDE zelf opstart.
Misschien heb je toch de 02locale file nodig...
Back to top
View user's profile Send private message
stevena
n00b
n00b


Joined: 17 Apr 2003
Posts: 50

PostPosted: Thu Jun 05, 2003 12:22 pm    Post subject: Reply with quote

Quote:
en heeft (dacht ik) nog geen effect gehad als KDE zelf opstart

Niet als je grafisch boot nee.
Als je grafisch boot haalt het dus niets uit om de LANG in de .bashrc te zetten omdat je dan helemaal niet langs bash passeert. Maar misschien kan je het dan wel in de .xinitrc zetten. Dit is maar een klein ideetje, heb nu geen tijd om het uit te proberen maar het zou wel eens kunnen werken.
In elk geval denk ik dat het het veiligst is om het gewoon in de /etc/profile te zetten.
Veel geluk.
Back to top
View user's profile Send private message
progster
Apprentice
Apprentice


Joined: 16 Jul 2002
Posts: 271

PostPosted: Thu Jun 05, 2003 12:53 pm    Post subject: Reply with quote

~ Blij dat z'n dead keys terug werken ~
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 762
Location: Gent (Belgium)

PostPosted: Thu Jun 05, 2003 1:07 pm    Post subject: Reply with quote

Ik had dit probleem ook met XFree 4.3.0-r2, met r3 is alles weer in orde, misschien handig om te upgraden? :wink:
_________________
Fvwm|Fvwm forum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum