Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Access denied, access_wr: /
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
nookie_pl
n00b
n00b


Joined: 24 Apr 2006
Posts: 34

PostPosted: Thu Sep 07, 2006 4:57 am    Post subject: Access denied, access_wr: / Reply with quote

Mod edit: Sticky for now (2006-10-14). (Unstuck 2007-01-17.) Please also see bug 101433. --kallamej

Please note that disabling the sandbox should only be done if you know what you're doing. This thread is about a very specific case where you have sys-apps/sandbox-1.2.11 or lower installed. Generally, sandbox violations are ebuild bugs that need to be fixed properly. Please file a new report if there isn't one already.



Hey,

I've started yesterday emerge --update world (from almost clean 2005.1 version) and today morning I've found that:

ACCESS DENIED access_wr: /
>>> Completed installing texinfo-4.8-r4 into /var/tmp/portage/texinfo-4.8-r4/image/

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-sys-apps_-_texinfo-4.8-r4-22573.log"

access_wr: /
--------------------------------------------------------------------------------

Somewhere on forums I've found solution to upgrade Sandbox, but when I compile it - I get same error (on Sandbox compilation).

Any ideas?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9273

PostPosted: Thu Sep 07, 2006 5:09 am    Post subject: Reply with quote

Perhaps emerge -C sandbox && emerge sandbox?
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Thu Sep 07, 2006 5:09 am    Post subject: Reply with quote

Did you remember to disable the sandbox feature of portage when you tried to update sandbox?
Back to top
View user's profile Send private message
Takaitra
n00b
n00b


Joined: 12 Apr 2004
Posts: 26
Location: Minnesota

PostPosted: Mon Sep 11, 2006 5:50 pm    Post subject: Reply with quote

Thanks yabbadabbadont, I was receiving the same error when performing an emerge system. The following fixed it.

Code:
FEATURES="-sandbox" emerge -1 sandbox
Back to top
View user's profile Send private message
paully
n00b
n00b


Joined: 21 May 2004
Posts: 47
Location: Folkestone, Kent, UK

PostPosted: Fri Sep 15, 2006 1:08 pm    Post subject: Reply with quote

Fantastic. That fixed the same problem for me!

:)

Paully
Back to top
View user's profile Send private message
pcooley
n00b
n00b


Joined: 17 Sep 2006
Posts: 3
Location: Seattle, WA

PostPosted: Sun Sep 17, 2006 2:46 pm    Post subject: Reply with quote

I also ran into this problem while doing:

Code:
emerge xorg-x11


It failed on xinit-1.0.2-r6
Emerging (1 of 27) x11-apps/xinit-1.0.2-r6 to /

Using the solution
Code:
FEATURES="-sandbox" emerge -1 sandbox

allowed it to work immediately on my next try.

Thanks very much.
Back to top
View user's profile Send private message
diilbert
n00b
n00b


Joined: 05 Sep 2005
Posts: 52

PostPosted: Tue Oct 10, 2006 5:10 pm    Post subject: Reply with quote

Thanks for the answer to the problem.

Got the same problem when updating php to php-4.4.4-r4

So updated to the latest Sandbox version to fix the problem.
Back to top
View user's profile Send private message
Corona688
Veteran
Veteran


Joined: 10 Jan 2004
Posts: 1204

PostPosted: Fri Oct 13, 2006 3:38 pm    Post subject: Reply with quote

This thread deserves a sticky.
_________________
Petition for Better 64-bit ATI Drivers - Sign Here
http://www.petitiononline.com/atipet/petition.html
Back to top
View user's profile Send private message
moocha
Watchman
Watchman


Joined: 21 Oct 2003
Posts: 5722

PostPosted: Fri Oct 13, 2006 3:52 pm    Post subject: Reply with quote

Corona688 wrote:
This thread deserves a sticky.
Subscribed.
_________________
Military Commissions Act of 2006: http://tinyurl.com/jrcto

"Those who would give up essential liberty to purchase a little temporary safety deserve neither liberty nor safety."
-- attributed to Benjamin Franklin
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4927
Location: Gothenburg, Sweden

PostPosted: Sat Oct 14, 2006 11:24 am    Post subject: Reply with quote

moocha wrote:
Corona688 wrote:
This thread deserves a sticky.
Subscribed.

Done.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Telexen
Apprentice
Apprentice


Joined: 09 Oct 2005
Posts: 189

PostPosted: Mon Oct 16, 2006 2:25 am    Post subject: Reply with quote

that fix still isn't working for me when trying to emerge nvidia-drivers ... xorg-x11 has no problems though.
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Mon Oct 16, 2006 2:32 am    Post subject: Reply with quote

Telexen wrote:
that fix still isn't working for me when trying to emerge nvidia-drivers ... xorg-x11 has no problems though.

Another user (on amd64) is having this issue with nvidia-drivers too. However, he was trying to use the latest (hard masked) version instead of the stable 1.0.8774 version. Which version are you trying to use and on which arch?
Back to top
View user's profile Send private message
Telexen
Apprentice
Apprentice


Joined: 09 Oct 2005
Posts: 189

PostPosted: Mon Oct 16, 2006 2:43 am    Post subject: Reply with quote

It appears to be this problem:

https://forums.gentoo.org/viewtopic-t-505651-highlight-.html

As I said in my post there I get the error with both the latest masked and unmasked versions on a mm-sources amd64 2.6.18-mm3 kernel
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Mon Oct 16, 2006 2:49 am    Post subject: Reply with quote

Telexen wrote:
It appears to be this problem:

https://forums.gentoo.org/viewtopic-t-505651-highlight-.html

As I said in my post there I get the error with both the latest masked and unmasked versions on a mm-sources amd64 2.6.18-mm3 kernel

Yeah, I saw your other post. I pointed the other user to that thread too.
Back to top
View user's profile Send private message
little_bob
Retired Dev
Retired Dev


Joined: 27 Jul 2004
Posts: 34

PostPosted: Wed Oct 25, 2006 5:33 am    Post subject: Access denied, access_wr: / Reply with quote

Hello,

many thanks for setting this sticky :D


I am one user of the rare special cases with sandbox lower or equal 1.2.11.

In my case it happened while i change to modular x. I did an emerge for the ttf-bitstream-vera-1.10-r3 ebuild when i run into this error.
I did not find something in the forum because i looked for ttf-bitstream-vera.

I was a bit in dispair because i could not find anything usefull. Then i decided to make an entry in this part of forum looking for help and found this sticky entry.

--little_bob
Back to top
View user's profile Send private message
puggy
Bodhisattva
Bodhisattva


Joined: 28 Feb 2003
Posts: 1992
Location: Oxford, UK

PostPosted: Thu Oct 26, 2006 1:22 pm    Post subject: Reply with quote

I have sandbox-1.2.18.1

Have tried:
Code:

FEATURES="-sandbox" emerge -1 sandbox


and can still not emerge nvidia-drivers or other kernel modules like vmware due to the access violation.

Portage 2.1.2_pre3-r9 (default-linux/x86/2006.1, gcc-3.4.6, glibc-2.5-r0, 2.6.18-rc4 i686)
=================================================================
System uname: 2.6.18-rc4 i686 Intel(R) XEON(TM) CPU 2.40GHz
Gentoo Base System version 1.12.5
Last Sync: Thu, 26 Oct 2006 09:30:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python: 2.3.5-r3, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache: [Not Present]
dev-util/confcache: [Not Present]
sys-apps/sandbox: 1.2.18.1
sys-devel/autoconf: 2.13, 2.60
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils: 2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.17-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-pipe -funroll-loops -mmmx -msse -msse2 -O3 -march=pentium4"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-pipe -funroll-loops -mmmx -msse -msse2 -O3 -march=pentium4"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig cvs distlocks manifest metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.blueyonder.co.uk"
LANG="en_GB.utf8"
LC_ALL="en_GB.utf8"
LINGUAS="en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 aac acl acpi akode alsa asf bash-completion berkdb bitmap-fonts bluetooth branding cdr cli cracklib crypt cups dbus dga divx4linux dlloader dmx dri dvd dvdr dvdread elibc_glibc ffmpeg font-server fortran fping gdbm gpm gtk gtk2 guile hal ieee1394 imagemagick input_devices_keyboard input_devices_mouse ipv6 isdnlog java jce jpeg2k kde kdeenablefinal kdehiddenvisibility kernel_linux libclamav libg++ linguas_en_GB mjpeg mmx ncurses nls nogecko-sdk nptl nptlonly nsplugin nvidia ofx pam pcre pdf perl perlsuid ppds pppd python qt qt4 readline real reflection samba session spl sqlite sse ssl subtitles subversion tcpd truetype-fonts type1-fonts udev unicode usb userland_GNU v4l video_cards_nvidia video_cards_v4l vidix vorbis win32codecs xcomposite xine xinerama xorg xvid zeroconf zlib"
Unset: CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
_________________
Where there's open source , there's a way.
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Thu Oct 26, 2006 11:59 pm    Post subject: Reply with quote

puggy wrote:
I have sandbox-1.2.18.1

Have tried:
Code:

FEATURES="-sandbox" emerge -1 sandbox


and can still not emerge nvidia-drivers or other kernel modules like vmware due to the access violation.

Try setting MAKEOPTS="-j1" temporarily in /etc/make.conf and see if it helps.
Back to top
View user's profile Send private message
piewie
Guru
Guru


Joined: 26 Sep 2002
Posts: 489
Location: old Europe

PostPosted: Fri Oct 27, 2006 10:19 pm    Post subject: Reply with quote

yabbadabbadont wrote:

Try setting MAKEOPTS="-j1" temporarily in /etc/make.conf and see if it helps.

nvidia-drivers does not compile - still sandbox violation. Seems to be a kernel bug with extern modules building:
https://bugs.gentoo.org/show_bug.cgi?id=149307
Back to top
View user's profile Send private message
jkcunningham
l33t
l33t


Joined: 28 Apr 2003
Posts: 649
Location: 47.49N 121.79W

PostPosted: Sat Nov 18, 2006 4:57 pm    Post subject: Reply with quote

I was trying to emerge system after syncing and running into the sandbox access errors on everything. I noticed that the first thing it wanted to update was 'sandbox' and *it* had a sandbox error. So I emerged it 'dangerously':
Code:

FEATURES="-sandbox" emerge sandbox

and after that everything else seems to be working fine. It looks like a catch-22: sandbox had a bug in it that couldn't be updated until you disabled sandbox.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4927
Location: Gothenburg, Sweden

PostPosted: Sat Nov 18, 2006 8:08 pm    Post subject: Reply with quote

jkcunningham wrote:
I was trying to emerge system after syncing and running into the sandbox access errors on everything. I noticed that the first thing it wanted to update was 'sandbox' and *it* had a sandbox error. So I emerged it 'dangerously':
Code:

FEATURES="-sandbox" emerge sandbox

and after that everything else seems to be working fine. It looks like a catch-22: sandbox had a bug in it that couldn't be updated until you disabled sandbox.

That's what this sticky is all about. Split your post from this thread and merged it here.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
dak1001
n00b
n00b


Joined: 16 Dec 2003
Posts: 9

PostPosted: Sun Dec 10, 2006 2:52 am    Post subject: Reply with quote

If you are unable to emerge the nvidia-drivers, check your kernel to see if you have the stack-protector selected. Try de-selecting the stack-protector and rebuilding your kernel. emerge the nvidia-drivers into your newly built kernel.
Back to top
View user's profile Send private message
ansa
n00b
n00b


Joined: 02 Feb 2007
Posts: 1

PostPosted: Fri Feb 02, 2007 10:14 pm    Post subject: Reply with quote

dak1001 wrote:
If you are unable to emerge the nvidia-drivers, check your kernel to see if you have the stack-protector selected. Try de-selecting the stack-protector and rebuilding your kernel. emerge the nvidia-drivers into your newly built kernel.


Yep. It worked for me, on amd64, gcc-4.1.1-r3, linux-2.6.19-gentoo-r5, nvidia-drivers-9746...
It's been a good lesson however: never turn on a kernel option without knowing *exactly* what it does :)
Back to top
View user's profile Send private message
Bizarro
n00b
n00b


Joined: 18 Jan 2007
Posts: 9

PostPosted: Thu Feb 22, 2007 10:55 am    Post subject: Reply with quote

Such a lovely sticky :oops:
_________________
[center][img]http://fsdmd1.googlepages.com/firmcopia.jpg[/img][/center]
Back to top
View user's profile Send private message
fusel
n00b
n00b


Joined: 24 Apr 2006
Posts: 15

PostPosted: Fri Mar 02, 2007 3:38 pm    Post subject: Reply with quote

That does the trick! Many thanks :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum