Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(SOLVED) yaboot on G3 ppc "Root Device not detected" issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
cowboycraig
n00b
n00b


Joined: 14 Sep 2006
Posts: 10

PostPosted: Thu Sep 14, 2006 9:28 pm    Post subject: (SOLVED) yaboot on G3 ppc "Root Device not detected&quo Reply with quote

yaboot on G3 ppc "Root Device not detected" issue

OK, I hate yaboot, and it hates me :?
This is on an iMac (G3 ppc 32 bit).


When booting I get "!! The root block device is unspecified or not detected."



This is my yaboot.cong. Everything is where is says:
## yaboot.conf generated by yabootconfig 1.0.8
##
## run: "man yaboot.conf" for details. Do not make changes until you have!!
##
## For a dual-boot menu, add one or more of:
## bsd=/dev/hdaX, macos=/dev/hdaY, macosx=/dev/hdaZ

boot=/dev/hda4
device=/pci@80000000/mac-io@10/ide@20000/disk@0:
partition=6
root=/dev/hda6
timeout=30
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot

image=/boot/kernel-genkernel-ppc-2.6.17-gentoo-r7
label=Linux
root=/dev/hda6
partition=6
read-only
initrd=/boot/initramfs-genkernel-ppc-2.6.17-gentoo-r7
initrd-size=8192

Then I run this while booted in the LiveCD: livecd ~ # ybin -v -C /mnt/gentoo/etc/yaboot.conf
ybin: Finding OpenFirmware device path to `/dev/hda4'...
ybin: Installing first stage bootstrap /usr/lib/yaboot/ofboot onto /dev/hda4...
ybin: Installing primary bootstrap /usr/lib/yaboot/yaboot onto /dev/hda4...
ybin: Installing /mnt/gentoo/etc/yaboot.conf onto /dev/hda4...
ybin: Setting attributes on ofboot...
ybin: Setting attributes on yaboot...
ybin: Setting attributes on yaboot.conf...
ybin: Blessing /dev/hda4 with Holy Penguin Pee...
ybin: Updating OpenFirmware boot-device variable in nvram...


All looks OK, then I get (when booting): >> Loading modules
>> Activating mdev
>> Determining root device...
!! The root block device is unspecified or not detected.
Please specify a device to boot, or "shell" for a shell
boot() ::



Help Help! Me not get this! Why is this happening to me! :!:

What isn't working here?

I have read that "macintosh partition support" needs to be in the Kernel. I don't know how to check that. How do I check? And how do I put it there if it ain't?


Also this is a "p" from mac-fdisk

Command (? for help): p
/dev/hda
# type name length base ( size ) system
/dev/hda1 Apple_partition_map Apple 63 @ 1 ( 31.5k) Partition map
/dev/hda2 Apple_Driver_ATA Macintosh 64 @ 64 ( 32.0k) Unknown
/dev/hda3 Apple_Driver_ATA Macintosh 64 @ 128 ( 32.0k) Unknown
/dev/hda4 Apple_Bootstrap bootstrap 1600 @ 192 (800.0k) NewWorld bootblock
/dev/hda5 Apple_UNIX_SVR2 swap 1048576 @ 1792 (512.0M) Linux swap
/dev/hda6 Apple_UNIX_SVR2 root 11544582 @ 1050368 ( 5.5G) Linux native

Block size=512, Number of Blocks=12594959
DeviceType=0x0, DeviceId=0x0
Drivers-
1: @ 64 for 21, type=0x701
2: @ 128 for 34, type=0xf8ff






Thanks,
Craig


Last edited by cowboycraig on Thu Sep 14, 2006 10:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Sep 14, 2006 9:36 pm    Post subject: Reply with quote

Well, did you use genkernel when configuring your kernel? Did you create your own config?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
cowboycraig
n00b
n00b


Joined: 14 Sep 2006
Posts: 10

PostPosted: Thu Sep 14, 2006 9:38 pm    Post subject: Reply with quote

I used genkernel
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Sep 14, 2006 9:48 pm    Post subject: Reply with quote

You didn't follow the handbook then. :(

Take a look at:
http://www.gentoo.org/doc/en/handbook/2006.1/handbook-ppc.xml?part=1&chap=10#doc_chap2

And modify your yaboot.conf to match the Genkernel arguments in Code Listing #2. That should help. :)
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
limn
l33t
l33t


Joined: 13 May 2005
Posts: 997

PostPosted: Thu Sep 14, 2006 9:55 pm    Post subject: Reply with quote

cowboycraig:
The moderator would have moved your post, you did not need to create a duplicate.
Back to top
View user's profile Send private message
cowboycraig
n00b
n00b


Joined: 14 Sep 2006
Posts: 10

PostPosted: Thu Sep 14, 2006 9:57 pm    Post subject: Reply with quote

OK me is looking. My yaboot.conf looks like this:

image=/boot/kernel-genkernel-ppc-2.6.17-gentoo-r7
label=Linux
root=/dev/hda6
partition=6
initrd=/boot/initramfs-genkernel-ppc-2.6.17-gentoo-r7
initrd-size=8192
read-only


I don't get what I can change?

I see the:
append="real_root=/dev/hda3 init=/linuxrc"
line but not sure how I figure that in...


?

Craig
Back to top
View user's profile Send private message
cowboycraig
n00b
n00b


Joined: 14 Sep 2006
Posts: 10

PostPosted: Thu Sep 14, 2006 10:05 pm    Post subject: Reply with quote

I fixed it!!!!!!!!!!!

From:
#image=/boot/kernel-genkernel-ppc-2.6.17-gentoo-r7
# label=Linux
# root=/dev/hda6
# partition=6
# read-only
# initrd=/boot/initramfs-genkernel-ppc-2.6.17-gentoo-r7
# initrd-size=8192

To:
image=/boot/kernel-genkernel-ppc-2.6.17-gentoo-r7
label=Linux
root=/dev/ram0
partition=6
initrd=/boot/initramfs-genkernel-ppc-2.6.17-gentoo-r7
append="real_root=/dev/hda6 init=/linuxrc"
initrd-size=8192
read-only

And BOOM, it worked.

Thanks!!!!!!!!!!!!!
Craig
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum