Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo on powerbok g4 - problem with yaboot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Rui_Carlos
n00b
n00b


Joined: 15 Aug 2006
Posts: 6
Location: Braga / Portugal

PostPosted: Thu Sep 21, 2006 6:02 pm    Post subject: gentoo on powerbok g4 - problem with yaboot Reply with quote

I installed gentoo on my PowerBook G4, but i can't configure yaboot.
I think that the problem is in the partitions or in the fstab.

partition map:
Code:
/dev/hda1   Apple_partition_map  Apple                         63 @ 1          ( 31.5k)  partition map
/dev/hda2            Apple_Boot  eXternal booter           262144 @ 64         (128.0M)  Unknown
/dev/hda3            Apple_HFSX  Apple_HFSX_Untitled_1   83099648 @ 262208     ( 39.6G)  Unknown
/dev/hda4            Apple_Boot  eXternal booter           262144 @ 83361856   (128.0M)  Unknown
/dev/hda5            Apple_HFSX  Apple_HFSX_Untitled_2   41156608 @ 83624000   ( 39.6G)  Unknown
/dev/hda6       Apple_Bootstrap  bootstrap                   1600 @ 124780608  (800.0k)  NewWorld bootblock
/dev/hda7       Apple_UNIX_SVR2  swap                     2097152 @ 124782208  (  1.0G)  Linux swap
/dev/hda8       Apple_UNIX_SVR2  root                    29422128 @ 126879360  ( 14.0G)  Linux native


fstab:
Code:
/dev/hda6        /boot        ext2        default,noatime        1 2
/dev/hda7        none         swap        sw                     0 0
/dev/hda8        /            reiserfs    noatime                0 1
none             /proc        proc        defaults               0 0
none             /dev/shm     tmpfs       nodev,nosuid,noexec    0 0
/dev/cdrom       /mnt/cdrom   auto        noauto,user            0 0


yaboot.conf:
Code:
## yaboot.conf generated by yabootconfig 1.0.8
##
## run: "man yaboot.conf" for details. Do not make changes until you have!!
##
## For a dual-boot menu, add one or more of:
## bsd=/dev/hdaX, macos=/dev/hdaY, macosx=/dev/hdaZ

delay=10

timeout=30

defaultos=macosx

boot=/dev/hda6
device=/pci@f4000000/ata-6@d/disk@0:
partition=8
root=/dev/hda8
timeout=30
install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot

image=/boot/2.6.17-gentoo-r5
   label=Linux
   read-only


macosx=/dev/hda3


somebody knows which is the problem?


P.S. sorry by bad english :roll:
_________________
Rui Carlos A. Gonçalves
http://www.rcg-pt.net
Back to top
View user's profile Send private message
limn
l33t
l33t


Joined: 13 May 2005
Posts: 997

PostPosted: Thu Sep 21, 2006 7:14 pm    Post subject: Reply with quote

You need to remove this from your fstab:
Code:
/dev/hda6        /boot        ext2        default,noatime        1 2

The bootblock and /boot are not the same thing.
Back to top
View user's profile Send private message
Rui_Carlos
n00b
n00b


Joined: 15 Aug 2006
Posts: 6
Location: Braga / Portugal

PostPosted: Thu Sep 21, 2006 8:05 pm    Post subject: Reply with quote

yaboot.conf is correct?
_________________
Rui Carlos A. Gonçalves
http://www.rcg-pt.net
Back to top
View user's profile Send private message
limn
l33t
l33t


Joined: 13 May 2005
Posts: 997

PostPosted: Thu Sep 21, 2006 8:21 pm    Post subject: Reply with quote

Looks correct. Are you getting an error running ybin?
Can you boot at all? Maybe post the error messages.
Back to top
View user's profile Send private message
Rui_Carlos
n00b
n00b


Joined: 15 Aug 2006
Posts: 6
Location: Braga / Portugal

PostPosted: Thu Sep 21, 2006 8:43 pm    Post subject: Reply with quote

i add
Code:
ofboot=hd:6


now i only have one error
Code:
ybin: Finding OpenFirmware device path to '/dev/hda3'...
ofpath: Unable to determine sysfs mountpoint
ybin: Unable to determine OpenFirmware path for macosx=/dev/hda3
ybin= Try specifying the real OpenFirmware path for macosx=/dev/hda3 im /etc/yaboot.conf

_________________
Rui Carlos A. Gonçalves
http://www.rcg-pt.net
Back to top
View user's profile Send private message
limn
l33t
l33t


Joined: 13 May 2005
Posts: 997

PostPosted: Thu Sep 21, 2006 9:10 pm    Post subject: Reply with quote

Maybe try
Code:
macosx=hd:3

instead of
Code:
macosx=/dev/hda3
Back to top
View user's profile Send private message
Rui_Carlos
n00b
n00b


Joined: 15 Aug 2006
Posts: 6
Location: Braga / Portugal

PostPosted: Thu Sep 21, 2006 9:15 pm    Post subject: Reply with quote

solved!!

Code:
macosx=hd:2

_________________
Rui Carlos A. Gonçalves
http://www.rcg-pt.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum