Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Erro compilando kde-3.5.4 (RESOLVIDO)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
LuisCO
n00b
n00b


Joined: 09 Feb 2006
Posts: 51

PostPosted: Fri Oct 06, 2006 4:28 pm    Post subject: Erro compilando kde-3.5.4 (RESOLVIDO) Reply with quote

Estou fazendo o emerge kde-3.5.4

Vinha correndo tudo normal e aconteceu o erro que segue:
make:***[sqlite2.o]
cups.cpp 1:23: cups/cups.sh: No such file or directory
cups.cpp 1:23: In function 'int main (int,char**)'
cups.cpp 5: error: 'cups_dest_t' undeclared (first use this function)
cups.cpp 6: error: (Each undeclared identifer is reported only one for each function it appears in)
cups.cpp 5: error: 'd' undeclared (first use this function)
cups.cpp 6: error: 'cupsGetDests' undeclared (first use this function)
cups disbled
cups suport cannot be enabled due to functionality test!
turn on verbose messaging (-v) to ./configure to see the final report
if you belive this message is in error you may use the continue switch (-continue) to ./configure to continue
!!!Error: x11-libs/qt-4.1.4 failed
call stack:
ebuild.sh, line 1546 Called dyn_compile
ebuild.sh, line 937 Called src_compile
qt-4.1.4 ebuild, line 167 Called die

Talvez eu esteja errando na busca mas não encontrei no fórum nada semelhante, então decidi postar.
Desde já agradeço a colaboração de todos


Last edited by LuisCO on Sun Oct 22, 2006 5:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7695
Location: Pelotas, BR

PostPosted: Fri Oct 06, 2006 6:40 pm    Post subject: Reply with quote

QT-4 não deveria ser necessário para kde 3.5.4
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
LuisCO
n00b
n00b


Joined: 09 Feb 2006
Posts: 51

PostPosted: Fri Oct 06, 2006 7:30 pm    Post subject: Reply with quote

Eu vi em outro tópico que não deveria mesmo ser necessário; poderia me dizer por que então esta sendo pedido junto à instalação do kde?
Ou então como fazer para que termine o kde sem que isso venha junto??

Agradeço a força
Back to top
View user's profile Send private message
LuisCO
n00b
n00b


Joined: 09 Feb 2006
Posts: 51

PostPosted: Sat Oct 07, 2006 6:04 pm    Post subject: Reply with quote

Resolvido este problema.

Como não entendi por que estava vindo junto do kde-3.5.4 mesmo não precisando, fiz o emerge separadamente depois disso continuou compilando o kde até certo ponto. Como o problema continua sendo quanto ao kde vou postar o proximo erro aqui mesmo, caso esteja enganado quanto a isso informem.

A cituação é a mesma durante o emerge kde-3.5.4 aconteceu o erro.

!!!ERROR: app-text/aspell-0.60.4 failed
make [1|: ***[libaspell.la| Error 1
make [1|: leaving directory '/var/tmp/portage/aspell-0.60.4/work/aspell-0.60.4'
Call stack
ebuild.sh,line 1546: Called dyn_compile
ebuild.sh, line 937: Called src_compile
aspell-0.60.4 ebuild, line 47: Called die


Tenho a impressão de que eu poderia terminar o emerge do kde sem este pacote e não me faria muita falta (me corrijam se eu estiver errado), mas me esta faltando algo em compreensão pois no manual do gentoo existe explicação de como fazer o emerge retirando algo que achamos desnecessário, porém eu não consigo fazer.
Se alguem puder me confirmar a não necessidade do aspell e como fazer o emerge do kde retirando este pacote já seria de grande ajuda.
Claro que, um esclarecimento de como resolver o problema e o motivo de ocorrer seria muito melhor.

Desde já agradeço a colaboração de todos.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum