Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] emerge --sync problem!!!
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 01 Dec 2005
Posts: 81

PostPosted: Mon Oct 09, 2006 12:33 pm    Post subject: [SOLVED] emerge --sync problem!!! Reply with quote

I'm trying to do "emerge --sync" in my system at last friday and receive this error:

Number of files: 149478
Number of files transferred: 1968
Total file size: 155785892 bytes
Total transferred file size: 6148002 bytes
Literal data: 6148002 bytes
Matched data: 0 bytes
File list size: 3410891
File list generation time: 398.048 seconds
File list transfer time: 0.000 seconds
Total bytes sent: 49887
Total bytes received: 9658775

sent 49887 bytes received 9658775 bytes 9163.44 bytes/sec
total size is 155785892 speedup is 16.05

>>> Updating Portage cache: 100%

Performing Global Updates: /usr/portage/profiles/updates/3Q-2006
(Could take a couple of minutes if you have a lot of binary packages.)
.='update pass' *='binary update' @='/var/db move'
s='/var/db SLOT move' S='binary SLOT move' p='update /etc/portage/package.*'
ppppTraceback (most recent call last):
File "/usr/bin/emerge", line 4049, in ?
File "/usr/bin/emerge", line 4006, in emerge_main
action_sync(settings, trees, mtimedb, myopts, myaction)
File "/usr/bin/emerge", line 2926, in action_sync
File "/usr/lib/portage/pym/", line 6656, in global_updates
File "/usr/lib/portage/pym/", line 198, in update_config_files
write_atomic(updating_file, "".join(file_contents[x]))
File "/usr/lib/portage/pym/", line 728, in write_atomic
File "/usr/lib/portage/pym/", line 696, in close
os.rename(, self._real_name)
OSError: [Errno 16] Device or resource busy

Today, i'm trying again and receive same error. Have someone with this error too? Because my emerge don't work, only if i remove " /usr/portage/profiles/updates/3Q-2006" archive.

My emerge --info:

blackpoison updates # emerge --info
Portage 2.1.1 (default-linux/amd64/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r8-fusion x86_64)
System uname: 2.6.17-gentoo-r8-fusion x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.5
Last Sync: Mon, 09 Oct 2006 11:59:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.2.11-r1
dev-lang/python: 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache: [Not Present]
dev-util/confcache: [Not Present]
sys-apps/sandbox: 1.2.17
sys-devel/autoconf: 2.13, 2.59-r7
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils: 2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.11-r2
CFLAGS="-march=k8 -mtune=k8 -pipe -O2"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=k8 -mtune=k8 -pipe -O2"
FEATURES="autoaddcvs autoconfig ccache distcc distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="amd64 X X509 Xaw3d aac aalib acl acpi alsa apm ares arts async athena auctex authdaemond automount bash-completion berkdb bidi big-tables bitmap-fonts blas buffysize bundled-libs bzip2 caps catalogs cdb cddb cdparanoia cdrom cli cln crypt cscope css cups curl dbus devmap dga directfb dlloader dnd doc dri dts dvb dvd dvdread eds effects elf elibc_glibc emboss encode erandom esd examples extra extrafilters extras fam fbcon ffmpeg fftw finger firefox fits flac foomaticdb fortran fpx freewn ftp fuse gcc64 gcj gd gdbm geos ggi gif gimpprint ginac gml gmp gmtfull gmthigh gmtsuppl gmttria gnutls gopher gpgme gpm gprof grammar graphviz gs gsl gstreamer gtk gtk2 gtkhtml guile hardened hdf hdf5 hpn idn imagemagick imap imlib inkjar input_devices_keyboard input_devices_mouse ipv6 irc isdnlog jabber jack java javascript jbig jpeg jpeg2k justify kernel_linux kqemu lapack lcms libcaca libclamav libgda linguas_pt_BR live lm_sensors logrotate lua lzw lzw-tiff mad mailwrapper math maya-shaderlibrary mbox mng motif mozcalendar mozdevelop mp3 mpeg multiuser musepack musicbrainz nas ncurses neXt netcdf nethack nls nntp nptl nptlonly nsplugin ntfs numeric nvidia objc objc++ objc-gc offensive ogdi ogg on-the-fly-crypt openext opengl oss pam parse-clocks pascal pccts pcre pdf perl plotutils pmu png pop pppd profile python qt3 qt4 quicktime readline reflection rfkill rle rpm rrdtool rtc ruby samba sasl sdl sensord session sftplogging skey slang smime smux sndfile source speex spell spl sqlite srp ssl stats subversion svg swat sysfs syslog tcltk tcpd tetex thesarus tiff toolbar truetype truetype-fonts type1-fonts uim unicode urandom usb userland_GNU userlocales uudeview v4l v4l2 vcd vda video_cards_nv video_cards_nvidia video_cards_vesa vim vorbis with-x wmf wordperfect xface xforms xinerama xml xorg xpm xv xvid yv12 zacl zlib"

Last edited by zhushazang on Tue Oct 10, 2006 11:14 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 11 Feb 2003
Posts: 445

PostPosted: Mon Oct 09, 2006 3:35 pm    Post subject: Reply with quote

This is fixed in >=portage-2.1.1-r1
You're just one revision behind :)
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 01 Dec 2005
Posts: 81

PostPosted: Tue Oct 10, 2006 11:16 am    Post subject: Reply with quote

Aplying the patch don't solved, but removing /usr/portage/profiles/updates/3Q-2006, and running "emerge -vauDN world" solved my problem

Back to top
View user's profile Send private message

Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Sat Oct 28, 2006 9:43 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please see this topic: portage fails - errno 16 Device or resource busy.
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum