Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
!!! Digest verification Failed
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
dk_millares
n00b
n00b


Joined: 23 Oct 2005
Posts: 16
Location: Engenheiro Coelho,SP, Brasil

PostPosted: Thu Oct 12, 2006 5:46 am    Post subject: !!! Digest verification Failed Reply with quote

Oi,

Acabei de instalar meu gentoo amd64 pela segunda vez e quando dou comando emerge para instalar o xorg dá este erro:
!!! Digest verification failed
!!! /usr/portage/distfiles/util-macros-1.10.tar.bz2
!!! Reason: Failed on MD5 verification

Já procurei na net,
Já fiz emerge --sync

Oque pode ser? Nunca tive este problema com o gentoo x86
Tentei reinstalar e dei de cara com o mesmo problema.
Se alguem puder me dar uma ajuda...
Grato desde já
Back to top
View user's profile Send private message
To
Veteran
Veteran


Joined: 12 Apr 2003
Posts: 1145
Location: Coimbra, Portugal

PostPosted: Thu Oct 12, 2006 8:56 am    Post subject: Reply with quote

O ficheiro pode ter ficado danificado. Tenta:

rm /usr/portage/distfiles/util-macros-1.10.tar.bz2

e voltar a fazer o emerge, o ficheiro é sacado de novo, desde que o seja correctamente não tens mais problemas.
_________________

------------------------------------------------
Linux Gandalf 3.2.35-grsec
Gentoo Base System version 2.2
------------------------------------------------
Back to top
View user's profile Send private message
dk_millares
n00b
n00b


Joined: 23 Oct 2005
Posts: 16
Location: Engenheiro Coelho,SP, Brasil

PostPosted: Sat Oct 14, 2006 2:13 am    Post subject: Reply with quote

Oi To,
depois de reinstalar todo o gentoo no pc fiz oque voce me passou e num adiantou nada cara...
estou começando a desanimar ja, reinstalei tres vezes essa semana pensando que fiz algo errado e sempre esse erro;
estou usando o 2006.0 amd64.
Oque posso fazer pra resolver issu?Quero usar o gentoo mas tudo oque vou instalar precisa desse util-macros...
=(
se alguem puder me ajudar...
grato
Back to top
View user's profile Send private message
njsg
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2005
Posts: 87

PostPosted: Sat Oct 14, 2006 9:43 am    Post subject: Reply with quote

Já experimentou fazer
Code:
emerge --sync
para actualizar a árvore do portage? Pode ser que os ficheiros relativos a esse pacote tenham erros, e, como o sync os substitui pela versão mais recente, se for esse o problema fica tudo resolvido.
Back to top
View user's profile Send private message
BaYGoN
Tux's lil' helper
Tux's lil' helper


Joined: 21 Sep 2004
Posts: 109
Location: Brasília - DF (Brasil)

PostPosted: Sat Oct 14, 2006 4:34 pm    Post subject: Reply with quote

dk_millares,

A solução mais "limpa" para seu problema é sem dúvida um emerge --sync. Porém, eu também já tive um problema com digest, e nem um --sync nem apagar o arquivo do distfiles resolveu.
Eu recomendo você tentar alterar o mirror de onde vc baixa suas atualizações e tentar novamente (não esqueça de apagar o arquivo problemático do distfiles antes). Se isso não der certo (também não deu comigo quando tive este problema), existe uma solução meio "suja" para resolver isso:

Code:
ebuild /usr/portage/x11-misc/util-macros/util-macros-1.1.0.ebuild digest


Este comando irá modificar o MD5 do arquivo no ebuild, para que ele reconheça o seu arquivo do distfiles como sendo o esperado.

Repare que o ebuild que eu apontei é da versão 1.1.0, não sei se é a mesma da sua. Verifique a sua digitando:

Code:
emerge -p util-macros


No meu micro, este comando retorna o seguinte:
Quote:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-misc/util-macros-1.1.0


Adapte o comando ebuild acima, para a versão do seu util-macros.
Volto a frisar que, este é o último recurso e o problema pode voltar depois de um novo --sync em que este arquivo tenha uma atualização (Acho difícil, mas pode acontecer).
Tente atualizar seu portage e mudar o mirror de onde vc baixa este arquivo primeiro.

Att,
BaYGoN
_________________
Linux User #433896
HP DV6-6190US / Linux 3.4.6-pf #1 SMP PREEMPT Fri Aug 10 13:19:26 BRT 2012 x86_64 Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz GenuineIntel GNU/Linux
"The destiny of every guru is to be a noob for eternity"
Back to top
View user's profile Send private message
dk_millares
n00b
n00b


Joined: 23 Oct 2005
Posts: 16
Location: Engenheiro Coelho,SP, Brasil

PostPosted: Mon Oct 16, 2006 1:47 am    Post subject: Reply with quote

Obrigado a todos do forum,
depois de mais um reinstall no gentoo;
desta vez eu peguei somente o servidor da unicamp e deu certo, nenhum problema mesmo.
Nem acreditei!
valeu mesmo caras!
[]s
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum