Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ppc g4 stage1 install [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
gohmdoree
Guru
Guru


Joined: 12 Oct 2004
Posts: 533

PostPosted: Thu Oct 26, 2006 3:59 pm    Post subject: ppc g4 stage1 install [Solved] Reply with quote

i tried to get going on a g4 stage1 install and i keep getting stuck on versioning. its either a glibc version error or gcc. meaning, suggesting not to downgrade, yada yada.

still poking around, but its like when i try to emerge empty or rebuild the toolchain, what is on the livecd is greater than what is pulled from portage.

any thoughts?


Last edited by gohmdoree on Tue Nov 07, 2006 4:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Thu Oct 26, 2006 5:34 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Gentoo on PPC.

A stage1 file doesn't contain very much but a minimal system just capable of building the rest. Did you get the latest portage snapshot and/or emerge --sync?
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand


Last edited by nixnut on Thu Oct 26, 2006 5:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
davidgurvich
Veteran
Veteran


Joined: 23 Apr 2004
Posts: 1063

PostPosted: Thu Oct 26, 2006 5:35 pm    Post subject: Reply with quote

Use stage3, get a system up and running. Normal update cycles will get eventually get the same result. Also, do not use the livecd.
Back to top
View user's profile Send private message
gohmdoree
Guru
Guru


Joined: 12 Oct 2004
Posts: 533

PostPosted: Thu Oct 26, 2006 6:14 pm    Post subject: Reply with quote

thanks for the same tip
Back to top
View user's profile Send private message
gohmdoree
Guru
Guru


Joined: 12 Oct 2004
Posts: 533

PostPosted: Tue Nov 07, 2006 4:14 pm    Post subject: Reply with quote

I'm up and running, but been stuck on getting glibc to compile. Going to solve this and focus on

Code:

../sysdeps/unix/sysv/linux/bind.S: Assembler messages:
../sysdeps/unix/sysv/linux/bind.S:5: Error: symbol `__bind' is             already defined


This is from glibc 2.3.6-r4

https://forums.gentoo.org/viewtopic-t-513529-highlight-.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum