Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
apparently I have a BIG problem [SOLVED]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message

Joined: 04 Oct 2004
Posts: 389

PostPosted: Sun Nov 05, 2006 5:37 pm    Post subject: apparently I have a BIG problem [SOLVED] Reply with quote

emerge -e system fails at sys-devel/libperl
Which of these apply, if any? [linux] 

You appear to have ELF support.  I'll try to use it for dynamic loading.
If dynamic loading doesn't work, read hints/ for further information.
Operating system name? [linux] 
Operating system version? [2.6.17-gentoo-r8] 
Build Perl for SOCKS? [n] 
Use the PerlIO abstraction layer? [y] 
Build a threading Perl? [n] 
Build Perl for multiplicity? [n] 
Use which C compiler? [powerpc-unknown-linux-gnu-gcc] 
Checking for GNU cc in disguise and/or its version number...
Now, how can we feed standard input to your C preprocessor...
Directories to use for library searches? [/usr/local/lib /lib /usr/lib] 
What is the file extension used for shared libraries? [so] 
Try to use long doubles if available? [n] 
Checking for optional libraries...
What libraries to use?
[-lnsl -lndbm -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc] 
What optimizer/debugger flag should be used?
[-O1 -mcpu=7450 -maltivec -mabi=altivec -fno-strict-aliasing -pipe] 
Any additional cc flags?
[-fno-strict-aliasing -pipe -Wdeclaration-after-statement] 
Let me guess what the preprocessor flags are...
Any additional ld flags (NOT including libraries)? [ -L/usr/local/lib] 
Checking your choice of C compiler and flags for coherency...
I've tried to compile and run the following simple program:

#include <stdio.h>
int main() { printf("Ok\n"); return(0); }

I used the command:

        powerpc-unknown-linux-gnu-gcc -o try -O1 -mcpu=7450 -maltivec -mabi=altivec -fno-strict-aliasing -pipe -fno-strict-aliasing -pipe -Wdeclaration-after-statement -L/usr/local/lib try.c -lnsl -lndbm -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc

and I got the following output:

/usr/lib/gcc/powerpc-unknown-linux-gnu/4.1.1/../../../../powerpc-unknown-linux-gnu/bin/ld: dynamic variable `' is zero size
/usr/lib/gcc/powerpc-unknown-linux-gnu/4.1.1/../../../../powerpc-unknown-linux-gnu/bin/ld: /usr/lib/gcc/powerpc-unknown-linux-gnu/4.1.1/../../../crt1.o(.rodata+0x0): unresolvable R_PPC_ADDR32 relocation against symbol `'
/usr/lib/gcc/powerpc-unknown-linux-gnu/4.1.1/../../../../powerpc-unknown-linux-gnu/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld returned 1 exit status
I can't compile the test program.
You have a BIG problem.  Shall I abort Configure [y] 
Ok.  Stopping Configure.

!!! ERROR: sys-devel/libperl-5.8.8-r1 failed.
Call stack:, line 1546:   Called dyn_compile, line 937:   Called src_compile
  libperl-5.8.8-r1.ebuild, line 265:   Called die

my make.conf:
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -mcpu=7450 -maltivec -mabi=altivec -fno-strict-aliasing -pipe"


USE="aiglx aim alsa -arts bzip2 cairo cdr dts dvd dvdr -eds -emacs fftw firefox flac gif glitz gnome gtk gtk2 guile hal imagemagick -java -javascript jpeg -kde mono nptl nptlonly ogg pdf plotutils png -qt3 -qt4 quicktime svg tetex tiff truetype usb vorbis wifi xmms"

INPUT_DEVICES="keyboard mouse"


emerge --info:
Portage 2.1.1-r1 (default-linux/ppc/ppc32/2006.1/G4, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r8 ppc)
System uname: 2.6.17-gentoo-r8 ppc 7455, altivec supported
Gentoo Base System version 1.12.6
Last Sync: Sun, 05 Nov 2006 07:30:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.16
CFLAGS="-O2 -mcpu=7450 -maltivec -mabi=altivec -fno-strict-aliasing -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -mcpu=7450 -maltivec -mabi=altivec -fno-strict-aliasing -pipe"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="ppc X aiglx aim alsa altivec apache2 berkdb bitmap-fonts bonobo bzip2 cairo cdr cli cracklib crypt cups dlloader dri dts dvd dvdr elibc_glibc emboss encode esd fftw firefox flac fortran gdbm gif glitz gnome gpm gstreamer gtk gtk2 gtkhtml guile hal iconv imagemagick input_devices_keyboard input_devices_mouse ipv6 isdnlog jpeg kernel_linux ldap libg++ libwww mad mikmod mono mozilla mp3 mpeg ncurses nls nptl nptlonly ogg opengl pam pcre pdf perl plotutils png pppd python quicktime readline reflection ruby sdl session spell spl ssl svg tcpd tetex tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU video_cards_radeon vorbis wifi xml xorg xv zlib"

gentoo good to be true

Last edited by nss on Wed Nov 08, 2006 3:16 pm; edited 2 times in total
Back to top
View user's profile Send private message

Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Nov 05, 2006 5:44 pm    Post subject: Reply with quote

Moved from Portage & Programming to Gentoo on PPC.
You'll probably have better luck here.
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Retired Dev
Retired Dev

Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sun Nov 05, 2006 10:34 pm    Post subject: Reply with quote

Try re-emerging db-4.3 it looks like it's failing due to a linking issue with that.
Gentoo PPC FAQ:
Back to top
View user's profile Send private message

Joined: 04 Oct 2004
Posts: 389

PostPosted: Wed Nov 08, 2006 3:15 pm    Post subject: Reply with quote

Thank you. That solved it.
gentoo good to be true
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum