Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Getting your PC to Powerdown after shutdown -h Command
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
squareroot
n00b
n00b


Joined: 09 Aug 2002
Posts: 22
Location: Orlando, Florida

PostPosted: Sun Aug 25, 2002 3:11 pm    Post subject: Reply with quote

insomniac wrote:
I have an Asus A7v-133, and shutdown works fine. Kernel is compiled with APM, no ACPI. Make sure "Use real mode to power off" is disabled in the kernel!

This is how my EPOX 8KTA3 works. An earlier socket 7 board, and different linux system, needed "Use real mode to power off," ( are computers consistent? )
arkane wrote:
I have an ECS P4S5A and APM would only put it into standby (with the fans still going). A shutdown -h now would make it reboot icon_razz.gif

I just compiled in ACPI and shutdown -h now works as promised. Now, I'd love to know how to put the system into suspend with ACPI *sigh*.

EPOX removed "suspend to RAM" from later versions of my board. ( Heat or power problems, or just buggy? )
[edited later]
A simple cause of these problems is a BIOS setting disabling APM and ACPI. Part of the problem with ACPI has to do with undocumented effects of BIOS settings.
( The BIOS changelog gives some clues, even if you don't intend to flash yours. ASUS is better than ECS about this. )

These people have collected a better set of BIOS links than I had:
http://www.webopedia.com/TERM/B/BIOS.html

(You may find yourself learning things you never intended, just to get your computer to run and stop. )

While checking other systems I found that one SuSE 8.0 system was installed with "safe" options and would not power down. Even though the kernel was compiled with support for APM, ACPI (and UDMA) there are boot flags that turn them off.

If you have tried the suggestions above without luck, check the way you are booting.
Back to top
View user's profile Send private message
biroed
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2002
Posts: 147
Location: Amsterdam

PostPosted: Mon Aug 26, 2002 5:17 pm    Post subject: Reply with quote

One thing i learned was to disable symmetric multi-processing support,
it seems that is a default option in the gentoo kernel.
When i disabled this, the computer stopped and the power went off using apm.
Back to top
View user's profile Send private message
Uranus
Guru
Guru


Joined: 07 May 2002
Posts: 438
Location: Portugal, Braga

PostPosted: Thu Aug 29, 2002 1:34 am    Post subject: Reply with quote

debian wrote:

I've asus a7m266-d and I also got kernel panic with acpi compiled in both r5 and r7.

So I tried mjc-kernel(emerge -s source) and it works perfectly. It also compiles 'I20C' which I previously failed in r5/7.

Just fyi.


I also have the same mobo, and with r5 it kernel panic'ed if I had ACPI... but with r7 it works... go figure
Back to top
View user's profile Send private message
kybber
Apprentice
Apprentice


Joined: 25 Jun 2002
Posts: 228
Location: Trondheim, Norway

PostPosted: Thu Aug 29, 2002 6:44 am    Post subject: Reply with quote

biroed wrote:
One thing i learned was to disable symmetric multi-processing support,
it seems that is a default option in the gentoo kernel.
When i disabled this, the computer stopped and the power went off using apm.


Brilliant! This was the solution for me. shutdown -h now powers down my Dell laptop :-)
Back to top
View user's profile Send private message
timbo
Apprentice
Apprentice


Joined: 29 Jul 2002
Posts: 231
Location: New Zealand

PostPosted: Sat Aug 31, 2002 5:29 am    Post subject: Reply with quote

Well this sugestion did not help me, I've tried everything the thing will still not powerdown.......

It always did with Mandrake, I have even compiled a vanilla kernel and set it up exactly the same but it still dosn't. It's a real pain reaching around the back of the box every time.

Can someone please offer some more sugestions.

Regards
Tim
8)
Back to top
View user's profile Send private message
kryddsill
n00b
n00b


Joined: 08 Sep 2002
Posts: 3
Location: Sapporo, Japan

PostPosted: Sun Sep 08, 2002 1:28 pm    Post subject: no-idle Reply with quote

Google is your friend, maybe. The only relevant information I've been able to find on this thread is this

http://216.239.51.100/search?q=cache:9nYiI0Vf7xgC:phobos.fs.tum.de/pipermail/acpi/2001-February/001061.html+acpi+linux+problem+kernel+apm&hl=en&ie=UTF-8

It pretty much says that "acpi=no-idle" works miracles ;)

Rasmus Ekman
www.kryddsill.net
Back to top
View user's profile Send private message
kryddsill
n00b
n00b


Joined: 08 Sep 2002
Posts: 3
Location: Sapporo, Japan

PostPosted: Sun Sep 08, 2002 1:28 pm    Post subject: no-idle Reply with quote

Google is your friend, maybe. The only relevant information I've been able to find on this thread is this

http://216.239.51.100/search?q=cache:9nYiI0Vf7xgC:phobos.fs.tum.de/pipermail/acpi/2001-February/001061.html+acpi+linux+problem+kernel+apm&hl=en&ie=UTF-8

It pretty much says that "acpi=no-idle" works miracles ;)

Rasmus Ekman
www.kryddsill.net
Back to top
View user's profile Send private message
hfij
n00b
n00b


Joined: 29 Sep 2002
Posts: 8
Location: Alicante (Spain)

PostPosted: Tue Oct 01, 2002 6:14 pm    Post subject: Re: Getting your PC to Powerdown after shutdown -h Command Reply with quote

I have an Asus A7A266, and shutdown works fine. Kernel is compiled with ACPI (all the options checked, compiled as part of the kernel), no APM (only ACPI).

Salu2 - Jorge[/b]
Back to top
View user's profile Send private message
Carlos
Guru
Guru


Joined: 07 Aug 2002
Posts: 458
Location: Providence, RI

PostPosted: Thu Oct 03, 2002 1:25 am    Post subject: Reply with quote

Assuming that you have an ACPI-compliant motherboard, all you need to do is enable Power Management support, ACPI support, Bus Manager, and System. acpid shouldn't make a difference: after all, by the time your system is supposed to be halted, it's been stopped. It definitely worked for me...
Back to top
View user's profile Send private message
peepsalot
n00b
n00b


Joined: 05 Apr 2003
Posts: 52
Location: Texas

PostPosted: Thu Apr 10, 2003 6:34 am    Post subject: Reply with quote

I tried following the instructions in this thread: enabling every option under General Settings--> ACPI Support, then
Code:
emerge acpid
rc-udate add acpid default


I reboot and I see the message "ACPI not compiled into kernel" 8O
But I compiled EVERY freakin ACPI option... :x

Am I missing something here?

Oh, and its a Gigabyte GA-7VAXP mobo, if that helps.
Back to top
View user's profile Send private message
DArtagnan
l33t
l33t


Joined: 30 Apr 2002
Posts: 942
Location: Israel, Jerusalem

PostPosted: Thu Apr 10, 2003 6:52 am    Post subject: Reply with quote

with acpi compiled in kernel I can shutdown but no sound.
Any idea?
_________________
All for one and one for All
--

MACPRO machine...
Back to top
View user's profile Send private message
peepsalot
n00b
n00b


Joined: 05 Apr 2003
Posts: 52
Location: Texas

PostPosted: Thu Apr 10, 2003 3:40 pm    Post subject: Reply with quote

DArtagnan: If you use alsa, did you remember to emerge alsa-driver after recompile?

If that's not it, I don't know. I'm just a n00b. :oops:
_________________
Call me butter, 'cause I'm on a roll!
Back to top
View user's profile Send private message
DArtagnan
l33t
l33t


Joined: 30 Apr 2002
Posts: 942
Location: Israel, Jerusalem

PostPosted: Thu Apr 10, 2003 5:27 pm    Post subject: Reply with quote

peepsalot wrote:
DArtagnan: If you use alsa, did you remember to emerge alsa-driver after recompile?

If that's not it, I don't know. I'm just a n00b. :oops:


Yep :-)
_________________
All for one and one for All
--

MACPRO machine...
Back to top
View user's profile Send private message
peepsalot
n00b
n00b


Joined: 05 Apr 2003
Posts: 52
Location: Texas

PostPosted: Fri Apr 11, 2003 7:36 am    Post subject: Reply with quote

Well, I found this thread, which basically leads me to believe I won't get ACPI working correctly unless I upgrade to a 2.5.XX development kernel. Being relatively new to Linux however, I am a little wary of doing that.

https://forums.gentoo.org/viewtopic.php?t=39637&highlight=acpi
_________________
Call me butter, 'cause I'm on a roll!
Back to top
View user's profile Send private message
ventricle
Guru
Guru


Joined: 04 Apr 2003
Posts: 305
Location: UK/Australia

PostPosted: Wed Apr 23, 2003 11:57 am    Post subject: Reply with quote

ACPI causes my startx to show garbled ascii type screen. When I do compile it in the kernel, my machine does shutdown nicely, but won't shutdown now -r, but if I can't run X, then I'm not able to use it!
Surely there must be a standard way to use APM to get the machine to shutdown? This is a desktop, not a laptop.
_________________
[LRU]
Back to top
View user's profile Send private message
col
l33t
l33t


Joined: 08 May 2002
Posts: 820
Location: Melbourne - Australia

PostPosted: Wed Apr 23, 2003 12:10 pm    Post subject: Reply with quote

I have a gigabyte 7vaxp....when I had kernel 2.4.19 r10 gentoo acpi worked & powered down my PC , since I changed to the gaming kernel 2.4.20 r2 acpi now stops my usb mouse from working which really suks ..... I tried APM which dont powerdown. Really this should work by now.....been compiling in apm & acpi for years now & it has always failed more often than not ....
Back to top
View user's profile Send private message
ajaygautam
Apprentice
Apprentice


Joined: 23 Jan 2003
Posts: 205
Location: London Below

PostPosted: Sat Apr 26, 2003 11:56 am    Post subject: Reply with quote

Well, I got poweroff on shutdown to work ! Woo-hoo !!

I am using the Asus A7N8X deluxe board.

Just for the sake of the free world, and to add cluter, I decided to write these steps for the mere mortals. Here is an account of what I did

1. Includ ACPI in kernel
2. Built _all_ acpi stuff as modules, Rebuild / reinstall kernel
3. In /etc/modules.autoload, add
Code:

#ACPI stuff for 2.4.19(-r10)
ospm_system
ospm_processor
ospm_button

#ACPI stuff for 2.4.20(-r2)
button
fan
processor

For shutdown, "button" is the only one that you will need.
4. modprobe these modules
5. emerge acpid
6. /etc/init.d/acpid start
7. rc-update add acpid default

It woks fine now. I did notice that grub actually shutsdown without any problem or any power mgmt BS...

HTHS

Ajay
Back to top
View user's profile Send private message
bombcar
Guru
Guru


Joined: 08 Apr 2003
Posts: 446
Location: Lincoln Acres, CA

PostPosted: Tue Apr 29, 2003 10:20 pm    Post subject: One little thing to look for.... Reply with quote

Be sure /boot is mounted before you copy your kernel over! :oops:
Back to top
View user's profile Send private message
insomniac
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jul 2002
Posts: 132
Location: Lund, Sweden

PostPosted: Wed Apr 30, 2003 1:47 am    Post subject: Re: Getting your PC to Powerdown after shutdown -h Command Reply with quote

[quote="Megatron2121"]I searched and searched this forum for answers but it seems like a lot of people gave up on getting this working. I have a really bad tendency to not sleep when I have a computer issue so I had to get this working :-)

I must have recompiled my kernel 20 times before I figured this out. :oops:

But I did :-) My machine shuts down and powers off now :-)

I have an ASUS board. ACPI compliant. So what I did was

I compiled the kernel with ACPI support. I enabled the whole ACPI tree and compiled it directly into the kernel.[/quote]

THAT was the culprit - I had previously tried compiling the ACPI stuff as modules, which did not work. When compiled directly into the kernel, the computer (Asus A7V133 + Athlon 1200) shuts down just fine!
_________________
My next computer is also a Gentoo computer
Back to top
View user's profile Send private message
ajaygautam
Apprentice
Apprentice


Joined: 23 Jan 2003
Posts: 205
Location: London Below

PostPosted: Wed Apr 30, 2003 4:32 am    Post subject: Reply with quote

insomniac, which kernel version are you using ?

I had everything working as modules in 2.4.19. I upgraded to 2.4.20, and xwindows freezes the system on boot. If I pass acpi=off to kernel, everything boots up fine...

Any inputs ?

TIA

Ajay Gautam
Motherboard: ASUS A7N8X Deluxe
Back to top
View user's profile Send private message
insomniac
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jul 2002
Posts: 132
Location: Lund, Sweden

PostPosted: Wed Apr 30, 2003 4:56 am    Post subject: Reply with quote

i've tried this with 2.4.19 and 2.5.68.
_________________
My next computer is also a Gentoo computer
Back to top
View user's profile Send private message
Lars
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 168
Location: Germany, near baltic sea

PostPosted: Wed Apr 30, 2003 6:03 am    Post subject: Reply with quote

I have an old NMC VIA MPV3 with K6-III 450
Power down works very well, but last weeks also my power down does not work any longer after change some things in kernel.
APM or ACPI both don't work.

But I found a solution.
CONFIG_SMP
is my killer, if it's active in the kernel, power down does not work. If your computer isn't a SMP machine (>1 CPU), switch it off.

Now, I use only APM (build in) and no ACPI. And it's working again :D

:!: 'For your safety (tm)' recompile the hole(!) kernel with make clean dep bzImage ...

Lars
Back to top
View user's profile Send private message
ajaygautam
Apprentice
Apprentice


Joined: 23 Jan 2003
Posts: 205
Location: London Below

PostPosted: Wed Apr 30, 2003 4:09 pm    Post subject: Reply with quote

Lars, I am not able to compile gentoo-sources 2.4.20 kernel with SMP off. I disabled it at "Processor type and features -> Symmetric multi-processing support". when I compile, I get (last gcc command onwards):

Code:

gcc -D__KERNEL__ -I/usr/src/linux-2.4.20-gentoo-r2/include -Wall -Wstrict-prototypes -Wno-trigraphs -O3 -fno-strict-aliasing -
fno-common -fomit-frame-pointer -pipe -mpreferred-stack-boundary=2 -march=athlon-xp -Os   -nostdinc -iwithprefix include -DKBU
ILD_BASENAME=ksyms  -DEXPORT_SYMTAB -c ksyms.c
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/modversions.h:68,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/module.h:21,
                 from ksyms.c:17:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/modules/dec_and_lock.ver:2:1: warning: "atomic_dec_and_lock" redefined
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/wait.h:16,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/fs.h:12,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/capability.h:17,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/binfmts.h:6,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/sched.h:9,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/mm.h:4,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/slab.h:14,
                 from ksyms.c:15:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/spinlock.h:67:1: warning: this is the location of the previous definition
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/modversions.h:135,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/module.h:21,
                 from ksyms.c:17:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/modules/i386_ksyms.ver:88:1: warning: "cpu_data" redefined
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/prefetch.h:13,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/list.h:6,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/wait.h:14,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/fs.h:12,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/capability.h:17,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/binfmts.h:6,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/sched.h:9,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/mm.h:4,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/slab.h:14,
                 from ksyms.c:15:
/usr/src/linux-2.4.20-gentoo-r2/include/asm/processor.h:80:1: warning: this is the location of the previous definition
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/modversions.h:135,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/module.h:21,
                 from ksyms.c:17:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/modules/i386_ksyms.ver:92:1: warning: "smp_num_cpus" redefined
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/sched.h:23,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/mm.h:4,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/slab.h:14,
                 from ksyms.c:15:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/smp.h:80:1: warning: this is the location of the previous definition
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/modversions.h:135,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/module.h:21,
                 from ksyms.c:17:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/modules/i386_ksyms.ver:94:1: warning: "cpu_online_map" redefined
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/sched.h:23,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/mm.h:4,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/slab.h:14,
                 from ksyms.c:15:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/smp.h:88:1: warning: this is the location of the previous definition
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/modversions.h:135,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/module.h:21,
                 from ksyms.c:17:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/modules/i386_ksyms.ver:108:1: warning: "smp_call_function" redefined
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/sched.h:23,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/mm.h:4,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/slab.h:14,
                 from ksyms.c:15:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/smp.h:87:1: warning: this is the location of the previous definition
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/modversions.h:170,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/module.h:21,
                 from ksyms.c:17:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/modules/ksyms.ver:594:1: warning: "del_timer_sync" redefined
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/ext3_fs_sb.h:20,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/fs.h:692,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/capability.h:17,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/binfmts.h:6,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/sched.h:9,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/mm.h:4,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/slab.h:14,
                 from ksyms.c:15:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/timer.h:30:1: warning: this is the location of the previous definition
In file included from ksyms.c:20:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/kernel_stat.h: In function `kstat_irqs':
/usr/src/linux-2.4.20-gentoo-r2/include/linux/kernel_stat.h:57: `smp_num_cpus' undeclared (first use in this function)
/usr/src/linux-2.4.20-gentoo-r2/include/linux/kernel_stat.h:57: (Each undeclared identifier is reported only once
/usr/src/linux-2.4.20-gentoo-r2/include/linux/kernel_stat.h:57: for each function it appears in.)
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/interrupt.h:45,
                 from ksyms.c:24:
/usr/src/linux-2.4.20-gentoo-r2/include/asm/hardirq.h:41:1: warning: "synchronize_irq" redefined
In file included from /usr/src/linux-2.4.20-gentoo-r2/include/linux/modversions.h:135,
                 from /usr/src/linux-2.4.20-gentoo-r2/include/linux/module.h:21,
                 from ksyms.c:17:
/usr/src/linux-2.4.20-gentoo-r2/include/linux/modules/i386_ksyms.ver:96:1: warning: this is the location of the previous defin
ition
make[2]: *** [ksyms.o] Error 1
make[2]: Leaving directory `/usr/src/linux-2.4.20-gentoo-r2/kernel'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.20-gentoo-r2/kernel'
make: *** [_dir_kernel] Error 2


I am able to re-compile my kernel after enabling the SMP option.

Any suggestions ?

Thanks

Ajay
Back to top
View user's profile Send private message
Lars
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 168
Location: Germany, near baltic sea

PostPosted: Fri May 02, 2003 5:25 am    Post subject: Reply with quote

Sorry, I've forgotten to say, I use the 2.4.20 vanilla-source kernel and it's compileable very well.

Lars
Back to top
View user's profile Send private message
Klin'Targ
n00b
n00b


Joined: 04 Mar 2003
Posts: 65
Location: Davis, CA

PostPosted: Wed May 21, 2003 1:09 am    Post subject: Reply with quote

ajaygautam: I had your problem, and fixed it by copying the .config file to another folder (root's home will do) and doing a make mrproper, then copying the .config file back to /usr/src/linux.

This error seemed to be caused by some file referring to multiprocessor support not being deleted as it should have been.

However, I am having another problem. Enabling ACPI support for my laptop (a Toshiba Satellite 1415-S173) causes the system to have 100% cpu usage at all times.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum