Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] PowerBook Pismo frame buffer problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
demonpengu
n00b
n00b


Joined: 12 Jan 2005
Posts: 6

PostPosted: Wed Nov 29, 2006 2:08 pm    Post subject: [Solved] PowerBook Pismo frame buffer problems Reply with quote

Having spent the last couple of years using gentoo on numerous platforms, I took the plunge and had a go on my Pismo.

I have at last got the system running reasonably nicely from a 2006.1 install.

I still have one irritating problem however. For some reason when set to 1024x768 the text falls off the bottom of the screen by about 10 lines or so, even though when yaboot starts there is a nice crisp text console running in the right mode. I have even gone as far as converting the Modeline from my Xorg.0.log and running through the conversion from

Code:
(II) R128(0): Modeline "1024x768"   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync
to
Code:
append="video=aty128fb:xres:1024,yres:768,depth:16,left:198,right:24,hslen:136,upper:29,lower:3,vslen:6,pixclock:15384"


I have also tried a different screen from another pismo, with exactly the same results. On top of that I had the same problems with ubuntu 6.1.0. I am now completely at a loss as to what to try. There are too many results from google relating to lord know how many problems.

One thing I have noticed is that there is often mention of /etc/fb.modes which I have not got.

Here is the top part of dmesg in case that may be of use.

Code:
Using PowerMac machine description
Total memory = 384MB; using 1024kB for hash table (at cff00000)
Linux version 2.6.17-gentoo-r5 (root@livecd) (gcc version 4.1.1 (Gentoo 4.1.1)) #1 Tue Nov 28 22:12:05 GMT 2006
Found UniNorth memory controller & host bridge @ 0xf8000000 revision: 0x08
Mapped at 0xfdfc0000
Found a Keylargo mac-io controller, rev: 3, mapped at 0xfdf40000
Processor NAP mode on idle enabled.
PowerMac motherboard: PowerBook Pismo
via-pmu: Server Mode is disabled
PMU driver v2 initialized for Core99, firmware: 0c
Found UniNorth PCI host bridge at 0xf0000000. Firmware bus number: 0->0
Found UniNorth PCI host bridge at 0xf2000000. Firmware bus number: 0->1
Found UniNorth PCI host bridge at 0xf4000000. Firmware bus number: 0->0
nvram: Checking bank 0...
nvram: gen0=690, gen1=689
nvram: Active bank is: 0
nvram: OF partition at 0x210
nvram: XP partition at 0x1220
nvram: NR partition at 0x1320
Top of RAM: 0x18000000, Total RAM: 0x18000000
Memory hole size: 0MB
On node 0 totalpages: 98304
  DMA zone: 98304 pages, LIFO batch:31
Built 1 zonelists
Kernel command line: root=/dev/hda3 ro video=aty128fb:800x600
mpic: Setting up MPIC " MPIC 1   " version 1.2 at 80040000, max 4 CPUs
mpic: ISU size: 64, shift: 6, mask: 3f
mpic: Initializing for 64 sources
PID hash table entries: 2048 (order: 11, 8192 bytes)
GMT Delta read from XPRAM: 0 minutes, DST: off
time_init: decrementer frequency = 24.966218 MHz
time_init: processor frequency   = 400.000000 MHz
Console: colour dummy device 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 384000k/393216k available (3332k kernel code, 8684k reserved, 296k data, 139k bss, 176k init)
Calibrating delay loop... 49.79 BogoMIPS (lpj=99584)
Mount-cache hash table entries: 512
device-tree: Duplicate name in /cpus/PowerPC,750@0, renamed to "l2-cache#1"
NET: Registered protocol family 16
KeyWest i2c @0xf8001003 irq 42 /uni-n@f8000000/i2c@f8001000
 channel 0 bus <multibus>
 channel 1 bus <multibus>
KeyWest i2c @0x80018000 irq 26 /pci@f2000000/mac-io@17/i2c@18000
 channel 0 bus <multibus>
PMU i2c /pci@f2000000/mac-io@17/via-pmu@16000
 channel 1 bus <multibus>
 channel 2 bus <multibus>
PCI: Probing PCI hardware
Can't get bus-range for /pci@f2000000/cardbus@1a, assuming it starts at 0
SCSI subsystem initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 4, 65536 bytes)
TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
TCP: Hash tables configured (established 16384 bind 8192)
TCP reno registered
Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered (default)
io scheduler deadline registered
io scheduler cfq registered
Generic RTC Driver v1.07
Macintosh non-volatile memory driver v1.1
PCI: Enabling device 0000:00:10.0 (0086 -> 0087)
aty128fb: Invalid ROM signature 0 should  be 0xaa55
aty128fb: BIOS not located, guessing timings.
aty128fb: Rage128 LF M3 AGP [chip rev 0x0] 8M 128-bit SDR SGRAM (1:1)
Console: switching to colour frame buffer device 100x37
Registered "ati" backlight controller,level: 15/15
fb0: ATY Rage128 frame buffer device on Rage128 LF M3 AGP
no framebuffer address found for /pci@f0000000/ATY,RageM3pParent@10/ATY,RageM3pB
mice: PS/2 mouse device common for all mice
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
loop: loaded (max 8 devices)
sungem.c:v0.98 8/24/03 David S. Miller (davem@redhat.com)
PHY ID: 406212, addr: 0
eth0: Sun GEM (PCI) 10/100/1000BaseT Ethernet 00:30:65:b5:bf:44
eth0: Found BCM5201 PHY
pcnet32.c:v1.32 18.Mar.2006 tsbogend@alpha.franken.de
PPP generic driver version 2.4.2
PPP Deflate Compression module registered
MacIO PCI driver attached to Keylargo chipset
mediabay0: Registered KeyLargo media-bay


TIA guys

Andy


Last edited by demonpengu on Thu Nov 30, 2006 4:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Nov 29, 2006 8:04 pm    Post subject: Reply with quote

Try emerging fbset. It lets you move the framebuffer around on the screen and it might fix your problem.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
demonpengu
n00b
n00b


Joined: 12 Jan 2005
Posts: 6

PostPosted: Wed Nov 29, 2006 8:55 pm    Post subject: Reply with quote

Thanks JoseJX

I have already got fbset on board, and I'm not sure quite what else will help to sort this out. If only the yaboot screen resolution stayed after the kernel is loading. The problems is not so much that the picture is too low so much as the top left hand side of the screen is in the correct position, it just finishes off the screen at the bottom.

As I said I have tried converting from the Modeline detected by xorg (which gives a much better picture than OSX by the way) but that seems to do exactly the same thing as just doing a straight 1024x768 setting :cry:

Do I perhaps need to look at fonts in the kernel or is that more of an x86 sort of thing, as I noticed in the x86 kernel setup there are resolutions you can set within that.
Back to top
View user's profile Send private message
demonpengu
n00b
n00b


Joined: 12 Jan 2005
Posts: 6

PostPosted: Thu Nov 30, 2006 4:46 pm    Post subject: Reply with quote

Ok I found an old HDD with OSX on it , booted up, changed the resolution to 800x600 and back again then back to 1024x768, and then shutdown OSX.

I then put the HDD with gentoo back in and booted the machine.....to now get the white screen while booting, but the machine load GDM and the screen came back (could also ssh in as well!). I the edited yaboot.conf, removed the append="video=aty128fb:800x600" rebooted and lo and behold the screen works exactly as it should.

So now it works, but I am completely confused as to why!!

Answers on a postcard please! :lol:
_________________
Illegitimi non carborundum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum