Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with nvidia drivers durig emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
bascom
n00b
n00b


Joined: 05 Dec 2006
Posts: 19
Location: North Carolina

PostPosted: Sun Dec 10, 2006 1:26 am    Post subject: Problems with nvidia drivers durig emerge Reply with quote

When I try to load my nvidia-drivers using emerge nvidia-drivers I get the following errors :

All ebuilds that could satisfy "nvidia-drivers" have been masked.
One of the following masked packages is required to complete your request:
-x11-drivers/nvidia-drivers-1.0.9742 (masked by : missing keword)
-x11-drivers/nvidia-drivers-1.0.9631 (masked by : missing keword)
-x11-drivers/nvidia-drivers-1.0.8776 (masked by : missing keword)
-x11-drivers/nvidia-drivers-1.0.8774 (masked by : missing keword)

Could someone please give a brother a hand ?

Thanks
Back to top
View user's profile Send private message
noice
Guru
Guru


Joined: 05 Dec 2005
Posts: 473
Location: italia, Ischia

PostPosted: Sun Dec 10, 2006 1:36 am    Post subject: Re: Problems with nvidia drivers durig emerge Reply with quote

you can try:
Code:
echo "x11-drivers/nvidia-drivers-1.0.9742" >> /etc/portage/package.keywords
echo "x11-drivers/nvidia-drivers-1.0.9631" >> /etc/portage/package.keywords
echo "x11-drivers/nvidia-drivers-1.0.8776" >> /etc/portage/package.keywords
echo "x11-drivers/nvidia-drivers-1.0.8774" >> /etc/portage/package.keywords

_________________
Noice

when you post remove comments
Code:
grep -vh '^[[:space:]]*\(#\|$\)' "$@"
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Dec 10, 2006 1:43 am    Post subject: Reply with quote

The nvidia-drivers do not work on PPC. You will need to use the nv (xf86-video-nv) driver instead.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
bascom
n00b
n00b


Joined: 05 Dec 2006
Posts: 19
Location: North Carolina

PostPosted: Sun Dec 10, 2006 1:55 am    Post subject: nv ? Reply with quote

Well, now that I know that the nvidia drivers do not work on ppc that certainly simplifies things a bit.
How do use nv driver, the obvious, emerge nv is not it

Thanks
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Dec 10, 2006 1:59 am    Post subject: Reply with quote

set VIDEO_CARDS="nv" in /etc/make.conf, then when you emerge xorg-server is should bring in the package for the nv drivers.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
bascom
n00b
n00b


Joined: 05 Dec 2006
Posts: 19
Location: North Carolina

PostPosted: Sun Dec 10, 2006 2:13 am    Post subject: nv driver Reply with quote

Great,
How can I check for the nv driver ?
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sun Dec 10, 2006 2:33 am    Post subject: Reply with quote

In the Device section of /etc/X11/xorg.conf, make sure that the driver is set to nv.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum