Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Blender Crashing X server
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
gentooken
n00b
n00b


Joined: 24 Jul 2006
Posts: 23

PostPosted: Wed Dec 13, 2006 12:29 am    Post subject: Blender Crashing X server Reply with quote

I can launch blender fine, but simply doing say, holding middle mouse down and circling the default cube and moving the camera along the different axis's crashes blender, and HARD. It takes the X server down with it.

Any ideas? I'm on ppc linux with an Nvidia card using the opensource nv driver

Xorg log has this:
Code:
Backtrace:
0: X(xf86SigHandler+0x98) [0x1008ed2c]
1: [0x100374]
2: [0x10a56408]
3: /usr/lib/xorg/modules/extensions/libGLcore.so(_swrast_write_rgba_span+0x510) [0xf5e8164]
4: /usr/lib/xorg/modules/extensions/libGLcore.so [0xf5dbc08]
5: /usr/lib/xorg/modules/extensions/libGLcore.so [0xf5d1708]
6: /usr/lib/xorg/modules/extensions/libGLcore.so(_swrast_Line+0x2c) [0xf5d06cc]
7: /usr/lib/xorg/modules/extensions/libGLcore.so [0xf613910]
8: /usr/lib/xorg/modules/extensions/libGLcore.so(_tnl_RenderClippedLine+0x2c) [0xf63c48c]
9: /usr/lib/xorg/modules/extensions/libGLcore.so [0xf6349d4]
10: /usr/lib/xorg/modules/extensions/libGLcore.so [0xf6374a4]
11: /usr/lib/xorg/modules/extensions/libGLcore.so [0xf63c5b4]
12: /usr/lib/xorg/modules/extensions/libGLcore.so(_tnl_run_pipeline+0x188) [0xf61d838]
13: /usr/lib/xorg/modules/extensions/libGLcore.so(_tnl_flush_vtx+0x358) [0xf6508dc]
14: /usr/lib/xorg/modules/extensions/libGLcore.so(_tnl_FlushVertices+0x94) [0xf64bbd4]
15: /usr/lib/xorg/modules/extensions/libGLcore.so(_mesa_LoadMatrixf+0x118) [0xf5653ec]
16: /usr/lib/xorg/modules/extensions/libglx.so [0xf9db120]
17: /usr/lib/xorg/modules/extensions/libglx.so(__glXRender+0x180) [0xf9cf094]
18: /usr/lib/xorg/modules/extensions/libglx.so [0xf9d5304]
19: X(Dispatch+0x228) [0x100438cc]
20: X(main+0x47c) [0x100255d0]
21: /lib/libc.so.6 [0xfb86758]
22: /lib/libc.so.6 [0xfb869ac]

Fatal server error:
Caught signal 11.  Server aborting



Code:
emerge --info
Portage 2.1.1-r2 (default-linux/ppc/ppc64/2006.1/32bit-userland/970/pmac, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r3 ppc64)
=================================================================
System uname: 2.6.18-gentoo-r3 ppc64 PPC970, altivec supported
Gentoo Base System version 1.12.6
Last Sync: Tue, 12 Dec 2006 21:30:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: [Not Present]
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.16
ACCEPT_KEYWORDS="ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -pipe -mtune=970 -mcpu=970 -maltivec -mabi=altivec -fno-strict-aliasing"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -pipe -mtune=970 -mcpu=970 -maltivec -mabi=altivec -fno-strict-aliasing"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://www.gtlib.gatech.edu/pub/gentoo "
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="ppc X alsa altivec apache2 apm arts berkdb bitmap-fonts cli cracklib cups dlloader dri eds elibc_glibc emboss encode esd foomaticdb fortran gcc64 gdbm gif gnome gpm gstreamer gtk iconv imlib input_devices_keyboard input_devices_mouse ipv6 isdnlog jpeg kde kernel_linux libg++ libwww mad mikmod motif mp3 mpeg ncurses nls nptl nptlonly ogg opengl oss pam pcre perl png pppd python qt3 qt4 quicktime readline reflection sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts udev unicode userland_GNU video_cards_nv vorbis xml xorg xv zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Dec 13, 2006 2:07 am    Post subject: Reply with quote

Looks like a bug in the software renderer. Perhaps report it upstream to X.org, they would know if it's an application error or an issue with the driver.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum