Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
yaboot on XFS with initrd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Sun Dec 17, 2006 2:19 pm    Post subject: yaboot on XFS with initrd Reply with quote

I switched / filesystem from reiserfs to XFS. /boot has no seperated partition.
Now with the hint of our ppc faq about transfering the kernel image by cat vmlinux > /boot/kernel rather then by cp to avoid fragmentation finally I got the kernel booting. XFS seems to be quite sensitive for fragmentation here and gives kernel panic.

Now I'm not able to boot with initrd=/boot/fbsplash. I also copied this file by cat >. I made this image again with splash_geninitramfs. I also checked fragmentation of that file with xfs_fsr. I still get kernel panic.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Sun Dec 17, 2006 2:25 pm    Post subject: Reply with quote

Can you be more specific about what is causing the panic? Can you tell us what the panic is?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1563
Location: Germany

PostPosted: Sun Dec 17, 2006 3:38 pm    Post subject: Reply with quote

The kernel loads (version is shown), the display flushes as usual and is cleaned again.
Now the only line:
Code:
Unable to mount root fs on unknown-block(0,4)


At the moment, this yaboot section works, but without splash:
Code:
image=/boot/kernel
        label=Linux
        read-only
#       append="video=radeonfb:1024x768-32 splash=verbose,fadein,kdgraphics,theme:lila quiet fbcon=scrollback:128K CONSOLE=/dev/tty1 softlevel=wlan"
        append="video=radeonfb:1024x768-32 quiet fbcon=scrollback:128K CONSOLE=/dev/tty1 softlevel=wlan"
#       initrd=/boot/fbsplash-1024x768

_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G|amd64:HP EliteBook 8560w,i7-2620M,16G|Acer Z5610 (Core2QuadQ8200),8G|amd64-prefix:OpenSuse|HP EliteDesk 800G1 i7-4790|HP Compaq Pro 6300 i7-3770
Lila-Theme
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum