Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
net.ppp0 (adsl pppoe) network problem with xen domU started
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message

Joined: 11 Jul 2006
Posts: 9

PostPosted: Tue Dec 19, 2006 1:41 pm    Post subject: net.ppp0 (adsl pppoe) network problem with xen domU started Reply with quote


this has been bothering me for longer time and I have found no satisfying solution yet. if you had any *i mean really - any* ideas they woud be definetely appreciated.
in my setup I have one central server, which is main mail server, web, firewall etc and virtual machines are running under xen (mainly testing stuff, nothing too important)
i have gentoo 2006.1 with all latest updates (emerge finished yesterday) and xen 3.02-r4 running on it
recently after emerges old type of adsl pppoe seemed to be broken in conf.d/net, so i switched according to net.example to the new "proper way" of setting up pppoe connection (i can provide conf.d/net if requested but i checked it with different sources some dozen times, so one can almost assume it is ok)
the virtual network is bound to interface dummy0

internet---(eth3/ppp0)-dom0-(dummy0)--------(all the xen machines)
eth2(internal net)

probably most common setup to be found - in /etc/xen/xend-config.sxp only one change
(network-script network-bridge 'netdev=dummy0')
(vif-script vif-bridge)

now what happens - bootup works fine, all network cards start (except dummy0), xend/xendomains starts OK (bringing dummy0 up). i then try to start centos domU with the same kernel as above only domU version, and as soon as it tries to access the network through ppp0 interface, the ppp0 dies in very strange way, meaning:
interface ppp0 and eth3 are still up
there are still default routes set for ppp0
tcpdump on ppp0 shows no packets coming-in/out, from internal network, shows only some some LCP exchange with pppoe gateway

now i can still access internal networks from domU and vice-versa and also before problem happens i can access networks (except ppp0) and it does not cause any problems

what else - lets say i dont do anything with domU, but just start it and then restart named in dom0 (can be any other daemon) which binds separately to all network cards, then the same problem happens again - net.ppp0 gets somehow "disjointed" from the rest of kernel network stack and rest of OS does not see it (forgets about it?)

problem has nothing to do with iptables - tried to restart it / stop it (leaving just forwarding on) - all the same - no packets coming to net.ppp0 (although it is there and UP and routes are set)

what i made so far:
- reinstall xen completely including kernel redownload/recompile
- emerge -e x2 (system, then world)
- reinstall and recompile xen + kernel again

in the process after that last thing i noticed something very interesting:
- if I enable in the kernel "bridged ip/arp packets filtering" to have "physdev" match support then the whole problem above dissapears!
- however my life would be too good - with following options enabled packets coming out from dummy0 network don't seem to be hitting the POSTROUTING chain in iptables in NAT table and thus i have packets with private ip address leaving ppp0 (and we know what internet routers do with such packets, dont we?). WHY DOES IT HAPPEN?

- it would also be great to know why before even without bridged filtering all worked perfect and now it does not anymore (i disabled bridged filtering intentionally - i didnt need any l2 filtering and it was nightmare to configure)
- the other main question remains - why the hell the packets from dummy0 dont go through POSTROUTING chain? Where could I NAT them? With ebtables? This is illogical to have two separate functions in kernel to do the same thing.

Any ideas would be greatly appreciated! I can provide *any* config files/logfiles you request. (btw. dmesg,messages shows nothing, pppd is set to debug - also nothing)

Let me know if you saw anything even remotely similarrrr....

Back to top
View user's profile Send private message

Joined: 23 Sep 2003
Posts: 7221
Location: Sat in front of my computer

PostPosted: Tue Dec 19, 2006 6:34 pm    Post subject: Reply with quote

Moved from Kernel & Hardware to Duplicate Threads, please don't crosspost. Follow ups to this topic: net.ppp0 (adsl pppoe) network problem with xen domU started.
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum