Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Digest verification problems?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
dutchman
n00b
n00b


Joined: 16 Aug 2006
Posts: 20

PostPosted: Mon Jan 01, 2007 3:38 am    Post subject: Digest verification problems? Reply with quote

For the last week or so, I've been getting more and more digest verification errors pop up. I thought they would go away on their own, but they haven't. In fact, the number of issues seems to go up each time I resync. Any ideas? I don't see the same problems on my x86 box. Here is what I'm seeing whenever I go to emerge something:

Code:
# emerge -av portage

These are the packages that would be merged, in order:

Calculating dependencies \!!! Digest verification failed:
!!! /usr/portage/media-video/ffmpeg/ffmpeg-0.4.9_p20061016.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 5605
!!! Expected: 5596
 -!!! Digest verification failed:
!!! /usr/portage/media-libs/libmikmod/libmikmod-3.1.11-r3.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 1262
!!! Expected: 1263
 |!!! Digest verification failed:
!!! /usr/portage/dev-perl/Net-DNS/Net-DNS-0.59.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 748
!!! Expected: 744
 |!!! Digest verification failed:
!!! /usr/portage/sys-apps/tcp-wrappers/tcp-wrappers-7.6-r8.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 2294
!!! Expected: 2295
 -!!! Digest verification failed:
!!! /usr/portage/sys-libs/cracklib/cracklib-2.8.9-r1.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 1406
!!! Expected: 1514
 \!!! Digest verification failed:
!!! /usr/portage/sys-apps/man/man-1.6e.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 3307
!!! Expected: 3001
 /!!! Digest verification failed:
!!! /usr/portage/dev-java/avalon-logkit/avalon-logkit-1.2-r2.ebuild
!!! Reason: Failed on MD5 verification
!!! Got: 506b304ccae69a3b751092ee48cfb2b9
!!! Expected: 22543580679bb13b2be163dd875d8d36
 \!!! Digest verification failed:
!!! /usr/portage/dev-java/gjdoc/gjdoc-0.7.7-r1.ebuild
!!! Reason: Failed on MD5 verification
!!! Got: f954ebeed1e16ff7f18a9c700ef51c48
!!! Expected: 64209a5e0c0fbea6865552a6f7de1973
... done!
[ebuild   R   ] sys-apps/portage-2.1.2_rc4-r4  USE="-build -doc -epydoc (-selinux)" LINGUAS="-pl" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]   
Back to top
View user's profile Send private message
limn
l33t
l33t


Joined: 13 May 2005
Posts: 997

PostPosted: Mon Jan 01, 2007 12:02 pm    Post subject: Reply with quote

Only looking at the first two, it appears that the Manifests were not updated when the ebuilds were.
Do you have PORTAGE_RSYNC_EXTRA_OPTS set somehow to exclude Manifests?
Back to top
View user's profile Send private message
dutchman
n00b
n00b


Joined: 16 Aug 2006
Posts: 20

PostPosted: Tue Jan 02, 2007 12:53 am    Post subject: Reply with quote

I don't have a PORTAGE_RSYNC_EXTRA_OPTS in my /etc/make.conf at all. In fact, the only thing out of the norm is probably layman. Hmm...
Back to top
View user's profile Send private message
JoseJX
Retired Dev
Retired Dev


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Jan 02, 2007 1:10 am    Post subject: Reply with quote

Can you post your make.conf? Have you tried removing the directories containing errors and re-syncing?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
limn
l33t
l33t


Joined: 13 May 2005
Posts: 997

PostPosted: Tue Jan 02, 2007 1:25 am    Post subject: Reply with quote

You might also check, for example, whether
Code:
grep ffmpeg-0.4.9_p20061016.ebuild /usr/portage/media-video/ffmpeg/Manifest

shows the 5596 size.
Back to top
View user's profile Send private message
dutchman
n00b
n00b


Joined: 16 Aug 2006
Posts: 20

PostPosted: Tue Jan 02, 2007 3:13 am    Post subject: Reply with quote

Thanks for the ideas. I've just ripped portage out completely and brought back the latest snapshot and it seems fine. Not sure what triggered the problem, but don't really care now ;)

Happy New Year :)

-d
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum