Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing Gentoo on a PowerBook G3 Lombard
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
avegas
n00b
n00b


Joined: 08 Jan 2007
Posts: 1
Location: Boston, Ma

PostPosted: Mon Jan 08, 2007 11:20 pm    Post subject: Installing Gentoo on a PowerBook G3 Lombard Reply with quote

Hey all,

I'm trying to get Gentoo up and running on this ancient PowerBook. I worked through the first eleven steps of the handbook with what seemed like success, but when I went for the reboot(using kernel built from vanilla-source 2.6.18.4) I got this as a result:

Using Power Mac machine description
Total Memory = 64 mb; using 128kb for hash table (at c3fe0000)
Linux version 2.6.18.4 (root@livecd) (gcc version 4.1.1 (Gento 4.1.1) )
Found a Paddington mac-io controller, rev : 0 mapped at 0xfdf80000
PowerMac motherboard: PowerBook 101(Lombard)
setup_arch: bootmem
Found Grackle (MPC106) PCI host bridge at 0x00000080000000
nvram: OF partition at 0x140
nvram: XP partition at 0xffffffff
nvram: NR partition at 0xffffffff
arch: exit
Built 1 zonelists. Total pages: 16384
Kernel command line: root=/dev/hda8 ro video=ofonly
irq: Found primary Apple PIC /pci@80000000/mac-io@10 for 64 irqs
irq: System has 64 possible interrupts
PID hash table entries: 512 (order: 9, 2048 bytes)
GMT Delta read from XPRAM: 0 minutes, DST: on

My response to that was to attempt to build a kernel using 'genkernel all'. The kernel compiled just fine, but now I'm having problems emerging hotplug. Specifically, libusb-0.1.12, upon which hotplug depends. When i attempt the emerge, I get this error:

touch: setting times of '/var/tmp/portage/libusb-0.1.12/.unpacked': function not implemented

!!! ERROR dev-libs/libusb0.1.12 failed.
Call stack:
ebuild.sh line 1546: Called dyn_unpack
ebuild.sh line 709: Called die

!!! IO Failure -- Failed touch .unpacked in /var/tmp/portage/libusb-0.1.12

JoseFX advised that I try using the 2.6.19 kernel which I will build overnight tonight, assuming I can figure out how to get it and make it happen. If anyone has any insight into the preceeding two problems, I would love to hear about it.

Cheers,
Alex
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Tue Jan 09, 2007 3:46 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Gentoo on PPC.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum