Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] *-sharp-2.8.2 fails to compile on amd64 (stable)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message

Joined: 07 Aug 2003
Posts: 8
Location: Belgium

PostPosted: Tue Jan 16, 2007 2:27 pm    Post subject: [SOLVED] *-sharp-2.8.2 fails to compile on amd64 (stable) Reply with quote

UPDATE: ok, seems the answer popped up elsewhere

pielgrzym wrote:
johnnymac, try emerging it with older automake:

WANT_AUTOMAKE=1.9 emerge gtk-sharp

It worked for me ;)

I'm not exactly the guru, so I'd sure like to know how to find out which packages in stable I have to emerge with an older version of automake 8O

Emerging gnome for amd64 failed telling me "Failed to run automake".
It gave me the same after emerge -uD --newuse world and revdep-rebuild even (which shows nothing).

So trying:


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] dev-dotnet/gtk-sharp-2.8.2  USE="-doc" 0 kB

fails with the following message:


 * Running aclocal ...                                                    [ ok ]
 * Running libtoolize --copy --force --automake ...                       [ ok ]
 * Running aclocal ...                                                    [ ok ]
 * Running autoconf ...                                                   [ ok ]
 * Running autoheader ...                                                 [ ok ]
 * Running automake --add-missing --copy ...                              [ !! ]

 * Failed Running automake !
 * Include in your bugreport the contents of:
 *   /var/tmp/portage/gtk-sharp-2.8.2/temp/automake-18628.out

!!! ERROR: dev-dotnet/gtk-sharp-2.8.2 failed.
Call stack:, line 1546:   Called dyn_unpack, line 708:   Called src_unpack
  gtk-sharp-2.8.2.ebuild, line 51:   Called eautoreconf
  autotools.eclass, line 94:   Called eautomake
  autotools.eclass, line 195:   Called autotools_run_tool 'automake' '--add-miss
ing' '--copy'
  autotools.eclass, line 256:   Called die

!!! Failed Running automake !
!!! If you need support, post the topmost build error, and the call stack if rel

My make.conf:

CFLAGS="-march=athlon64 -O2 -pipe"

USE="aac amr beagle emacs glitz java mono mozbranding moznocompose moznoirc
     moznomail mozsvg mplayer nas nntp nvidia real realmedia samba tcl theora
     usb vnc wma xvid -arts -esd -kde -qt3 -qt4"
VIDEO_CARDS="nvidia vesa vmware nv"
LINGUAS="en nl"

I have no custom settings in /etc/portage.
Any ideas as to why this is happening?
Should anyone want, I have the autoheader,autoconf, automake logs from the failing emerge.

Thanks a bunch,
can't wait to get going again with tomboy!


PS: mono is already installed & working at version

[ebuild   R   ] dev-lang/mono-  USE="X nptl" 0 kB
Back to top
View user's profile Send private message

Joined: 27 Jun 2003
Posts: 4923
Location: Gothenburg, Sweden

PostPosted: Wed Jan 17, 2007 10:51 pm    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads in favour of the above mentioned thread. Please also see e.g. bug 161410. There are a few similar bugs.
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum